Help us improve Answers HQ! Take Survey No, Thanks

Re: Origin blurry

by Blaster7R
Reply

Original Post

Accepted Solution

Origin blurry

★★★ Newbie

The Origin GUI appears blurry on my UHD screen after the last update. How do I get it to my native screen resolution?

Message 1 of 10 (3,741 Views)

Accepted Solution

Re: Origin blurry

Community Manager

Can you try the following @SharpeXB to see if it improves how it looks.

 

You need to navigate to Origin.exe Properties > Compatibility > Change High DPI Settings > High DPI Scaling Override > Override High DPI Scaling behaviour

 

Tick the Checkbox and set 'Scaling performed by' to 'Application'

 

Let me know how you get on.

Darko

View in thread

Message 3 of 10 (3,652 Views)

All Replies

Re: Origin blurry

★★★ Guide
Hi

looks like same issue as rest of the 4K problem.

locate Origin.exe propertise on it and turn off HIGH dpi.
ofc. you have close client first.

( scale issue ) check own Graphic settings first, that it is native screen resolution.

the blurry is best guess that, i doubt you have change other things that also can do this. some monitor has app that adjust to viewers point so it should be better but with scale and dpi , it could look odd or blurry sametime. most never do this, and just keep standard.
Message 2 of 10 (3,709 Views)

Re: Origin blurry

Community Manager

Can you try the following @SharpeXB to see if it improves how it looks.

 

You need to navigate to Origin.exe Properties > Compatibility > Change High DPI Settings > High DPI Scaling Override > Override High DPI Scaling behaviour

 

Tick the Checkbox and set 'Scaling performed by' to 'Application'

 

Let me know how you get on.

Darko

Message 3 of 10 (3,653 Views)

Re: Origin blurry

★★★★ Novice

@EA_Darko wrote:

Can you try the following @SharpeXB to see if it improves how it looks.

 

You need to navigate to Origin.exe Properties > Compatibility > Change High DPI Settings > High DPI Scaling Override > Override High DPI Scaling behaviour

 

Tick the Checkbox and set 'Scaling performed by' to 'Application'

 

Let me know how you get on.

Darko


that worked for me...     but every time I launch i have to click off a origin warning 

Message 4 of 10 (3,168 Views)

Re: Origin blurry

Community Manager

What is the warning you are seeing @Blaster7R?

 

The more info we have the better we can help.


Darko

Message 5 of 10 (3,037 Views)

Re: Origin blurry

★★★★ Novice

@EA_Darko wrote:

What is the warning you are seeing @Blaster7R?

 

The more info we have the better we can help.


Darko


"You are about to launch Origin in Windows Compatibility Mode.  Please disable Compatibility Mode if you encounter any issues"   

 

I have windows 10 Pro with a 4 K monitor 

Message 6 of 10 (3,009 Views)

Re: Origin blurry

Community Manager

You should be able to fix this issue @Blaster7R by right-clicking on the Origin application and then go into the compatibility tab. From here ensure that nothing is selected, if you have anything ticked or selected remove it.


Once done restart the system and you should hopefully be good to go.

 

Darko

 

Message 7 of 10 (2,981 Views)

Re: Origin blurry

★★★★ Novice

@EA_Darko wrote:

You should be able to fix this issue @Blaster7R by right-clicking on the Origin application and then go into the compatibility tab. From here ensure that nothing is selected, if you have anything ticked or selected remove it.


Once done restart the system and you should hopefully be good to go.

 

Darko

 


unfortunately nothing was selected..  :/ 

Message 8 of 10 (2,954 Views)

Re: Origin blurry

★★★★ Newbie

to prevent the compatibility settings from showing everytime click change stings for all users

Message 9 of 10 (2,311 Views)
Highlighted

Re: Origin blurry

★★★★ Novice

Yep..  that fixed it... 

 

 

Message 10 of 10 (2,104 Views)