Help us improve Answers HQ! Take Survey No, Thanks

Re: Origin Download Button Not Working

by xlaviudanegrax

Original Post

(Mac) Download Button Not Working for Sims 4 packs

[ Edited ]
★★★★★ Newbie


I am trying to install all The Sims 4 Expansion Packs on my Mac, but when I click download nothing happens. I really just want to play my game.


edited title to make it easier for others to find the thread.  -puzzlezaddict

Message 3 of 314 (8,667 Views)

Can't download packs

★★★ Novice

I needed to re-download the sims 4 and that goes with all of the packs as well but I only could download sims 4 but not the packs that I bought. I would tap the download button and nothing happened. I hope that anyone could know why this is happening. Thank you.


(I also use a Mac but this never happened before)


Message 1 of 314 (8,464 Views)

Re: Can't download packs

★★★★ Novice

Same thing with me. Brand new laptop, brand new origin.


I ran Origin Reset but I can't download any of my expansion packs. The button just sits there after I tap it. 

Message 2 of 314 (8,455 Views)

Re: Origin Download Button Not Working

★★★★★ Newbie

I have used the reset tool and I uninstalled the game multiple times

Message 4 of 314 (8,632 Views)

Re: Origin Download Button Not Working

@xlaviudanegrax  Try launching the game itself.  That usually causes Origin to start downloading any missing packs.


If that doesn't help, reset Origin again, and when you open it, uncheck the box to automatically keep Origin and games up to date.  Then hover over your username, select Application Settings, and under Application (the first header), scroll down to Client update and enable auto game updates.  Quit Origin and open it again, and see whether your packs start downloading.  Again, if they don't, try loading the game and see if the downloads start.


I don't work for EA. I'm just trying to help fellow players with their games.
Message 5 of 314 (8,627 Views)

Re: Can't download packs

★★★ Novice

Having the same problem - can't download any packs and the download button does nothing. I called tech support and none of the suggestions they gave helped.

Message 6 of 314 (8,437 Views)

Unable to download expansion pack

★★★ Novice

Recently bought Snowy Escape and went to download it but nothing appeared, not even an error message. I called EA support and tried everything from clearing cache, repairing sims, and uninstalling and reinstalling origin but nothing worked. This problem has never occurred before so no idea what's wrong. Please help, thank you!

Message 7 of 314 (8,429 Views)

Re: Origin Download Button Not Working

★ Novice
@puzzlezaddict this helped me! Thank you!!
Message 8 of 314 (8,604 Views)

Re: Origin Download Button Not Working

★★★ Newbie

I'm having the same issue, I have uninstalled Origin, restarted my computer, played a little, and still not downloading. I got two expansion packs and they are not downloading. 

Message 9 of 314 (8,596 Views)

Re: Origin Download Button Not Working

★★★★★ Newbie

@puzzlezaddict I tried it and it's not working. It worked on my Windows laptop though.

Message 10 of 314 (8,592 Views)
Twitter Stream