Help us improve Answers HQ! Take Survey No, Thanks

Compatibility mode Origin Start up

by Kidlat_FielGPC
Reply

Original Post

Accepted Solution

Compatibility mode Origin Start up

★★★★ Novice

Just recently whenever launching origin it will popup an error saying "You're currently running windows in compatibility mode. Please disable compatibility mode if you encounter any issues" Last time I checked origin was not running in compatibility mode. Does anyone have a fix for this?

Message 1 of 35 (54,380 Views)

Accepted Solution

Re: Compatibility mode Origin Start up

EA Staff

@83AnimaL83 This message seems to also pop up if you are running Origin with Admin rights. If you wish that to stop, you can disable this if you right click the Origin.exe file (default location: C:\Program Files (x86)\Origin), select 'Properties' and then 'Compatibility' tab - make sure that 'Run this program as an admin.' is unticked.

View in thread

Message 4 of 35 (59,169 Views)

All Replies

Re: Compatibility mode Origin Start up

EA Staff

@Kidlat_FielGPC You can check if you are running Origin in compatibility mode if you right click an Origin short cut, select properties and then the 'Compatibility' tab.

Message 2 of 35 (54,258 Views)

Re: Compatibility mode Origin Start up

★★★★ Novice

I have this exact problem, after origin made its last update i now get this message, I don't use a short cut, i use the start with windows option provided by origin, i have checked all options for "compatibility mode" and they are not in use,

Message 3 of 35 (54,239 Views)

Re: Compatibility mode Origin Start up

EA Staff

@83AnimaL83 This message seems to also pop up if you are running Origin with Admin rights. If you wish that to stop, you can disable this if you right click the Origin.exe file (default location: C:\Program Files (x86)\Origin), select 'Properties' and then 'Compatibility' tab - make sure that 'Run this program as an admin.' is unticked.

Message 4 of 35 (59,170 Views)

Re: Compatibility mode Origin Start up

★★★★ Novice

I've the same issue, except that I dont have admin rights ticked and I dont have any compatibility thing on. It just happens automatically whenever I open Origin. 

Message 5 of 35 (54,098 Views)

Re: Compatibility mode Origin Start up

[ Edited ]
★★★★★ Expert

@Nebeleixis

 

I think you can try a Clean Boot In this case, they can be eliminated as the source of the problem...

 

-you need to press the key combination: “Windows Key + R”;
In the “Run” window, type the message “msconfig” without quotes;
-you need to left click on the “OK” button;
Select “General” tab, from the toolbar and chose the feature called “ Selective startup”;
-uncheck the box found in the left of the message: “ Load startup items”;
Select “Service” tab, from the toolbar;
-check the box in the left of message: “Hide all Microsoft services”;
Left click on the “Disable all” button, found on the lower-right side of the window;
Left click on the “OK” button;
-a new message box will prompt on your display. Left click on the “Restart” button in order to restart your operating system.


NOTE save any open files and close all programs before restarting your computer.

Greetings

@yahel_1

I am just a gamer wich trying to help another gamer.
I do not work for EA.

Spoiler
Constantly updating drivers is a good way to Mess'up the whole system. ""Don't fixit with it if it ain't broken!
My Opinion is no more important or right than yours.- Ask, and it shall be given you.

 

Retired champion.
Message 6 of 35 (54,089 Views)

Re: Compatibility mode Origin Start up

[ Edited ]
★★★★ Novice

i do run in compatibility coz of the bad graphics handling of BF4  and i do NOT wanna see this message everytime

 

plz fix the bad graphics handling of BF4 so i can turn compatibility off again

 

or add a checkbox for Do not show compatibility message at start.

 

Message 7 of 35 (54,041 Views)

Re: Compatibility mode Origin Start up

★★★★★ Newbie

while not running it as administrator works for stopping the popup from appearing, it doesn't make sense, it's not compatibility mode and a popup should not appear. It should be possible to run in admin mode without a compatibility popup bugging you. 

Message 8 of 35 (53,752 Views)

Re: Compatibility mode Origin Start up

★★★★ Novice

Since the last patch of Origin, this bug has appeared. I am not running in compatibility mode but get the message. I tried to communicate with EA Customer Experience to chat with a game advisor but never got an answer from them. They sent me an email stating an advisor would communicate with me but they did not follow up. This is bad service but it is to be expected. They should close the site if they do not want to answer. Also, it would be nice if EA could advise us that it is a bug instead of creating chaos by not advising their clients who are trying all sort of fix that don't work.

 

Anyway, don't worry, it's just another EA bug... 

Message 9 of 35 (53,189 Views)

Re: Compatibility mode Origin Start up

[ Edited ]
★★★★ Novice

Hello,

 

I had this problem as well and someone helped me out. Check this registry key folder:

 

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

 

I had a bunch of Origin games in there (mostly command and conquer). I removed those entries and reboot my computer. Now Origin doesn't display the warning anymore. I guess this is some faulty programming on EA's side. Individual game compatibility settings shouldn't affect the Origin executable. My problem is fixed now.

Message 10 of 35 (53,109 Views)