Help us improve Answers HQ! Take Survey No, Thanks

60 FPS workaround without speeding the game up.

by psychic717
Reply

Original Post

Highlighted

60 FPS workaround without speeding the game up.

[ Edited ]
★ Apprentice

So it seems that a modder at Guru3D found a workaround to the 30 fps cap.

Just add these commands to the game's shotcut directory or at Command Line Arguments (Game Properties):

 

-GameTime.MaxSimFps 60 -GameTime.ForceSimRate 60

 

Beware that for a smooth gameplay, you need to have solid 60 fps all the time, or else the game will speed down when your framerate decreases.

So you need to be sure you have a system above the recommended requirements.

 

Source

 

EDIT:

After testing the game at 60 fps, I can tell you that it is very nice at this framerate but it only gives you a smooth gameplay at certain areas of the game.

There are situations where the game is clearly not well optimized, and because of that, this is not a solution. There are major FPS drops that just need to be fixed, and that keep this workaround to be a good alternative.

 

The game needs a patch to fix those fps drop issues.

And the developers need to provide us with "real" 60 fps without slowing/speeding the game.

 

Message 1 of 25 (35,805 Views)

Re: 60 FPS workaround without speeding the game up.

★★★★ Novice

Cool find. WIll try it later

Message 2 of 25 (35,724 Views)

Re: 60 FPS workaround without speeding the game up.

[ Edited ]
★★★★ Novice

That guy is my new hero and so are you. :D

Just gonna have to back off my max AA a bit on my GTX780 and then I'll be good to go. Tried it just now and it stutter-pauses if you drop below 60 but it looks and plays sooooo much better.

Message 3 of 25 (35,686 Views)

Re: 60 FPS workaround without speeding the game up.

★ Apprentice

@SCHUMI4EVER wrote:

That guy is my new hero and so are you. :D

Just gonna have to back off my max AA a bit on my GTX780 and then I'll be good to go. Tried it just now and it stutter-pauses if you drop below 60 but it looks and plays sooooo much better.


I'm glad you're happy.

Btw, how were you using AA?

Message 4 of 25 (35,680 Views)

Re: 60 FPS workaround without speeding the game up.

[ Edited ]
★★★★ Novice

I was forcing it through the control panel...still lots of jaggies but I think it worked since it did seem to start looking better....

 

 

Or not...just turned AA off and no difference at all...must have just been my desperately wanting a better game that seemed to make it look nicer.

Damn that means even a GTX780 isn't enough for 60FPS all the time (poor GPU use by the game though since it erratically jumps between 40-50% and then occasionaly spikes to 60+% but never above 70%.

Message 5 of 25 (35,649 Views)

Re: 60 FPS workaround without speeding the game up.

[ Edited ]
★ Apprentice

@SCHUMI4EVER wrote:

I was forcing it through the control panel...still lots of jaggies but I think it worked since it did seem to start looking better....

 

 

Or not...just turned AA off and no difference at all...must have just been my desperately wanting a better game that seemed to make it look nicer.

Damn that means even a GTX780 isn't enough for 60FPS all the time (poor GPU use by the game though since it erratically jumps between 40-50% and then occasionaly spikes to 60+% but never above 70%.


Yeah, forcing AA through the control panel doesn't work. Maybe with nvidia inspector, but I wasn't able yet.

Your GPU is more than enough. The problem is that the game is not optimized enough to provide stable fps.

I have a GTX 770 and never reach 80% of usage, but still have fps drops. Which means the game has some issues.

 

And I think those will be fixed in a patch (and 30 fps cap too).

I'm hopeful.

 

Message 6 of 25 (35,629 Views)

Re: 60 FPS workaround without speeding the game up.

[ Edited ]
★★★★ Novice

To what do I add these lines exactly ?

Message 7 of 25 (35,568 Views)

Re: 60 FPS workaround without speeding the game up.

★★★★ Guide

Make a shortcut to NFS14.exe, right click the icon and select properties. Add the command line after where the file is specified, it will look something liked this: "E:\Spel\Need for Speed(TM) Rivals\NFS14.exe" -GameTime.MaxSimFps 60 -GameTime.ForceSimRate 60

 

Start up the game and then it should run in 60FPS. However, this isn't something I'd recommend. If you would be able to keep it at 60fps steady across the whole map, you'd need a SLI or xfire setup of any of the highrange cards. I've got an EVGA GTX780 Classified which is overclocked to 1293Mhz on the core and that still isn't enough.

 

It's fluent and nice for the most part with a few dips here and there which is somewhat ok. The problem is when you reach the bay city area on the nort western part of the map (think it's there anyways). It will plunge down to 35 and as you know, without the forced simrate, the game will go at double speed, however, since this simrate isn't dynamic, it will affect you the other way around. Your car will go slower and you're steering will be so unresponsive it feels like you're driving a 14 tonne tank.

 

This is just a command line for making it try and run at 60fps. It's not something that works, if it where, then it would have been implemented in the game already. So unless you got a super powerful rig, I'd suggest you keep your game at original when you've tried it out. Pursuing or fleeing from someone in that area will be troublesome, trust me.

Message 8 of 25 (35,465 Views)

Re: 60 FPS workaround without speeding the game up.

[ Edited ]
★ Apprentice

I agree with you, just like I said on the "EDIT" part .

 

The one thing I'm not sure you are correct is the part where you say people need super powerful rigs.

I have a gtx 770 and I experience those fps drops, but my card never reaches 70% of usage. Which means the game has optimization problems with the GPU or CPU.

Message 9 of 25 (35,460 Views)

Re: 60 FPS workaround without speeding the game up.

★★★★ Novice

i dont want to spoil anyones fun with the 60 fps unlock. But this only seems to work. 

There are still many things that behave strange when running the game on 60 fps:

While the cars now dont run at double speed anymore other things like the target animation of the emp (bar getting smaller) still do.

Also you seem to take and do more damage on crashes. These are only a few of the things i noticed so far.

 

The most shocking part is that this even is possible, because with all those settings you can destroy any mplayer balance for this game.

It is also shocking that we need to resort to those things in order to get a smoothly playable game. lets hope they fix it soon.

Message 10 of 25 (35,439 Views)

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help