Help us improve Answers HQ! Take Survey No, Thanks

Re: CPU 100% Bug

by Keberro
Reply

Original Post

Accepted Solution

CPU 100% Bug

★★★★ Novice

Today downloaded NFS,

 

The game looks good on ultra 2560x1440. 144fps.

 

The only problem is my cpu is running 100% this must be a bug.

 

I contacted the support, but they don't listen and the expert clearly doesn't have a clue what he's talking about.

 

Hope someone can help me out. or the game get patched soon. 

 

I got a I7 6900K with a 1080TI strix. 32gb ddr4 3000mhz ram

 

Should run perfectly fine like all other games on ultra.

 

 

Message 1 of 6 (11,797 Views)

Accepted Solution

Re: CPU 100% Bug

★★★★ Novice
I had a similar issue too. Running on a GTX 970m 3gb, i7-6700HQ, 16gb ddr4 ram at 1080p with medium-ultra settings

I fixed the issue by going into the Nvida control panel and forcing NFS payback to run using my GPU in the program settings (it was set as automatic). My CPU usage went from 97-100% to about 65-70%. Doing this same process on other games fixes numerous other performance issues too

The problem about this is that I'm doing this on a laptop, and I've heard from others that people with desktop GPU's can't really perform the same solution, as their version of the Nvidia control panel won't let them select which rendering device is forced to run for a specific application

Hopefully this in some way helps Standard smile

View in thread

Message 2 of 6 (17,534 Views)

All Replies

Re: CPU 100% Bug

★★★★ Novice
I had a similar issue too. Running on a GTX 970m 3gb, i7-6700HQ, 16gb ddr4 ram at 1080p with medium-ultra settings

I fixed the issue by going into the Nvida control panel and forcing NFS payback to run using my GPU in the program settings (it was set as automatic). My CPU usage went from 97-100% to about 65-70%. Doing this same process on other games fixes numerous other performance issues too

The problem about this is that I'm doing this on a laptop, and I've heard from others that people with desktop GPU's can't really perform the same solution, as their version of the Nvidia control panel won't let them select which rendering device is forced to run for a specific application

Hopefully this in some way helps Standard smile
Message 2 of 6 (17,535 Views)
Highlighted

Re: CPU 100% Bug

★★★★ Novice
@McYeeter I hope you are still active. I got this problem with Battlefield V currently, could you give me a step by step instruction how to perform this?
Message 3 of 6 (1,714 Views)

Re: CPU 100% Bug

★★★★ Novice
@Keberro Hey man

1. Right click anywhere on your desktop, and go to the Nvidia Control panel.

2. Inside the Nvidia control panel, on the left side there are a number of menus in blue text underneath "select a task." In the "3D Settings" category, click on manage 3D settings.

3. Once you click on that, the rest of the window to the right will open up the 3D settings. Underneath "I would like to use the following 3D settings," click the "Program settings" tab.

4. Once that tab opens up, in "1. Select a program to customize:" click on "Add". Another window will eventually pop up, asking you to select a program. Find the Battlefield V application, click it, then click "Add selected program" at the bottom of the window.

Btw, after clicking on "Add," the window may take some time to open, so don't panic if it seems like it isn't opening.

5. After clicking on "add selected program," the window will close. Now back in the Nvidia Control panel you should see that under "1. Select a program to customize:" now has the Battlefield V .exe selected in the drop down box. If you see it selected, then so far so good.

6. Now under "2. Select the preferred graphics processor for this program:" click on the drop down box, and choose the "high performance Nvidia processor" option.

7. Once your done that, click "apply" at the bottom right hand corner of the control panel. Give it a few seconds to make the changes, and you should be good to go.

This solution works for pretty much any game but it doesn't always work for everyone. Let me know if it worked for you.
Message 4 of 6 (1,708 Views)

Re: CPU 100% Bug

★★★★ Novice
@McYeeter Thanks for replying this fast.

I've hoped the fact that I am not using a laptop wouldn't affect the solution for me, but it does. This apparently works only for laptops.

However, I managed to find a solution by updating my chipset, at least I think this solved the issue, so if anyone else is reading this and has not an integrated GPU, going through outdated drivers might be your best bet.
Message 5 of 6 (1,683 Views)

Re: CPU 100% Bug

★★★★ Novice
@Keberro Yes, unfortunately for whatever reason desktops can't perform that same solution. I'd bet there'd be maybe a different way to do it and achieve the same result but I'm not sure.

Good to hear you found something that works! Have fun bro.
Message 6 of 6 (1,663 Views)

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help