Microstuttering + choppy, skipping frametimes

by StricMatic
Reply

Original Post

Microstuttering + choppy, skipping frametimes

★★★ Newbie

I've hardly seen anyone else mention this, but I'm having big, game-ruining microstuttering issues with the PC version of the game on Steam (haven't played the original). Regardless of the graphics settings, as I've tried everything from Ultra to Low presets in 1080p.

 

I have a 4-core i5 4590 CPU @ stock 3.3-3.7 GHz from 2014 and a Geforce 1660 Ti GPU, plus 16 GB of RAM. The rig seems more than enough (especially the GPU) to run this slightly updated 10-year old game maxed out, as it exceeds recommended specs, and most of the time it runs at a locked 60 fps. Also installed the latest 457.09 Nvidia drivers that specifically provide 'Day 1 support' for NFS HP Remastered.

 

However, quite regularly, especially in cases where there's multiple cars and large roadside objects on screen (e.g. night-time police event in the rain with loads of highway traffic), I get a regular microstuttering issue where the framerate only drops by about 5 fps or so, but the choppy, unsmooth feel of the stutters is really a joykiller and makes the game way less fun.

 

I've searched online and found threads about the original game from 2010 having identical problems on modern PCs with Windows 10, where it seems to put all the load on the first core (CPU 0) of a multicore CPU while ignoring the others. Apparently, in the original game, that could be solved by alt-tabbing out of the game and changing the CPU affinity in Task Manager - unchecking the CPU 0 core and only keeping cores 1-3 active, so the game would split the load between the other three cores.

I've tried that yesterday and while it initially seemed to work, I encountered a different, even worse issue twice after about 20 minutes of playing - the game would suddenly drop down to 3-4 fps, until I left the current race to the main menu and restarted the event.

 

I'll do some more testing, especially with MSI Afterburner to check whether the game's really only using one core of my CPU properly, but right now, it seems I'm stuck with either frequent microstuttering or the CPU affinity bypass, which works fine at first but seems to completely * the game after 15-20 minutes, prompting me to restart the event or the whole game.

 

What a mess, I sure hope they didn't actually carry over the same issue from the original game. What worries me most is that I don't see other users with the same problem in any threads online, and the Known issues from EA section doesn't even acknowledge the problem.

 

And please don't tell me my 4-core i5 4590 is the issue, it's above recommended specs and the problem is the same on both Low and Ultra settings, Fullscreen or Borderless, Vsync On or Off (I've tried all). I doubt it's a particular graphics setting that's causing it.

Message 1 of 19 (6,753 Views)

Re: Microstuttering + choppy, skipping frametimes

★★★ Newbie

Interesting note - after a bit more testing, I've discovered that the CPU affinity 'solution' (unchecking CPU 0 and only leaving CPU 1-3 checked) definitely gets rid of the stutters and frame drops (even on maxed Ultra setttings), but it WILL eventually (after about 10-15 minutes of playing) lead to the game's framerate completely tanking into the single-digit numbers at some point. What's peculiar is that at that moment, my wireless Xbox One controller will also lose connection and the game will ask me to reconnect it. I'm not sure whether the controller losing connection is a result of the game slowing to a 3 fps crawl, or the cause of it. Maybe the CPU 0 core handles something with regards to the controller and turning it off leads to the controller losing connection and tanking the game's framerate?

 

Changing power usage to Maximum performance in Nvidia CP didn't help (it was initially set to the default Maximum power, not Adaptive, for me).

Honestly, I don't know what to do now. Stuttering is really obvious and experience-ruining on certain tracks, and the CPU affinity trick works for about 15 minutes, but then seems to completely choke out the game, with me needing to restart the event or the whole game...

Message 2 of 19 (6,730 Views)

Re: Microstuttering + choppy, skipping frametimes

Community Manager
Hi @StricMatic,

Thanks for testing and sharing the results with us. We'd recommend running a Clean boot and then trying it again with a wired controller minus the MSI Afterburner. MSI Afterburner has been known to cause some issues while playing games and removing that plus a clean boot and connected controller may do the trick.

Could you add what PSU and how old it is in your reply please?

Thanks,

- EA_Lanna
Lanna.png____________________________________________________________


*Accept as Solution button- If a post answers your question please let us and other players know by hitting this button.
*Me Too button - 'Me Too' helps us track how many players are also experiencing that issue. Definitely make use of this button.
*XP button - Say Kudos and help players 'Level Up' by giving them XP for helpful posts.


Please only DM me if I've asked you too, or in the case of highly sensitive content. General questions/issues/topics are best shared on the forum where others can take part/benefit from the responses/solutions/workarounds

Message 3 of 19 (6,701 Views)

Re: Microstuttering + choppy, skipping frametimes

★★★ Newbie

Some more feedback:

 

I didn't have MSI Afterburner running when I experienced the issues, but just in case, I removed it entirely from my system and restarted the PC. Still the same problems.

 

I've also tried (according to advice from one player with similar problems) setting both my Nvidia GPU to Max Peformance mode (from the default Max Power) in Nvidia Control Panel, and setting my whole PC's power plan from Balanced to Maximum performance in the Windows 10 settings. Neither helped. The only reason I tried the latter is because I had a sort of similar, Windows 10 related issue a few years ago where the game Bulletstorm; Full Clip Edition would refuse to run at more than 50 fps with Vsync on, but changing the system's power plan to Max performance would fix it and enable the proper locked 60 fps framerate.

 

I can't try a wired Xbox One controller yet, but I tried playing the game with the keyboard for a bit (controller wasn't even turned on) and experienced the same problems, so it doesn't look like it has anything to do with the controller.

 

Can't check my PSU's specs right now (I'll open the case and post them later) but it's just over 6 years old at this point, like the CPU and the motherboard. I doubt it's a failing power supply, since I've been running newer and more demanding games (like Doom Eternal) perfectly in recent months.

 

Also, another important symptom I forgot to mention - the game's menus that feature in-game roads as backgrounds seem to be locked at 50 fps most of the time, and in some cases, even the actual gameplay is stuck at 50 fps (though the frame limit is 60) until I restart the game or change the graphics settings from one preset to another and back. 

The magic CPU affinity trick (disabing the first core of the 4-core CPU) that I mentioned REALLY temporarily fixes all of the above issues - both the stutering/frameskipping and the 50 fps cap in the menus, but unfortunately always causes the game to almost completely lock up after 15-20 minutes. It's the EXACT SAME issue and workaround that was apparently noted by many players in the PC version of the original game, only the solution isn't quite working for me.

 

Hopefully this is enough information and the development team can get a good patch out to fix it, it's really souring my experience. And it's even more grating that it seems to be an issue carried over from the 2010 PC release.

Message 4 of 19 (6,684 Views)

Re: Microstuttering + choppy, skipping frametimes

★ Novice

you dont have to worry you are not alone with this, i have an i5 9400f, gtx 1660 and 16gb ram and i can barely touch 60 in game, this game is just poorly optimised, im surprised no one talks about this.

Message 5 of 19 (6,647 Views)

Re: Microstuttering + choppy, skipping frametimes

★★★★ Pro
@StricMatic Try Windowed mode rather than full screen,my PC has a i5-3470 and also stucks at 50 FPS in full screen but can reach 60 in Windowed mode.
Message 6 of 19 (6,634 Views)

Re: Microstuttering + choppy, skipping frametimes

★★★★ Novice

same issue here

 

i5 8300H

8GB RAM

GTX 1050 4GB

 

I hope EA will soon release a fix for this issue

Message 7 of 19 (6,626 Views)

Re: Microstuttering + choppy, skipping frametimes

★★★ Novice

I've put the game on the backburner until this is fixed as it's really impacting my enjoyment. Please fix this. This was already a fairly premium price for a very low-effort 'remaster'. At least have it run well.

Message 8 of 19 (6,589 Views)

Re: Microstuttering + choppy, skipping frametimes

[ Edited ]
★★★ Newbie

Okay, so I seem to have found a working solution for this. Fiddled around with the CPU affinity trick and some other settings, and I've been able to find a combination of settings that allowed me to have three 1h+ sessions with no stuttering, a perfect, constant 60 fps and no game freezes in the last couple of days. It also seems to simultaneouly solve the problems with skipping/stuttering/crackling audio that is likely the result of the same issue.

 

Alt-tabbing out of the game when it's been running for a few minutes in the main menu and turning off the first CPU core  (CPU 0) in the game's CPU Affinity settings in Task Manager while leaving the rest active is indeed the fix that solves the issue. Keep in mind that this is apparently the very same bug that the original HP2010 had on PCs (at least the Steam version), so the Remaster just carried over this issue and it's likely a part of the game's core code. I really hope and urge the EA representatives on this forum to forward this issue to the dev team, as it's a 10-year old bug that hasn't been properly addressed, even though it's well documented on various online forums.

 

Other settings: 

 

- Power usage in in Nvidia Control Panel's profile for the game: High Performance (might be a placebo, but I'll just leave it as such)

 

- in Launch Options for the game in Steam's Library, I put '-high' (High CPU priority for the Steam version of the game)

 

- Borderless Windowed mode in-game

 

- Vsync On in-game (didn't force it through Nvidia CP)

 

- Max quality graphics preset in-game

 

 

The best part is that the secondary problem with the game totally locking up after 10-15 minutes while using the CPU affinity solution is apparently also gone, but I'm not sure what party of my toying with different other settings solved it. It might have been the High CPU priority launch option in Steam, as I'm pretty sure that after adding it, I've had no further issues. If you don't have the Steam version of the game, maybe try increasing the game's CPU Priority from Normal to High or Real-time in Task Manager (besides unchecking the CPU 0 core in Affinity).

 

Overall, while the game is now very enjoyable and I can finally start playing it properly, I really feel like PC players shouldn't be expected to try all these ad-hoc solutions themselves, and for the Remaster to be plagued by the same obvious technical issue that the original game had a decade ago.

Message 9 of 19 (6,546 Views)

Re: Microstuttering + choppy, skipping frametimes

★★★ Novice

Nice find!

 

You can use a program called Process Lasso to permanently set the priority and affinity. Like you say though, this is not a permanent solution and needs to be fixed.

Message 10 of 19 (6,508 Views)
Twitter Stream

ea-play-promo-splash

What's EA Play?

New name, new look, same great benefits: EA Access and Origin Access are now EA Play.

Get more info on the change here.

ea-help-promo-3

Forget your EA Account ID or password?

Reset, update, or link your account information.

View more on EA Help