Mass Effect Legendary Edition on Origin does not start

by drone-ah
Reply

Original Post

Accepted Solution

Mass Effect Legendary Edition on Origin does not start

[ Edited ]
★★★★★ Newbie

Hi,

 

I am in the UK, preloaded the game, and is now past 16:00 BST at which point the game was supposed to launch. The game on Origin says that it's been recently released, but I am unable to start the game. When clicking play, Origin minimises itself and a second or two later restores the window.

 

I went into the game directory and started the launcher manually. It shows up in task manager for a couple for seconds, goes back to the Origin Window and then disappears again.

 

I tried the same with the ME1, ME2 and ME3 executables with the same outcome.

 

I have also tried verifying the game data with no benefit!

 

Edit: Updated graphics (Nvidia) driver, with no help

 

Is anyone able to help?

 

Thanks

Message 1 of 288 (14,440 Views)

Accepted Solution

Re: Mass Effect Legendary Edition on Origin does not start

[ Edited ]
★ Guide

EDIT: Since the 7 June Update I have updated the custom launcher to v2.1. Some people are still using it to unlock all of the language options that aren't always available in the original BioWare launcher. See the NexusMods page for new version and the list of changes. I will no longer be updating this post.

 

7 June Update:

The 7 June update for Mass Effect Legendary Edition removed the dependency on the AVX instruction set in the launcher, so this custom launcher should no longer be needed for people with older CPUs. This leaves the custom launcher largely obsolete, but nonetheless I will leave it up in case anybody still has a use for it.

 


 

Old post:

 

TLDR: If the launcher is not running it may be due to old CPUs not supporting the AVX instruction set. The launcher itself requires AVX instruction set support, but the games themselves do not. Below is linked a custom launcher to bypass the original launcher. (If you can already get the original launcher to run and show up, but when you try to launch the Mass Effect games themselves you get a different problem, then this will not be a solution for you. However, there may still be other solutions you could try.)

 

launcher_gui.png

 

My mother was having the problem with the lack of AVX instruction set support on her older hardware, but I managed to help her by replacing "MassEffectLauncher.exe" with a custom one of my own. As the games themselves do not use AVX instructions, only the launcher, bypassing the launcher seems to work. I'm pleased to report ME1 runs very well on my mother's older hardware now. 

 

Below I have linked to an AutoHotkey script that achieves this. You will need to compile the AutoHotkey script to an EXE file, or if you prefer you can just use the pre-compiled EXE provided in the download link below. If you want to compile the script yourself, thankfully it is quite easy. You will need to download AutoHotkey and install it, and then copy & paste the script code linked below into a fresh text file. Name it "MassEffectLauncher.ahk".

 

Right-click the "MassEffectLauncher.ahk" file that you have just created and choose to compile the script. You can choose 'Compile Script' or 'Compile Script (GUI)'. The first option will create the EXE in the same folder (you may need to hit F5 in your file explorer for it to show up), whereas the GUI allows you to specify where to create the EXE. Once you have compiled script, make sure your EXE is called "MassEffectLauncher.exe". Do NOT simply rename the "MassEffectLauncher.ahk" script file to an EXE file, as this will not work.

 

In your "Mass Effect Legendary Edition\Game\Launcher" directory, rename your original "MassEffectLauncher.exe" (i.e. the one that shipped with the game) to "MassEffectLauncher.exe.original", so that you have a backup of the game's original launcher. You should be able to restore the original launcher anyway by verifying the game's integrity through Steam, but it is still probably best to make a backup. Then replace the original EXE with the new one that you compiled from the AutoHotkey script. The custom launcher MUST be placed in this directory; it should NOT be placed anywhere else or run from anywhere else. When it is in the correct place, just run the game through Steam or Origin like you normally would.

 

Do NOT try to double-click on the EXE and run it manually as this will probably not work. You would see the custom GUI appear, but when you try to run a Mass Effect game, it will likely not launch. As I said, just run the game through Steam or Origin like you normally would.

 

IMPORTANT: Do NOT set the EXEs to run as administrator (by going to the files' Properties  Compatibility options). This includes the custom "MassEffectLauncher.exe" and the game EXEs themselves ("MassEffect1.exe", etc.). This has been confirmed by multiple people to make it NOT work.

 

Link to the AutoHotkey script (v2):

https://pastebin.com/ygt4DPP2

 

Link to download the pre-compiled custom launcher (also includes the AutoHotkey script file if you wish to compile it yourself):

BioWare's original launcher has some options to change the language and subtitle font size etc. Version 2 of this custom launcher also allows you to change the language. If you want to change the subtitle font size you should be able to edit it in the Commandline section of the script and recompile.

 

Hope this helps some people. Hopefully BioWare will patch this soon anyway.

 

PS. When you choose a Mass Effect game to run from my custom launcher, the launcher will hide itself but it will still be running. When you exit the game, the launcher will show up again. I tried to replicate the behavior of BioWare's original launcher here. However, this means that you need to be sure to close the launcher using the x button when you're finished playing, if you don't want Steam to constantly count you as playing the game when you're not. (You can also close it from the system tray by right-clicking the AutoHotkey icon and choosing 'Exit'.) It's harder to miss this with BioWare's original launcher, since it's a full-screen application with music etc., but with the custom launcher you could easily idle with it running in the background for hours without realizing it. This isn't harmful or anything, but like I say, Steam would then count you as playing the game for those hours when you are not.

 

Perhaps it would have been better if instead the custom launcher were to exit itself when you quit the game, but I'm not going to update it now. If anybody wants that behavior, it would be easy to edit the script, replacing 'Gui, Show' (below the 'RunWait' lines) with 'ExitApp', and recompile.

 


 

Does this custom launcher:

 

  • Still allow achievements to still be earned?
    • Yes, achievements still work fine.
  • Still keep Steam updated with hours played?
    • Yes, see the paragraphs above.
  • Bypass the Origin stuff?
    • No, if you own Mass Effect Legendary Edition on Steam you still need to have Origin running. Origin will still launch automatically if it is not running though.

View in thread

Message 122 of 288 (30,878 Views)

All Replies

Re: Mass Effect Legendary Edition on Origin does not start

[ Edited ]
★★★ Novice

EDIT: This is still getting XP somehow so I should note I am working around this by temporarily adjusting my antivirus settings following the post by @Utimer which is here.


 

Exactly the same experience.

 

I've tried resetting Origin's cache, creating a new user (someone reported this worked for them), running each of the executables separately (with or without administrator), disconnecting peripherals (SteelSeries wireless headset, wired mouse), closing various services, checked the firewall settings for the launcher.

 

No change - everything happens exactly as the OP described in each case. No error, just returned to Origin after a couple of seconds.

Message 2 of 288 (14,358 Views)

Re: Mass Effect Legendary Edition on Origin does not start

★★★★★ Novice

Similar issue here, the intro screen loads then dumps me back to the desktop using origin also, i get your issue if i set the launcher to run as admin

Message 3 of 288 (14,348 Views)

Re: Mass Effect Legendary Edition on Origin does not start

[ Edited ]
★★★★ Novice

Im on my third install all i get is, Theres a problem with your game setup, please reinstall your game, and thats all it does, uninstalled, reinstalled same over and over. Tried administrator, verified the files, it even gives me the compatibility option to choose what operating system to run it under, dont usually get that much with new games. Im lost. Bet its something like a missing DLL. The deleting origin files suggestion did nothing at all.

Message 4 of 288 (14,334 Views)

Re: Mass Effect Legendary Edition on Origin does not start

★★★★ Novice

i don't even get to the main menu

Message 5 of 288 (14,270 Views)

Re: Mass Effect Legendary Edition on Origin does not start

★ Apprentice

Same issue here, quick screen free then back to Origin.

Verifying did not help, neither did Administrator

Message 6 of 288 (14,240 Views)

Re: Mass Effect Legendary Edition on Origin does not start

★★ Apprentice

I finally got the game to launch by disabling fraps and the game loads.

Message 7 of 288 (14,197 Views)

Re: Mass Effect Legendary Edition on Origin does not start

★★ Novice

Same here on EA Desktop, opening cinematics play, then back to EA Desktop

 

Faulting application name: MassEffectLauncher.exe, version: 2.0.0.47902, time stamp: 0x6088ef8c
Faulting module name: MassEffectLauncher.exe, version: 2.0.0.47902, time stamp: 0x6088ef8c
Exception code: 0xc0000005
Fault offset: 0x00000000002b2ef3
Faulting process id: 0x13b4

Message 8 of 288 (14,195 Views)

Re: Mass Effect Legendary Edition on Origin does not start

★★★★★ Newbie
@badboy6423 Wish I had fraps installed - just so I could try disabling it and running the game :-/
Message 9 of 288 (14,133 Views)

Re: Mass Effect Legendary Edition on Origin does not start

@drone-ah 

 

Please create a DxDiag in text file format and post it with your next reply. You can do that  with the "Choose file" button at the bottom right corner of the reply window. 

 

 

+++++++++++++++++++++++++++++++++++++++++++++++++++++

This is a players helping players forum, I don't work for EA.
Dies ist ein Spieler helfen Spielern Forum, ich arbeite nicht für EA.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Death closes all: but something ere the end, Some work of noble note, may yet be done, Not unbecoming men that strove with Gods.
Ulysses - Alfred, Lord Tennyson
Message 10 of 288 (14,038 Views)
Twitter Stream

ea-play-promo-splash

What's EA Play?

New name, new look, same great benefits: EA Access and Origin Access are now EA Play.

Get more info on the change here.

ea-help-promo-3

Forget your EA Account ID or password?

Reset, update, or link your account information.

View more on EA Help