Help us improve Answers HQ! Take Survey No, Thanks

Re: stuck on activation

by Aseya

Original Post

stuck on activation

★★★★ Novice


just bought MA3 through origin and I installed it fine, tried to start the game and the ME3 screen comes up with a wheel but then I cant progress past that.
If I try to close it its asking me if I want to close ME3 activation
The origin thinks Im running the game and the play button is greyed out even if I close the ME3 until I restart the computer

I am running origin as an administrator, I tried to start the game as administrator, uninstalled and reinstalled the game, done repair install ( that says everything is fine), disabled origin in game - makes no difference
Im not being impatient  either I left it overnight, still stuck on same screen but Origin shows I played the game for 8 hours

I have reinstalled origin couple of weeks ago and searching through internet my issues seems something people encounetred when game weas released not now?

Message 1 of 7 (459 Views)

Re: stuck on activation

★★★★ Novice

any ideas? still have the same problem

Message 2 of 7 (455 Views)

Re: stuck on activation

[ Edited ]
★★★★ Novice

can someone please answer


I have emailed EA Customer Experience on 17.11 and even though they acknowledge an opened inquiry I still have not received a response

Message 3 of 7 (443 Views)

Re: stuck on activation

★★★★ Novice

this is getting ridicoulous - to this date no one bothered to reply  and when I try to call Im just put on hold without any idication of how long Im supposed to wait, I gave up after 15 min

Message 4 of 7 (422 Views)

Re: stuck on activation

Community Manager (retired)

Have you tried repairing the ME3 install? (Right click on ME3 in Origin and click "Repair Install")


Message 5 of 7 (398 Views)

Re: stuck on activation

[ Edited ]
★★★★ Novice

yes, it made no difference as there were no missing or currupt files

I have recently reinstalled origin so I could patch up the game and this morning ran repair install again but it makes no difference (again no error found)

I really believe there is nothing wrong with the game instalation, this is purely origin issue as the game does not get past activation screen and I can't manually activate it either by trying to redeem the code as it says it has been used already

Message 6 of 7 (391 Views)

Re: stuck on activation

[ Edited ]
Community Manager

Hi aseya,


Have you already tried to play the game in Offline Mode? Please try that and let us know if you get the activation screen in Offline Mode as well.




Message 7 of 7 (369 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help