Help us improve Answers HQ! Take Survey No, Thanks

"Unable to authorize the listed DLC"

by scottbert

Original Post

"Unable to authorize the listed DLC"

[ Edited ]
★★★★ Newbie

I started up ME3 to play this weekend's challenge, and was greeted with this message at the main menu, listing all my DLC.

It says to "login to my Alliance account" but I'm clearly connected, both in Origin and in the game. If I go to multiplayer, all the DLC content is gone.


How do I fix this? It was fine last weekend!


Additional problem: Even with non-DLC classes, I can't earn points towards the weekend challenge (it doesn't show up on my N7 profile)


Tried repair install and check for updates on ME3 and all DLC. No help (no updates or corrupted files were found)


Tried reinstalling ME3. No help.


Tried deleting Origin's files and making it redownload. Still no help.


I did notice one thing though: It used to be, that the menu appeared *before* the 'checking DLC' message. Now though the background appears, the menu doesn't appear until after. Does this indicate anything?


Update: Tried to connect again at about 4:40 eastern time on Saturday and it mysteriously worked!

Update: Tried to connect at 11PM and the problem is back again.

Message 1 of 12 (13,377 Views)

Re: "Unable to authorize the listed DLC"

★★★★ Newbie

Update: Tried again at 2PM Monday, and it worked, twice. Noticed unusual behavior:


When ME3 is working properly, the 'connecting to EA' message doesn't appear until the menu screen -- and then the menu opens and the checking DLC message appears, twice.

When ME3 is _not_ working, the 'connecting to EA' message appears on the title screen -- and then the 'checking DLC' message appears on the menu screen twice, before the menu appears and the 'unable to authorize...' message appears. Does this help indicate what was going wrong?

Message 2 of 12 (13,311 Views)

Re: "Unable to authorize the listed DLC"

★★★★ Novice

I have same problem. Did you find any solution yet?

Message 3 of 12 (13,252 Views)

Re: "Unable to authorize the listed DLC"

★★★★ Novice

I'm having this problem as well, "From Ashes" is the DLC that wont authorize for me and im trying to see if Origin Live help can help fix it..... Not going well so far

Message 4 of 12 (13,244 Views)

Re: "Unable to authorize the listed DLC"

★★★★ Novice

I've "talked" with them via Live Chat 4 times. No help for me.

Message 5 of 12 (13,239 Views)

Re: "Unable to authorize the listed DLC"

★★★★ Novice

Having the same problem.

Tried uninstalling and re-installing but the game still insists that "ME3: Content Patch DLC Module  Multiplayer Expanion Pack 4" can't be authorized.  Can play in multiplayer but the portions of DLC from Pack 4 are unavailable.


Still trying things here and there, but am unsure where to go from here.

Message 6 of 12 (13,218 Views)

Re: "Unable to authorize the listed DLC"

[ Edited ]
★★ Guide

I experienced this and eventually solved it.  Here is my long winded explanation:


It seems like many of you have hit that issue.


The Original Poster, Scottbert appears to have run into a different issue.

I read somewhere else in here that somebody ended up getting a profile back in sync by unplugging their Ethernet cord during the checks, and then reconnecting it after the checks finished, usually with an error message.  After doing that a few times, they eventually returned to normal behavior and did not have to do the unplugging anymore.

Message 7 of 12 (13,214 Views)

Re: "Unable to authorize the listed DLC"

★★★★ Newbie

I had the exact same problem. I did two things which solved it:


1. In Origin right click on Mass Effect 3 and select: CHECK FOR UPDATE and then REPAIR INSTALL.


I can't confirm whether this part of the process is essential or not, but I did do it. But part 2 is key:


2. Log into using your origin ID. Just doing this should help. But just in case look around for anything that synchronises your game and galactic readiness data.


Anytime I get the "CAN'T AUTHORIZE DLC" message I got to and just log in again and it solves the problem. I've had to leave the tab open. It's tedious, but so far it's worked every time.


I did not need to reinstall Mass Effect 3.


I hope this helps!

Message 8 of 12 (12,367 Views)

Re: "Unable to authorize the listed DLC"

★★★★ Newbie

I kept having the same issues; however, even when I had social.bioware logged in, it still wouldn't work for me.  I am able to get it to work by disconnecting myself from the internet.  I don't reconnect myself as I don't play multiplayer too much so I'm not sure how to work with that.  I hope this helps.

Message 9 of 12 (12,289 Views)

Re: "Unable to authorize the listed DLC"

★★★ Newbie

Thanks- I had tried this a couple times also reparing the install before after playing without problems for a few months and nearly at the end but it did not work at first. I had to resort to disconnecting internet but finally today it worked for some reason when it had not before. Had lost DLC on both ME2 and ME3 on the repair this time after Origin installer was updated.


Just to let people know if you tried this before and it did not work, it might now.

Message 10 of 12 (12,000 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help