Help us improve Answers HQ! Take Survey No, Thanks

Mass Effect 3 DLC Authorization

by hooberschmit1

Original Post

Mass Effect 3 DLC Authorization

★★★★ Newbie

The problem is conveyed as followed:

"Unable to authorize the listed DLC. Please log in to the Alliance network with the account used to purchase the DLC. ME3 Content Patch DLC module, Omega, Multiplayer Expansion Pack 4."


Please note that i have successfully dowloaded, installed and played both From Ashes and Leviathan DLC. Furthermore i have attempted to repair the only one i give a crap about: Omega (as i payed 15 bucks for it) and it says that none of the whiles were corrupt and it is up to date.


My suspicion, after looking at a wide variety of other forums and seeing no solution, is that it has something to do with the content in question not being properly linked to my Bioware Social Network Account. Both From Ashes and Leviathan are listed under my registered game content but the DLC packages in question are not. Seeing as i log in with my Origin email and password, it should auto register, but even though it does not, i can not do it manually, as origin fails to provide product codes for Purchased DLC. 


Please reply with a real solution or at least humor my percieved dead end solution.

Message 1 of 3 (2,417 Views)

Re: Mass Effect 3 DLC Authorization

★★★★ Newbie

I had the exact same problem. I did two things which solved it:


1. In Origin right click on Mass Effect 3 and select: CHECK FOR UPDATE and then REPAIR INSTALL.


I can't confirm whether this part of the process is essential or not, but I did do it. But part 2 is key:


2. Log into using your origin ID. Just doing this should help. But just in case look around for anything that synchronises your game and galactic readiness data.


Anytime I get the "CAN'T AUTHORIZE DLC" message I got to and just log in again and it solves the problem. I've had to leave the tab open. It's tedious, but so far it's worked every time.


I hope this helps!

Message 2 of 3 (2,006 Views)

Re: Mass Effect 3 DLC Authorization

★★★★ Novice
I have the same problem too but I found out that the problem is actually "From Ashes" pack. It's buggy. I know for sure from several conversations with support as well as trying the game with the pack installed and then again without it. It's fun if you can get it to work but overall not worth the effort.
Message 3 of 3 (1,036 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help