Help us improve Answers HQ! Take Survey No, Thanks

Re: Mass Effect 3 Configuration Utility crashes on startup with new hardware

by lmt_7816
Reply

Original Post

Mass Effect 3 Configuration Utility crashes on startup with new hardware

[ Edited ]
★★★★ Novice

Running PC version through Origin. I have a 5 year old workstation running Dual Xeon X5460 Quad core processors on an S5000XVNSASR Intel workstation board running Windows 7 SP1 64bit enterprise edition. Evga GTX 260. Creative XFI-Fatlity Sound card The configuration utility works fine. I just loaded my new server running Dual 8 core Xeon E5-2687W-V2 processors on a W2600CR2 Intel workstation board with Windows 7 Ultimate SP1 64bit. Evga GTX-760. Creative-Z Soundcard. The utility crashes on start up.. I've disabled the  UAC. Tried running in all other compatibility modes. Running directly from the EXE as administrator. Any suggestions?

 

Let me update this post with a little more detail.

 

The Mass effect 3 configuration utility crashes on startup in my new system. It works fine on the system I am replacing. Mass Effect 3 is completely up to date. I have uninstalled and reinstalled the game twice. The game runs but the graphic settings are low and need to be configured with the utility.

 

I am Running PC version Mass effect 3 through Origin. I have a 5 year old Intel workstation running Dual Xeon X5460 Quad core processors on an S5000XVNSASR Intel workstation board. Running Windows 7 SP1 64bit enterprise edition. Evga GTX 260 video card. Creative XFI-Fatality Sound card. The configuration utility works fine.

 

I just loaded my new server running Dual 8 core Xeon E5-2687W-V2 processors on a W2600CR2 Intel workstation board with Windows 7 Ultimate SP1 64bit.

Evga GTX-760 video card. Creative-Z Soundcard.

The utility crashes on start up.

I've tried starting the utility with a base load of windows and no windows updates. Utility crashes

I've also Tried starting the utility after all windows updates and SP1 applied. Utility crashes

I've disabled the  UAC. Tried running in all other compatibility modes. Running directly from the EXE as administrator.

I am thinking the Utility does not know how to handle hardware this new and powerful though I can't decide if it is the new video card or the actual computer hardware.

Any ideas?

Message 1 of 2 (675 Views)
Highlighted

Re: Mass Effect 3 Configuration Utility crashes on startup with new hardware

★★★★ Novice

I do realize this is years old, but I have the same issue and have solved it.  I have a 44 Core Xeon machine (22 physical cores and 22 hyperthreaded for a total of 44).   Many of these older games don't manage this many cores well and actually will run faster/better with some cores disables.  My previous machine was a dual Xeon with 12 cores per processor for 24 total and no games had issues, thus I approximated that.  Using msconfig, under "Advanced Option" button, I limited the machine to 22 cores (the physical number) and voila! it runs fine!  This was also true for Far Cry 4 to even load.  Once cores dropped, it runs fine.

 

 

Message 2 of 2 (289 Views)

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help