Help us improve Answers HQ! Take Survey No, Thanks

Game crashes when I go to Sparta

by Fictitiousfable
Reply

Original Post

Accepted Solution

Game crashes when I go to Sparta

★★★ Novice

Every time i go to the Sparta system to go find Liara (i think that is her name), my game crashes due to an error. I am playing this on PC. How do i fix this?

Message 1 of 166 (5,219 Views)

Accepted Solution

Re: Game crashes when I go to Sparta

Community Manager (retired)

And just like that, we should have a fix in place. Those of you who are impacted by this, can you right click on your game tile and click Repair Game? You should be asked to download ~600 megs of extra data. If you're not, please let me know.

 

Thanks!

View in thread

Message 147 of 166 (3,596 Views)

All Replies

Re: Game crashes when I go to Sparta

★ Novice

I'm having this issue as well when trying to land on Edolus to find Liara. I've tried validating files, completely reinstalling, running as admin and am out of ideas. The error that I'm getting is a General Protection Fault and references the kernel.dll file in my C drive even though I'm running the game off of my F drive (this may be common, I have no idea). If you figure out your issue or if anyone has solved this before, please post here because I'm just stuck and can't progress in the game. Specs if they are useful at all:

 

i5-3450

8gb ddr3 1600 RAM

MSI Lightning GTX 680

Windows 7 64-bit

Message 2 of 166 (5,159 Views)

Re: Game crashes when I go to Sparta

★★★ Novice

I tried contacting EA through their chat. They said they would put me in contact with a specialist over email.

Message 3 of 166 (5,157 Views)

Re: Game crashes when I go to Sparta

[ Edited ]
Hero

System specs are always useful with this kind of problem.

General Protection Fault is usually associated with graphics hardware and drivers. I recommend you do a clean installation of your Geforce drivers. You may want to try a previous driver version just in case the latest Nvidia driver have compatibility issues.



CCP Hero Banner - Red.png


Message 4 of 166 (5,143 Views)

Re: Game crashes when I go to Sparta

★★★ Newbie

I, too, am having this problem whenever I go to the planet in the Sparta system, but I'm also having it whenever I try to go to land on Luna. I really have no idea what to do to fix this problem. The error message I received mentioned something wrong with C++

 

"Runtime Error

Program C:\Program Files... [etc.]

This application has requested the Runtime to terminate it in an unusual way. Please support the application's support team for more information."

Message 5 of 166 (5,122 Views)

Re: Game crashes when I go to Sparta

★★★ Newbie

Same problem here, crashes at travelling to Luna and 1 other place I have encountered so far, everywhere else I travel, no issue.

 

Changed graphics from Ultra to default, can't really think of anything and this is hell of a frustrating, EA PLEASE!

 

Win7 64bit

16GB RAM

 

Motherboard : Intel DH67BL
http://www.intel.com/content/www/us/en/motherboards/desktop-motherboards/desktop-board-dh67bl.html

Processor : Intel Core i3-2100 CPU @ 3.10GHz
http://ark.intel.com/products/53422/

Hard Drive : Corsair SATA3 SSD 240GB 6Gb/s
http://www.corsair.com/ssd/force-series-3-ssd/force-series-3-240gb-sata-3-6gbps-solid-state-hard-dri...

Graphics : Leadtek Winfast PX9600 GT S-FANPIPE 512MB
https://www.google.co.za/?gws_rd=cr#bav=on.2,or.r_cp.r_qf.&fp=d28c137a71273f3c&q=px9600gt+s-fanpipe

PSU : Cooler Master Elite Power 400 RS-400-PSAR-13
http://www.coolermaster.com/product/Detail/powersupply/elite-power/elite-power-400w.html

Message 6 of 166 (5,103 Views)

Re: Game crashes when I go to Sparta

★ Apprentice

Same problem at Sparta and Hawking Eta... it is occurring all the time i get little video before the travel (at Sparta you see Shepard listening to an sos, in hawking eta you see shepard talking with Alliance)... please help.

Message 7 of 166 (5,093 Views)

Re: Game crashes when I go to Sparta

★★★★ Novice

I have experienced the same thing, some planets freezes the game at the loading screen and gives me a message saying:

 

General protection fault!

 

History:RaiseException() Adress = 0x76c3c42d (filename not found) [in C:\Windows\syswow64\KERNELBASE.dll]

 

and a bunch more text after that

 

 

There seems to be only certain planets that does this and they are Edolus (Sparta) and Solcrum (Grissom) 

 

I have not tried Luna yet but I suscpect I will have the same problem there since others here seems to have it.

 

 

I have reinstalled the game, tried deactive it in Origin, tried changing graphic settings but nothing seems to work

Message 8 of 166 (5,078 Views)

Re: Game crashes when I go to Sparta

★★★ Novice

I've also been having this problem. At first I thought it was the game and so I uninstalled and tried to go there again and it keeps crashing. Every time it does, now, I get the set of error messages that there's a General Protection Failure. Given that I can't insert or link a photo, I can't share which ones exactly, it seems, and I can't find an error log file or a dmp log file in order to share the specific error messages I'm getting.

 

I'm running an ASUS with an NVIDIA graphics card. I have 24 GB of RAM, with an Intel Core i7-4700HQ CPU @ 2.40 GHz. I'm running the 64 bit version of WIn8.1 as well. If I've uninstalled and reinstalled the game more than once and I keep getting the same error messages every time, so therefore it's not me and it's the game. Is there a fix for this? I'm getting pretty darn frustrated by this and Googling this issue isn't helping me at all.

Message 9 of 166 (5,067 Views)

Re: Game crashes when I go to Sparta

[ Edited ]
★★ Novice

I just bought the trilogy and am having the same problem. Any attempt to land on Edolus in the Sparta system causes a general page fault. I also tried landing on Presrop and the result was the same. I've tried this with other save files and I still get a general page fault. I must have tried to land on Edolus over 25 times trying the various suggested fixes I could find. This is has been quite frustrating and I'm nearing the point  of giving up and requesting a refund. This is simply unacceptable.

 

System specs list below in case they might help.

i7-3770k

MSI Z77-GD65 (Realtek onboard audio)

MSI R7850

Windows 7 x64 (fully updated)

 

Edit: Graphics driver version is latest 14.12.

Message 10 of 166 (5,056 Views)
Twitter Stream