Help us improve Answers HQ! Take Survey No, Thanks

Masterworks stopped working?

by Razzakx
Reply

Original Post

Highlighted

Masterworks stopped working?

★★★ Novice

I got a few Masterworks on my Storm and today they seem to just stop working.

 

Elemental Rage Assault Rifle - 5% Elemental damage on hit stacks to 20. This was GREAT to buff up my gear casts. I could see the buff being applied on the left and the damage increase was amazing. Now the buff no longer applies. Doesn't show up on the left and no damage boost.

 

Gunslinger's Mark - Weak point damage while hovering. It used to have a percentage but now it says 0% and it's clear that it no longer works. Ground and hover weak point damage is the same.

 

Mark of Ruin - While Q recharges, increase E dmg by 20%. This just doesn't work either. No buff is shown on the left, and no damage boost.

 

I've tested this a BUNCH in freeplay with different setups for the past 2 hours just now. They just don't work and render my build pretty useless. Guess I'll play another class for now?

Message 1 of 8 (240 Views)
Highlighted

Re: Masterworks stopped working?

★★★★★ Novice

I noticed the Gunslingers Mark today after the patch. Yesterday: +60% weakpoint damage while hovering.  Today: +0%, really disappointing. Come on guys, you need to QA your patches

 

Message 2 of 8 (196 Views)
Highlighted

Re: Masterworks stopped working?

★ Pro

Elemental Rage buff counter on left was definitely working today for me.

Message 3 of 8 (187 Views)
Highlighted

Re: Masterworks stopped working?

★ Apprentice

Yeah, there's a few masterworks that just don't work.  There's a colossus mortar that should detonate combos, but doesn't, and an automatic pistol that should get a damage buff to itself and melee when shooting enemies up close, but doesn't.  It's pretty sad when you find these interesting weapons and abilities, only to learn they literally don't even function.

Message 4 of 8 (178 Views)
Highlighted

Re: Masterworks stopped working?

★★★★★ Apprentice

There are a lot of items that just don't work. Special Arms Ammo Comp that gives 30% damage boost to Hpistols , Mpistols Autos and nade launchers has zero effect after multiple tests.. It's a pain loading and unloading to see what works.. A target dummie or shooting range in the hanger would help a lot with this.

Message 5 of 8 (171 Views)
Highlighted

Re: Masterworks stopped working?

[ Edited ]
★ Apprentice

@Liquidous_Flame wrote:

There are a lot of items that just don't work. Special Arms Ammo Comp that gives 30% damage boost to Hpistols , Mpistols Autos and nade launchers has zero effect after multiple tests.. It's a pain loading and unloading to see what works.. A target dummie or shooting range in the hanger would help a lot with this.


Wait, special arms doesn't work?  I never checked it, but that's the only non-MW component I have because I thought I couldn't live without it!  I'm both upset that it doesn't work, and excited for when/if it ever does.

 

Edit:  After running some tests, I can say with complete certainty that Autocannons (at least) do receive a damage bonus from the component.  Maybe it was fixed recently?

Message 6 of 8 (165 Views)
Highlighted

Re: Masterworks stopped working?

★★★★★ Apprentice

My Veteran's Furor from Elemental Rage works. At least the buff is there. But Gunslinger's Mark shows 0 as well.

Message 7 of 8 (154 Views)
Highlighted

Re: Masterworks stopped working?

★ Apprentice

They specifically replied to one, it was just not working as intended. I'm not sure about the others but you can probably assume, they're broken too.

 

https://twitter.com/BenIrvo/status/1099474691603992576

Message 8 of 8 (152 Views)
Twitter Stream