Help us improve Answers HQ! Take Survey No, Thanks

Showhiddenobjects command failed

by Nollster01
Reply

Original Post

Highlighted

Showhiddenobjects command failed

★★ Novice

When I type in bb.showhiddenobjects and bb.showliveeditobjects it says that the command failed. I know my cheats are working because moveobjects works. This is the first time I’ve tried using showhiddenobjects on my Mac, please help!

Message 1 of 12 (3,976 Views)
Highlighted

Re: Showhiddenobjects command failed

★★ Guide

@Nollster01  Some cheat codes require testingcheats to be enabled. So before you type bb.showhiddenobjects or bb.showliveeditobjects, type in the following:

 

testingcheats on

 

OR

 

testingcheats true

 

This should make it work.

 

Good luck!

Message 2 of 12 (3,967 Views)
Highlighted

Re: Showhiddenobjects command failed

★★ Novice

I tried that, as well as disabling all of my mods, restarting the game, restarting my computer, and typing The cheat in live, build, and buy mode.

Message 3 of 12 (3,961 Views)
Highlighted

Re: Showhiddenobjects command failed

★★ Guide

@Nollster01 After disabling or removing (or even adding) mods you should also always delete your localthumbcache file that is located in your Sims 4 documents folder as it may hold information of previously installed mods or CC. Don't worry, the game will automatically generate a clean new one. Now, if that still doesn't work, you may have to repair your game through Origin. Hope this helps!

 

Message 4 of 12 (3,949 Views)
Highlighted

Re: Showhiddenobjects command failed

★★ Novice

Thank you, I’ll do that as soon as I’m done with my build.

Message 5 of 12 (3,943 Views)
Highlighted

Re: Showhiddenobjects command failed

★ Pro

@Nollster01  Where you type in the cheats can make a difference at times too.  And this hasn't been mentioned yet.

 

So have you tried typing them in at the map screen before you enter the lot?  The two that @DMDragonCT mentioned are normally used and work in both and build modes but I've had problems with them too from time to time.  Typing them in before you enter the lot seems to help sometimes and if they are still not active when you enter the lot, type them in again and they might activate then.  It's worth a try anyway.

Message 6 of 12 (3,912 Views)
Highlighted

Re: Showhiddenobjects command failed

★★ Novice

That doesn’t seam to work, usually when I try it just says something along the lines of ‘unable to do command’ 

Message 7 of 12 (3,905 Views)
Highlighted

Re: Showhiddenobjects command failed

[ Edited ]
  1. Type in testingcheats on and hit Enter. You should get a message that cheats have been enabled.
  2. Type in bb.showhiddenobjects and hit Enter.
  3. Type debug into the search box in build/buy mode then click the top option Text Search for: “debug”. The items should now show up in the catalogue.

I’m on a Mac too Standard smile

 


The Sims 3 Mac Help Thread - | - The Sims 4 Mac Help Thread -
- The Sims 3 Mac super patch 1.67 - | - Origin Reset Tool for Mac -
- I am not affiliated with EA in anyway -
Apple Signature.png
Please do not PM me unless I ask you to
Message 8 of 12 (3,872 Views)
Highlighted

Re: Showhiddenobjects command failed

[ Edited ]
★★ Guide

@Nollster01 I'm sorry to hear that none of the above has worked for you.

 

I've done some reading and came across something that might work: Apparently, for some unexplained and exceptionally weird reason, there seems to be an issue for some players whereby these codes don't work on certain lots. So, as a last-ditch effort, you could try going to different lots and activate the cheat codes there. Once activated they should work until you leave the game (or deactivate them manually), so after doing that, you can go back to the lot you actually want to use those codes on. I know this sounds bizarre, but it's worth a shot.

 

Let me know if this works!

 

EDIT: @Bluebellflora Sorry, you posted yours while I was writing mine, so please disregard the first statement of this post.

Message 9 of 12 (3,866 Views)
Highlighted

Re: Showhiddenobjects command failed

[ Edited ]
★★ Apprentice

I remember running into a very similar issue last month! Did you try the commands in live mode (instead of build mode)? For me, that did the trick! For some reason, I couldn't get the 'testingcheats on' to work otherwise. (The not being able to get the 'testingcheats on' command to work, makes the other commands fail and that was my issue.)

 

/good luck!

Message 10 of 12 (3,816 Views)
Twitter Stream