Help us improve Answers HQ! Take Survey No, Thanks

My sims won't get married glitch!

by sevvstaa

Original Post


My sims won't get married glitch!

★ Novice

Help! I have a problem which is complicated so please read carefully!
So in my sims 4 game, I have a big amount of custom content but not A LOT like some simmers. First of all, my 
sim would not propose when my couple have both full bar friendship and full bar romance. When I pressed propose nothing happened. It must of been a gitch. Instead, I tried something else. I waited for the romance festival to come in town then I made the boy sim do the "moment of heat proposal" at the romance festival and it worked. Then I wanted them to get married so I planned a wedding ad everything was going great until when I pressed get married, the same glitch happened. I looked up similar problems but they all said get rid of cc and test it again. I was trying to put my mods folder into my desktop but instead it disappeared! When i went in my game all my mods were still there then I checked my mods folder and it was empty! It doesn't make any sense! Since I know my mods are still there but hidden, should I find a different way to get my sims married instead of actually deleting all of my cc? Or should I wait for the romance festival again and do the "moment of heat marriage"? Please help!

Message 1 of 3 (662 Views)

Re: My sims won't get married glitch!

★★★★ Expert

It appears that the game does not use the folder you thought it did. Here is an easy way to find out which folder your game is using:

Message 2 of 3 (650 Views)

Re: My sims won't get married glitch!


Because the recent patch broke a lot of mods and cc many things are possible when it comes to glitching if you have mods or cc still in your game. If it took extra incentive for this particular couple, it may be possible that you could first try something like making sure they serenade each other or somehow get to flirty or very flirty before clicking 'get married' (make sure all of their needs are in the green also), or experiment with this just at home or something (elope now). 


Otherwise you can make sure you have removed all mods and cc first (as @jpkarlsen directed for where to do so), and see if they will marry then. If it works you can then re-add your mods/cc one at a time to see if anything is causing glitching there. It also couldn't hurt to do a game repair if there is something buggy going on. 

SheriGR ☕ –  I don’t work for EA.
Me Too – if you also have this problem – first post on thread has this button
XP – for helpful comments (& to help others 'level up')
Mark As Solution – to help others find the answer to the issue now & in the future
Message 3 of 3 (638 Views)
Twitter Stream