Help us improve Answers HQ! Take Survey No, Thanks

Unravel Two: game doesn't work (crash on first cut scene - AMD Phenom II)

by AgoutiRat

Original Post


Re: UnravelTwo crashes after first cutscene

★★ Novice

it doesn't seem to be just a phenom II problem. might be an amd problem in general. i have an amd a10 7850k and the game crashes to the desktop even before arriving at a cutscene. black screen whileloading and suddenly i'm back at the desktop.


which somehow speaks against your "minimum requirements" since the 7850k is on par with the fx 4350, including support for sse4.x.

Message 11 of 18 (3,913 Views)

Re: UnravelTwo crashes after first cutscene

[ Edited ]
★★ Novice

Hey guys, I was able to find a workaround fix for this, for those of us with the AMD Phenom II/SSE 4.2 Issue.  Despite what some have said, your hardware is most likely more than good enough to play this game!  Here's the workaround and how it came to be:



I figured since Valentine's Day is coming up, there isn't a much sweeter game to couch co-op on than a game like Unravel.  When we first found out about it last fall, it was like a little yarn fist clenching a stone punched me in the gut when the game failed to load fully.  We were about to give up our hope of playing, when I remembered a similar issue when we tried to play 'Little Nightmares" a few months prior. While I  found the LN solution at the time, it was too late to try and we pretty much forgot about it, so this was still new territory.
I got the idea to see if, just maybe, it might work here on Unravel 2.  I was expecting failure, but lo and behold, we were playing! 
It might look like a lot of hoop-jumping at first, but once you do it, you'll find it's very simple. (You can even make a batch file if you're feeling adventurous).



To get this working, you'll need to use Intel's SSE4.2 Instruction set, which you can get directly from Intel (below). (Even though you have an AMD chip, it will still run.  It can be summed up as an SSE4.2 emulator.)
1) Download the newest version for Windows here:
(some people report AV complaining about this, but ours didn't have an issue. Either way, it's from Intel direct)  (around 17.5MB)
2) Create a folder in your C drive.
    Name it something short so it's easy to navigate to in the command prompt in the next step.  I'll use "UV2fix" as my example folder.
3) Unzip the file you just downloaded ("sde-external-8.16.0-2018-01-30-win.tar.bz2") to the folder you just created. 
    (It might look unfamiliar, but WinRAR will recognize that extension)
4) Open up your command prompt with administrator privileges (via right click context menu on cmd.exe shortcut)
5) In your command prompt console, navigate to the folder you just created:
    Enter "cd C:\UV2fix(no quotes, of course)
6) Do not close your command prompt console window, navigate back to your desktop and start Unravel 2
    Wait for the start screen. (alt+tab)
7) Go back to your command prompt window(alt+tab)
8) Enter "tasklist" (no quotes). Look for your 'Unravel2.exe' and make note of it's PID (the number right next to it, which will be different every time)
9) Enter "sde -attach-pid ####"  
 (replace ####'s with the number that you made note of in the previous step) (no quotes). If you entered it correctly, you won't get a message and it  might look like nothing happened. *Leave this window open.*
10) Go back to Unravel 2.  
You will probably experience some temporary loading lag either during the title screen or intro, so don't panic!).  Once you get to the gameplay it clears up where it is fully playable.  We were able to enjoy the entire game without issue other than the initial hiccup and maybe a minor hiccup near another load scene (It's been awhile since we played, I can't remember for sure). 
As far as we know, there is still no fix for this issue on Unravel 2 or Little Nightmares.  This isn't a matter of the CPU or GPU not being able to handle the game itself!  Even with this SSE4.2 stuff having to be emulated, the gameplay itself performed as flawless as Unravel 1 did on this machine. You'd think these studios could patch this without a whole lot of effort.
Credit goes to Steam user Jezze for posting the original workaround for Little Nightmares, which they themselves adapted from Steam user Disky's Resident Evil 7 workaround

Let me know if you've had any success or issues. Enjoy the game!



(Edit: Thank you to whoever approved this and let the post go through)

Message 12 of 18 (3,478 Views)

Re: UnravelTwo crashes after first cutscene

★★★ Newbie

This fix works. I went through the troubleshooting process before finding this fix. The intel emulation is the solution and the intel link is legit. You will have to use this solution anytime you play Unravel 2, but it's worth it. Not sure why EA can't patch this. Game now works as good as it does on my other lesser PC.

Message 13 of 18 (3,233 Views)

Re: UnravelTwo crashes after first cutscene

★★ Newbie

hi, my command prompt says 'sde' is not recognized as an internal or external command, operable program or batch file.

i dont know if thats normal, but either ways, it didn't work. now my game crashes at the first cutscene and force closes rather than freezing into a black screen Frown

Message 14 of 18 (3,034 Views)

Re: UnravelTwo crashes after first cutscene

★★ Newbie

BTW, i'm completely sure i followed the instructions correctly, ive tried leaving only command prompt and unravel2.exe open, exiting steam, and other clients, etc.

Message 15 of 18 (3,033 Views)

Re: UnravelTwo crashes after first cutscene

[ Edited ]
★★ Novice

Hey.  Sorry for any confusion, I'll do my best to help you out.  If it's not recognizing SDE as a command, I don't see how it would've changed the outcome of your situation since that file is not actually getting run. The original problem reported at the very start of this thread (and in the title) was about that game crashing at the first cut scene.  My memory is bad and I don't have the AMD machine I used with me to confirm if my issue was right at the cutscene or where yours originally was beforehand, but I'm pretty sure it was the cutscene. 


Since it's not recognizing the SDE command, it really sounds like one of three things;


1) You're not in the same directory within the command prompt that the Intel package was extracted. Make sure it didn't extract to a subfolder. The installer package comes with a subfolder within it. I failed to mention that in my instructions and you should manually move it from the subfolder it creates into your UV2fix folder or rename it to something short just to keep it clean, since the subfolder has a long awkward name to type in. Alternatively, you can navigate to the directory it creates as is (with the CD command) if you prefer. Either way, it has to be run from the folder the files reside in. I had forgotten about the automatic subfolder until I found the old screenshot).


2) Less likely, you might not have extracted the package and just have the downloaded file sitting there in that directory still zipped up. Make sure you didn't grab the Linux or Mac version by mistake (the download page lists all 3 lumped together).


3) There could be one tiny thing off in your syntax (i.e. make sure you didn't add the pound signs and just added the required numbers in place of them, only leave spaces where it shows, and of course don't add the quotation marks). I did that a couple times myself at first based on the other game's instructions from the Steam thread. It's easy to do.


It should look like this:


sde -attach-pid 8104



The 8104 in that example will be a different number for you, which will be your own unique PID. 

That screenshot is using a different directory name that the one I suggested in my original

instructions in case there's confusion; that's just what I originally used.

There you can see the annoyingly long sub directory that the unzipped file created. 


Let us know if you were able to get it working and I'll update my original instructions so no one else is confused!

Message 16 of 18 (3,013 Views)

Re: UnravelTwo crashes after first cutscene

[ Edited ]
★ Novice

I have an AMD Phenom II X6 1100T processor which is more powerful than the AMD FX 6300. The game does not work because my procesor does not support SSE4.1 / 4.2. EA_Mai does not understand this. Just recompile the game code .... Who has to do it? fans ?? This is pathetic! 
Share the source code for this game and the next day will be a working version on Phenom. You are just lazy ....
Or maybe you have a contract with equipment manufacturers to more sales ??? :/

I do not want to replace the processor with a weaker model.....

my spec:

AMD Phenom II X6 1100T


GTX 1060 6GB

SSD 512 GB + 3TB

which is stronger than recommended. (the only problem is the lack of support for SSE 4.1 / 4.2)


Message 17 of 18 (2,975 Views)

Re: Unravel Two: game doesn't work (crash on first cut scene - AMD Phenom II)

★★ Newbie

Just install the premium version of avast antivirus to clear all junk files and all malwares, then update all the drivers. Thats it. I hope it will work. It worked for me.

Message 18 of 18 (1,035 Views)
Twitter Stream