Help us improve Answers HQ! Take Survey No, Thanks

Re: Origin prevents system from hibernating

by kyosji
Reply

Original Post

Accepted Solution

Origin prevents system from hibernating

★★★★ Novice

Need help on this.  For whatever reason, Origin is preventing my system from sleeping.  It's a tad annoying, as I rather keep origin running in the system tray, but cannot because it will never let my computer just go to sleep.  It didnt do this before, and it's something I just recently noticed since I came back to p[laying EA games.

Yes, I am 100% sure it's Origin causing the system from going to sleep, I spent a month testing it to make sure it WAS Origin.  I just want to find out how to make it stop causing the hibernation from starting.

Message 1 of 18 (3,181 Views)

Accepted Solution

Re: Origin prevents system from hibernating

★★ Newbie

Disabling the Origin Helper Service, under application settings, worked for me, on a clean windows 10 install that wouldn't sleep.

 

To see if anything else is preventing sleep run an elevated command prompt (start, type cmd, right click, run as admin) type powercfg /requests

 

For me, with the service enabled I had...

 

SYSTEM:
[DRIVER] NVIDIA High Definition Audio (HDAUDIO\FUNC_01&VEN_10DE&DEV_0071&SUBSYS_10438508&REV_1001\5&3801de31&0&0001)
An audio stream is currently in use.

 

After disabling the service...

 

SYSTEM:
None.

 

Origin Version 10.5.4.63358 - 0

View in thread

Message 8 of 18 (3,649 Views)

All Replies

Re: Origin prevents system from hibernating

Community Manager

@kyosji

 

Go to the Origin menu, Application Settings, Notifications, turn all of those off and let us know if your machine hibernates after that, thanks.

 

 

--------------------------------------------------------------------------------------------------
If a post Answers your question please click on Accept as Solution.
Thank players and help them 'Level Up' by giving them XP.
Thank you for sharing your gaming expertise with your fellow players!
Message 2 of 18 (3,160 Views)

Re: Origin prevents system from hibernating

[ Edited ]
★★ Newbie
@EA_Barry I have exactly same problem and those notification offing doesn't help! This problem comes in bf1 launch when origin updates new menus. EA please fix your software!
Message 3 of 18 (3,130 Views)

Re: Origin prevents system from hibernating

★★★★ Novice

Still happening after a clean install.  It's 100% Origin, as I haven't had origin installed for a month and everything was fine.  The same time I installed origin and downloaded BF4 and BF1, my system does not hibernate when Origin is in the system tray.

This is why I despise launchers.  Life was better when I clicked on a shortcut on my desketop and it launched the game.  Now I have to open a launcher that needs to constantly be updated before I can use it, then select my game and launch it.  It's additional tasks in my task bar, and they can cause conflicting issues with the system, like disabling hibernation.

Message 4 of 18 (3,049 Views)

Re: Origin prevents system from hibernating

★★★★ Novice

@EA_BarryStill doing this.  Please don't ignore us here.

Message 5 of 18 (2,965 Views)

Re: Origin prevents system from hibernating

Community Manager

@kyosji@JuSiZ1

 

It is possible that clearing your Origin cache as follows will help, please let us know either way.

 

https://help.ea.com/en-us/help/origin/origin/origin-my-games-list-is-blank/

--------------------------------------------------------------------------------------------------
If a post Answers your question please click on Accept as Solution.
Thank players and help them 'Level Up' by giving them XP.
Thank you for sharing your gaming expertise with your fellow players!
Message 6 of 18 (2,943 Views)
Highlighted

Re: Origin prevents system from hibernating

★★★★ Novice

@EA_BarryNo.  As stated, I've done clean installs, and since then, i've reinstalled windows to a new SSD, same issue.

Message 7 of 18 (2,935 Views)

Re: Origin prevents system from hibernating

★★ Newbie

Disabling the Origin Helper Service, under application settings, worked for me, on a clean windows 10 install that wouldn't sleep.

 

To see if anything else is preventing sleep run an elevated command prompt (start, type cmd, right click, run as admin) type powercfg /requests

 

For me, with the service enabled I had...

 

SYSTEM:
[DRIVER] NVIDIA High Definition Audio (HDAUDIO\FUNC_01&VEN_10DE&DEV_0071&SUBSYS_10438508&REV_1001\5&3801de31&0&0001)
An audio stream is currently in use.

 

After disabling the service...

 

SYSTEM:
None.

 

Origin Version 10.5.4.63358 - 0

Message 8 of 18 (3,650 Views)

Re: Origin prevents system from hibernating

★★ Newbie

This is still happening in December 2017.

 

Disabling the Origin Helper Service fixes the issue.  Without it disabled the system fails to go to sleep due to:

 

[SYSTEM]

Legacy Kernel Caller

 

Origin

Version 10.5.8.17910 - 0

Message 9 of 18 (2,698 Views)

Re: Origin prevents system from hibernating

★★★ Novice

Hi Barry,

 

when can we expect a new Origin update ? Last year that was happening twice weekly in some period and now it's long time.

Many MS updates have passed under the bridges (and routers), we are still with Version 10.5.8.17910 - 0--

 

Any release date or website where to see official Origin release dates ?

 

Every SW has update schedules...

 

Thanks for taking the time to find out Standard smile

Message 10 of 18 (2,603 Views)
Twitter Stream

ea-promo

Do you need to talk to us?

We’re here to help! Here’s how to get in touch with an EA Advisor.

I need to contact EA

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help