Help us improve Answers HQ! Take Survey No, Thanks

Re: No sound on Origin games

by EA_Darko
Reply

Original Post

Highlighted
Accepted Solution

No sound on Origin games

[ Edited ]
★ Novice

Hello,

 

Currently, on every single Origin game I have, I get no sound. 

I have done all the suggestions from this question:

No sound on my origin games??!?

 

I have played Origin games for several hours before with everything working perfectly fine. 

I have no issues with any other games.

I have reinstalled my drivers for both older and newest. Using RealTek.

I've disabled all but my main playback audio, in the computer management window. 

I've done everything you can possibly do to your audio within windows, even resetting things in the command prompt.

 

OS Name Microsoft Windows 7 Ultimate
Version 6.1.7601 Service Pack 1 Build 7601
System Type x64-based PC

MB:  MSI Z170A Gaming M7
Processor Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz

GPU:Nvidia GeForce GTX 970

Installed Physical Memory (RAM) 16.0 GB

 

I have looked, looked, looked, and looked again for a solution for this problem. 

 

I don't really know what else to do. 

 

 

 

 

Thank you!!

Message 1 of 10 (15,896 Views)

Accepted Solution
Highlighted

Re: No sound on Origin games

Community Manager

@Ericeel

 

An additional tip:

 

Make sure that you've set to correct Default Device in your audio settings: right-click Speaker icon in your taskbar - Playback Devices - right-click your desired device and make sure that Set as Default Device and Set as Default Communication Device are enabled.

 

Using these settings any application should automatically use the device that you desire.

 

 

--Tom

View in thread

Message 5 of 10 (18,904 Views)

All Replies
Highlighted

Re: No sound on Origin games

★★ Apprentice

Hi Ericeel

 

The only other suggestion I can make is to go into your bios and disable your on-board sound device. Restart and boot into Windows. 

Go to your sound options and see if any devices are found, it should just tell you no audio device was found.

If it does display a different audio device then it's most likely your HDMI audio interfering from your graphics card.

In that case you can choose to use the HDMI audio (not always so great) or uninstall the Nvidia audio drivers.

 

If you choose to uninstall then simply go back to your bios once all has been removed and re-enable your realtec audio.

Windows should auto detect it now and just for safe measure download the latest drivers from your motherboard website for your board and re-install.

 

Your audio should work now across everything.

 

Hope it works Standard smile

Message 2 of 10 (15,880 Views)
Highlighted

Re: No sound on Origin games

[ Edited ]
★ Novice

Hello Sgt,

 

Thank you for your suggestion! 

 

Here is exactly what I did. 

 

I restarted the PC, went into the bios, disabled the on-board sound driver.

 

Started up PC, started Origin, then started Simcity. I instantly had sound in the launcher, and in game. So, it worked!!! 

 

Now, I uninstalled the Nvidia HD Audio Controller Driver. When it was finished, it asked me to restart, I did, while restarting, I went into the bios again, and enabled the on-board drivers.

 

Now, I start Simcity again, and I don't have audio.

 

 What I will try now is to update my drivers from MSI, I'm currently running an older version cause in some forum, they said that might work. 

 

I'm going to revise this cause the Nvidia HD Audio re-installed itself automatically. 

 

I got the Nvidia Driver to not automatically re-install. 

 

So, while finding out how to stop it, I installed the realtek drivers from the MSI website. I stopped Nvidia from reinstalling, I rebooted, to disabled the on-board audio, uninstalled Nvidia audio, rebooted, made sure it didn't come back, rebooted and enabled the on-board. 

 

Still no sound. Everything else on my pc has sound. Just no games from Origin. 

 

 

Message 3 of 10 (15,863 Views)
Highlighted

Re: No sound on Origin games

★★ Apprentice

Hi Ericeel

 

Alright great so at-least now we know where the issue is. Your system is currently confused between two audio devices that both have equal rights to play. It is also constantly switching those rights as the devices are constantly trying to install and activate themselves. You get this issue all the time with USB powered headsets.

 

What you want to do is stabalise the two audio devices and then assign rights to both.

 

So firstly install and get both working perfectly this way you not gonna have them constantly wanting to re-install and interfere with one another. Might take a few restarts. Once this is done you want to make sure the realtech is working for everything and the HDMI audio is not. So you do the following.

 

Go into your audio (sound) settings in control panel and you need to firstly set your on-board audio by right clicking to be set as the default device. Once done a tick should appear next to it. Now go down to the HDMI audio device  and right click and select disable.

 

Your audio should now be sorted, a restart might be required. I had the same issue with my Creative sound blaster and AMD HDMI Audio device.

 

Hope this helps Standard smile

Message 4 of 10 (15,844 Views)
Highlighted

Re: No sound on Origin games

Community Manager

@Ericeel

 

An additional tip:

 

Make sure that you've set to correct Default Device in your audio settings: right-click Speaker icon in your taskbar - Playback Devices - right-click your desired device and make sure that Set as Default Device and Set as Default Communication Device are enabled.

 

Using these settings any application should automatically use the device that you desire.

 

 

--Tom

Message 5 of 10 (18,905 Views)
Highlighted

Re: No sound on Origin games

★ Novice

For some reason EA game disable audio when using bluetooth headphones, it sucks, now I'm going to share the only work around for this issue.

-control panel

-go to devices and printers

-click twice on your headphones

-click the services tab

-uncheck handfree telephony

(if you want to talk with someone and play the game disable Audio Sink and enable hfree telephony) its sucks I know but you know EA.

 

Hope it works.

Message 6 of 10 (8,491 Views)
Highlighted

Re: No sound on Origin games

★★★ Newbie

Hi there, just wanted to say a huge thanks. Nothing else worked for me except this. :eahigh_file:

Message 7 of 10 (5,790 Views)
Highlighted

Re: No sound on Origin games

[ Edited ]
★★ Newbie

Thank you, KnightDragon79. Your solution worked for me.

Message 8 of 10 (3,774 Views)
Highlighted

Re: No sound on Origin games

★ Novice

Hey I dont know if you still have this issue but after following forum instructions and checking drivers, nothing worked until i went to my Realtek Audio Console app, went to device advanced settings and made selected "Mute the internal output device, when an internal output device plugged in,"

Message 9 of 10 (2,841 Views)
Highlighted

Re: No sound on Origin games

Community Manager

Hey all, thanks for taking the time to share all the fixes you found for issues with sound in Origin.

Darko

Message 10 of 10 (2,830 Views)
Twitter Stream