Help us improve Answers HQ! Take Survey No, Thanks

Re: I have a Win 10 64 bit processor

by sp3mjg01t
Reply

Original Post

Highlighted

I have a Win 10 64 bit processor

★★ Novice

Why is origin requiring me to have Legacy?

 

Intel i7-8550U CPU @ 1.80 GHz with 16 MB or RAM should not require Legacy.

Message 1 of 4 (235 Views)
Highlighted

Re: I have a Win 10 64 bit processor

@sp3mjg01t  Are you talking about Sims 4?  If so, you can tell Origin to launch the game in 64-bit.  Open your Origin game library, right-click on the Sims 4 icon, select Game Properties > Advanced Launch Options, and select 64-bit from the dropdown menu.  If this doesn't work, please post a screenshot of the error.  If your game crashes with the standard version of Sims 4 but the Legacy Edition works fine, please run a dxdiag and attach it to a post.

 

https://help.ea.com/en-us/help/pc/how-to-gather-dxdiag-information/

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 4 (227 Views)
Highlighted

Re: I have a Win 10 64 bit processor

★★ Novice

Game properties is grayed out.  My only choices are Show Game details (which shows the play button grayed out and a note to download Legacy), Add to Favorites, and Hide.  All other options are gray/

Message 3 of 4 (225 Views)
Highlighted

Re: I have a Win 10 64 bit processor

★★ Novice

So I did the great Microsoft fix for all problems, rebooting the computer, and it came up and worked.  No idea why, but it seems all is now well.  Thank you for being there and responding so quickly.  Greatly Appreciated!

Message 4 of 4 (224 Views)
Twitter Stream