Help us improve Answers HQ! Take Survey No, Thanks

Re: Can't open Origin

by HulkBusterXLIV
Reply

Original Post

Can't open Origin

★★★★ Novice

The OriginThinSetup.exe isn't working. It will download but it won't run when I try to open it. I'll click it and nothing happens. I have already tried doing a clean boot and renaming it originTMP. I've heard that some other people are also having this problem.

Message 1 of 6 (146 Views)

Re: Can't open Origin

Community Manager (retired)

@Rormonger If you right click the setup file and select 'Run with Admin rights', does this help? Also please make sure that your firewall/antivirus is not quarantining any Origin files.

 

Let us know how you get on!

Message 2 of 6 (130 Views)

Re: Can't open Origin

★★★★ Novice

I tried clicking that and it still won't work. There's also no problem with the firewall or anything like that, but thanks. Please let me know if there's anything else that might work.

Message 3 of 6 (126 Views)

Re: Can't open Origin

★★★★ Novice

Yeah, I gave up. (Spent 6 or 7 hours searching and attempting possible solutions.) Just used a different computer.

Message 4 of 6 (106 Views)

Re: Can't open Origin

★★★★ Novice

Oh then maybe I'll just try it on a mac instead. Thanks!

Message 5 of 6 (95 Views)
Highlighted

Re: Can't open Origin

[ Edited ]
★★★★ Novice

I'm having the same issue, after trying the same fixes with no success.  I'm wondering if it's a Windows 10 thing, because it seems I started having this problem after I upgraded.  Although it does occasionally work.  I had to uninstall Origin, delete the exe file, etc., etc.  Nothing works now though.

 

Does ANYONE have a suggestion?

Message 6 of 6 (72 Views)

ea-promo

Do you need to talk to us?

We’re here to help! Here’s how to get in touch with an EA Advisor.

I need to contact EA

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help