msvcp110 'missing'

by Kadian1
Reply

Original Post

msvcp110 'missing'

★★★ Newbie

Hello Community,

So, to make it...relatively short. I recently bought and installed DA:I, however, every time I try to start the game it says the following:

 

"Invalid License. Reason Code= missing DLL MSVCP110.dll Error 0xC1."

Of course I at least somewhat know my Programs - that's a vc redist error ; I went into the folder of DA:I, and from there into _installer/vc and used the given exes to repair my vc redist.

I then tried to start the game again - still the same error. Fine, I said, I then >deinstalled< all the VC redist's i had on my computer and installed them again; still the same issue. I then deinstalled and reinstalled the game itself, and yet I still have the same issue as before.

 

I then checked the internet for possible solutions, but only could find a few posts about BF4 having similar issues. The 'solutions' there were reinstalling the vc redists, which I did - several times.

That's why I turn to this place. Any Ideas as to why it's not working? I have all the Redistributables installed (2008, 2012 and 2013), the dll in question (msvcp110.dll) is in my windows/system32 folder and in the Dragon Age Inquisition/Core folder. Why can't it recognize the dll then...?

Message 1 of 17 (16,587 Views)

Re: msvcp110 'missing'

★★★ Newbie

Seems like the file in Windows is different version, so copy msvcp110.dll from Dragon Age Inquisition\Core to Windows\System32. This worked for me.

Message 2 of 17 (16,525 Views)

Re: msvcp110 'missing'

[ Edited ]
★★ Guide

Try running 'windows system files repair tool',

Press start, and type, 'command prompt', right-click and 'run as administrator'. At the dos prompt type, 'sfc/scannow', press enter.

Restart your system.

Message 3 of 17 (16,521 Views)
0

Re: msvcp110 'missing'

★★★ Novice

Hello.

 

Having the same problem here. While starting the game, error screen pops up saying: "Error code = Missing DLL: [MSVCP110.dll] Error: 0XC1.

 

Steps taken to fix.

  • Reinstalling VC++ redistr;
  • Uninstalling all VC, reboot, installing both x64 and x86 for 2008, 2012 and 2013 versions;
  • Updating Microsoft .NET installation;
  • Checking game files;
  • Copying MSVCP110.dll from DAI folder to System32 folder;
  • Reinstalling Origin;
  • Miserable wailing and self-pity.

Nothing helps.

 

So it would be good to hear from Support regarding this.

Thanks.

Message 4 of 17 (16,505 Views)

Re: msvcp110 'missing'

★★★ Novice

Hello.

 

Update:

Had a talk with support, they advised to delete game, delete Origin and then install Origin and DAI. Done that (13 hours to download Frown ) - did not help.

Search continues.

Message 5 of 17 (16,482 Views)
0

Re: msvcp110 'missing'

★★ Guide

@mlleyr wrote:

Hello.

 

Update:

Had a talk with support, they advised to delete game, delete Origin and then install Origin and DAI. Done that (13 hours to download Frown ) - did not help.

Search continues.


Recommend the following,

 

Run a malware sweep,

https://www.malwarebytes.org/

 

Clean your registry,

https://www.piriform.com/ccleaner/download

 

And reinstall 'Visual C++ Redistributable for Visual Studio 2012 Update 4'.

http://www.microsoft.com/en-au/download/confirmation.aspx?id=30679

Message 6 of 17 (16,479 Views)

Re: msvcp110 'missing'

[ Edited ]
★★ Novice

Had the same issue when I first tried running it. Fixed it by re-installing VC++, but I downloaded the install files from the microsoft website. I then rebooted, repaired the VC installs (since it still did not work) as well as updating my Nvidia graphics drivers, then rebooted again. One of the last steps fixed it. 

Message 7 of 17 (16,473 Views)
0

Re: msvcp110 'missing'

★★★ Novice

Try that solution from Talgrin -> Here

Message 8 of 17 (16,449 Views)
0

Re: msvcp110 'missing'

★★★ Novice

Hello guys.

 

Managed to start the game.

 

Steps taken to fix (not sure if all are required, starting from most possible fix):

1. Copy MSVCP110.DLL and MSVCR110.DLL from "\Origin Games\Dragon Age Inquisition\Core\" to "\Origin Games\Dragon Age Inquisition\". Those DLLs should be in the same folder as DragonAgeInquisition.exe file. Try to launch the game. If doesn't work, check next point.

 

2. Open regedit (smart thing to do is to backup your registry at this moment) and make a search for all entries containing "msvcp" and "msvcr" string. Look for entries that define location of those DLLs, but have a mistake in them: instead of "C:\", path is written as "C?\". Change those entries so they have "C:\". Mind, there is a way to do it automatically, but use that method on your own risk.

 

Would be nice if someone with this problem can check above points and give feedback. Hope it helps.

Message 9 of 17 (16,441 Views)

Re: msvcp110 'missing'

[ Edited ]
★★★★★ Newbie

The first step fixed the problem for me. Thank you dude!


@mlleyr wrote:

Hello guys.

 

Managed to start the game.

 

Steps taken to fix (not sure if all are required, starting from most possible fix):

1. Copy MSVCP110.DLL and MSVCR110.DLL from "\Origin Games\Dragon Age Inquisition\Core\" to "\Origin Games\Dragon Age Inquisition\". Those DLLs should be in the same folder as DragonAgeInquisition.exe file. Try to launch the game. If doesn't work, check next point.

 

2. Open regedit (smart thing to do is to backup your registry at this moment) and make a search for all entries containing "msvcp" and "msvcr" string. Look for entries that define location of those DLLs, but have a mistake in them: instead of "C:\", path is written as "C?\". Change those entries so they have "C:\". Mind, there is a way to do it automatically, but use that method on your own risk.

 

Would be nice if someone with this problem can check above points and give feedback. Hope it helps.


 

Message 10 of 17 (16,404 Views)
0
Twitter Stream