Help us improve Answers HQ! Take Survey No, Thanks

Re: inquisition blackscreen after messi loading screen

by Tino1407
Reply

Original Post

Highlighted

Re: During crash 1 CPU core only

★★★★ Novice

@Urouborous wrote:

The game won't start on Core 2 Quad Q6600. Same issue as by using Core 2 Duo E8500. 

 

http://hastebin.com/posecusafe.tex


Open msconfig.exe, go to the Boot tab, click the Advanced Options button, uncheck Number of Processors (if it's checked, it probably is and set to 2 from your old CPU by the sound of it). Reboot. Probably play game.

Message 1001 of 1,253 (3,075 Views)
Highlighted

Re: During crash 1 CPU core only

★★★ Novice

Thanks for the suggestion but still nothing Frown I have just installed new OS. Win 7 Pro x64. New drivers and all stuff. It's useless. This black screen makes me crazy. Hours lost on trying to start this crappy game. EA should refund all guys that met declared minimal requirements and still can not play.

Message 1002 of 1,253 (2,896 Views)
Highlighted

Re: inquisition blackscreen after messi loading screen

★★★★★ Novice

i wonder why EA take so long time to create a patch for a game,almost 2 weeks still without any patch,dont tell me the next patch isnt trying to fix this issue,annoyed

Message 1003 of 1,253 (2,344 Views)
Highlighted

Re: inquisition blackscreen after messi loading screen

★★★★ Novice

ok so NVIDIA GeForce Experience told me it needs to optimize DA:I. as game never worked on my AMD Phenom II Quad Core 3.2Ghz (GTX 560 Ti) i thought what the heck and did the optimization. it basically put eveything on lowest setting possible...

 

Game loaded.. i was extatic - till i looked at how it looks - pixelated 640X480... lol

 

so - EA - any answers??? Patches??? Anything???

Message 1004 of 1,253 (2,126 Views)
Highlighted

Re: inquisition blackscreen after messi loading screen

★★ Newbie

For people who are experiencing the issue of crashing on game load on quad core processors:

 

I tried upgrading to the latest AMD beta drivers and it did nothing. What did fix this problem for me was going into the profile settings and deleting them.

 

These are located in Documents -> BioWare -> Dragon Age Inquisition -> Save

 

I removed both ProfileOptions and ProfileOptions_Profile

 

If this was a repost then I apologize, but I did not want to read through 100+ pages of content.

 

I was playing on windowed mode and I changed it back to fullscreen and now it seems to be running fine.

Message 1005 of 1,253 (2,108 Views)
Highlighted

Re: inquisition blackscreen after messi loading screen

[ Edited ]
★★★ Novice

Finally it works! My problem was that Win7 didn't detect my new cpu as a hexa-core but triple-core because the old one was a triple core and the settings couldn't get updated. So I had to reset the number of the cores to default. If someone else is having this problem with wrong number of cores then follow this guide:

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/howto-get-windows-7-to-detect-yo...

It seems that in most cases the black screen problem comes if you have less than four cores.  I was really desperate when the game refused to work after I spent 200 euros for the system upgrade. I had a really cpu so the upgrade was a necessary thing to do sooner or later.

Message 1006 of 1,253 (1,957 Views)
Highlighted

Re: inquisition blackscreen after messi loading screen

★★ Novice

Okay, I had this same problem Thursday and Friday. I was into the game about 100 hours, everythign working fine. Then the next time I tried to login to the game I got the Origin update and then the game would only load to the Bioware Logo and then black screen. Nothing helped.

 

Here is what  I did... one of these things must have worked, becausew now I am playing again with no problems. (Also, I'm on a quad core)

 

I completely uninstalled the game except for the saves.

 

I downloaded a fresh copy.

 

I updated bios.

 

Updatred my graphics driver (again, I had done this just two days before release)

 

At this point I reinstalled the game and tried to load again, but this time I got a blue screen.

 

I ran a registry cleaner. There were some DA:I files in there too.

 

Went through my Nvidia control panel and switched all the settings for the game to the lowest possible settings.

 

Game loaded, but had to put it in windowed mode a few times to get it to load to the options/saves screen.

 

Save loaded up, but of course the graphics were horrible. I put the graphics settings back to where I had them originally. Game played fine. Made a save, closed the game, and reloaded with no problems this time.

 

Game seems to be working fine now with the exception that in Skyhold the FPS is a little down.

Message 1007 of 1,253 (1,911 Views)
Highlighted

Re: inquisition blackscreen after messi loading screen

[ Edited ]
★ Apprentice

@Asheilia wrote:

The injector got rid of the blackscreen issue for me, and although the fps is terrible, i'm able to get through character creation and even past the first cinimatic. When you are making your character, you're in the map of the cinimatic, but after the cinimatic, you should be in a totally different map and a dialouge should start. My new problem is when the cinimatic ends, I'm left to freeroam the map of the cinimatic, which is nifty and all, but I shouldn't even be here, especially if I, ya know, actually want to play the game.

 

So now all I can do is roam around near a couple of rocks with a sweet rift in the sky that I cant get to because I'm surrounded by mountains. Not a fort, not a keep, not anywhere near people. The teleport to the next area doesn't happen, and now I'm stuck once again.

 

Gonna try going to gamestop tomorrow to see if they'll let me trade my current physical pc copy for a xbox 360 copy. Graphics will be much lesser, but at this point, as long as I can play the game that I paid for, I don't give a damn.

 

This sucks.


Hahahaha! This happened to me too!

It was the first time I had played the game and I assumed this meant I had to find out where to go. That map is ridiculously huge. I explored way off into the mountains. After about 15 minutes of me running up and down mountains, I realized that this wasn't supposed to happen. I reloaded a few times to take screenshots.

Not sure what happened that solved this strange issue for me. It just worked once and I was like "ok, on to the rest of the game i guess."

Picture of where you spawn

A view of the whole valley (the circled bit is the hill that you spawn on - seen in the link above)

 

I explored about an area triple the size of that valley before giving up. Like I said, that map is HUGE!!

Message 1008 of 1,253 (1,679 Views)
Highlighted

Re: inquisition blackscreen after messi loading screen

★★ Novice

Overclocked g3258 Duel core stomps on lots of cpus pair it with 780gtx and i have never had a problem. refund???

Message 1009 of 1,253 (1,563 Views)
Highlighted

Re: inquisition blackscreen after messi loading screen

★★ Novice

48 hours to get a reply and 10 days from that to get a refund... nice experiance i wonder if i get any interest on my 12 day loan to EA...

Message 1010 of 1,253 (1,545 Views)
Twitter Stream