Help us improve Answers HQ! Take Survey No, Thanks

Unable to play Dragon Age Inquisition

by EspressoSloth
Reply

Original Post

Highlighted

Unable to play Dragon Age Inquisition

[ Edited ]
★★ Newbie

So, I'm experiencing really bad technical problems with DA:I. In short, I was playing DA:I and nothing was wrong until I had to do a windows update and since that update, I can't play DA:I. The problem is that when it starts up it looks fine and its loading properly however before the Bioware logo can even pop up, the game basically freezes. But it's not frozen, it's just incredibly laggy (audio is laggy as well). I had to wait about 20 minutes for it to get past the Bioware logo.  The game is going so slow that it's literally one frame every minute making it so I'm unable to play DA:I.

 

All of my drivers are updated, I even uninstalled the windows update, still no dice. I tried re-installing the update to see if it would work -- still nothing. I've even tried re-installing drivers, repairing the game through origin and re-installing the game but nothing seems to be working. My Nvidia graphics are all up to date (version 350.12) as well. I've tried lowering all the graphic settings via Nvidia's graphic control thingy but it's still not working.

 

Any help would be much appreciated, please and thank you!

Message 1 of 2 (233 Views)
Highlighted

Re: Unable to play Dragon Age Inquisition

https://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

 

 

Run that program and see how much load DAI is taking up versus other background programs.

 

Try a clean boot and see if it helps any.

 

Post a DX file per.... http://answers.ea.com/t5/Dragon-Age-Inquisition/How-to-post-the-relevant-info-when-you-create-a-ques...

 

Have you updated all the related drivers for your machines CPU and mobo, not just Graphics??

 

Remember Info is king when you are trying to fix an issue.  Simple info such as what Op system we are talking about can make a huge difference and you didn't even post that.

 

------------------------------------------------------------------------------------------------
I am NOT an EA employee, I am just a simple gamer like most everyone else here volunteering my help to those who may can use it .....That means I have to pay for my games just like you, lol.
------------------------------------------------------------------------------------------------
Message 2 of 2 (187 Views)
Twitter Stream