Help us improve Answers HQ! Take Survey No, Thanks

Impassable cut-scene (some spoilers)

by Vrekasht
Reply

Original Post

Impassable cut-scene (some spoilers)

★ Novice

I've been stuck on this one for nearly three days now.

Firstly - my machine barely, barely runs the game.  Freezing, crashing, looks awful, etc. etc.  All of this I can live with (maybe not cheerily, but I can live with it).

Now, however, I'm completely stuck.

After the fight with Alexius, we go back through the time-portal and return to the present and...the combat HUD is jammed overtop of the following cutscene, so Alexius just sits there on his knees and the Inquisitor looms over him and nothing happens at all.  Esc doesn't work because of course it's using the HUD controls so it just takes me to the menu, useless because I can't save and then reload.  I've gone through the entire quest twice and tried to  get though this part specifically at least fifteen times, now; done the fight, sat through the portal opening.  And I'm probably estimating low.  I can quote it by heart.

 

The workarounds some people have suggested elsewhere (open Origin ingame, hit ESC through the preceeding cut scenes) freeze me up entirely.  It worked ONCE....and then I froze up about a minute later when it went back to the War Room.  Of course, no autosave or opportunity to save, so I'm right back where I started.

I don't even know how to report a bug.  Is this where?  I have no idea.  I'm tearing my hair out over here, this is absolutely maddening.

Message 1 of 1 (113 Views)
Twitter Stream