Dragon Age Keep "An Error has Occured" still after almost a year

by ZeSpecter
Reply

Original Post

Highlighted

Dragon Age Keep "An Error has Occured" still after almost a year

★★★★★ Novice

After encountering this issue on November of 2022, after countless interactions with EA support staff, after clearing browser and cache, after trying different browsers, after trying different devices, after trying a different internet connection, after changing my EA password, nothing has fixed it for me and we're going on the 10th month currently still not being able to access Dragon Age Keep. I figured I'd wait it out and here I am 10 months later trying again only to get the exact same error "Oops, an error has occured, please refresh page and retry"

 

Here's one thread I posted back in November of last year: https://answers.ea.com/t5/Dragon-Age-Inquisition/Dragon-Age-Keep-quot-Oops-an-error-occured-quot-Yet...

Here's another thread I posted back in December of last year: https://answers.ea.com/t5/Other-Dragon-Age-Games/Problem-with-Dragon-Age-Keep-quot-Oops-an-error-occ...

 

 

I see this thread from July this year while I haven't been here and somehow that fixed it for many, but not for me: https://answers.ea.com/t5/Dragon-Age-Inquisition/Dragon-Age-Keep-Error-Oops-An-Error-Has-Occurred-Ne...

 

Still, the issue is there for me and I cannot access Dragon Age Keep going on the 10th month since I first encountered this which is utterly insane.

 

Why is this still happening to my account? Should I just consider my account broken or something but all my games are connected to this account? I'd like to get this fixed once and for all so I'm trying yet again to get some support so it can be resolved.

Message 1 of 2 (605 Views)

Re: Dragon Age Keep "An Error has Occured" still after almost a year

★ Apprentice

This is also happening for me; I have been unable to access the Dragon Age Keep since August 2023. I have tried everything; clearing my caches, changing my EA password, using incognito mode, using a different browser, using a different device, etc. I am really frustrated by this! Hoping this gets solved soon!

Message 2 of 2 (297 Views)