Help us improve Answers HQ! Take Survey No, Thanks

Dragon Age: Inquisition

by Mister-Cutup

Original Post


Dragon Age: Inquisition

★★★★ Novice

When I attempt to load Inquisition the game behaves as if it's going to start, but nothing evolves beyond the Hourglass. At that point nothing shows up.  However, whenever I check to determine whether it's running, Origin designates that I've last played the game on that day and that I've played it for seven hours.  Always, it's seven hours, no more no less and the date is always for the particular day I've tried to start the game.  I've uninstalled and reinstalled the game twice.  Still the same problem.  My drivers are up to date. 



Message 1 of 1 (90 Views)

Check out the official website

Find information about characters, multiplayer, and DLC packs.

Learn more


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help