Help us improve Answers HQ! Take Survey No, Thanks

DirectX Error

by Ansehelm
Reply

Original Post

Re: DirectX Error

★★ Newbie

I got the same problem and this really sucks man i really want to play the game. I dont have a problem with the cut scenes its just happens when im exploring or when something explodes like a rift opening.

 

 

http://hastebin.com/emazodulod.tex

Message 71 of 769 (2,021 Views)

Re: DirectX Error

★ Apprentice

I am getting these DirectX Errors regularly and I am running the latest Nvidia Drivers as of 11/18/2014 . Alsio I set my PhysX to use CPU and lowered  BOTH of my GPUs / SLI clock speed to default since it was factory Overclocked by 79Mhz.

 

THIS NEEDS FIXED BIOWARE! Frown

 

http://hastebin.com/idufobamab.tex

 

https://pbs.twimg.com/media/B2wmp8VCEAAv4HG.png

Message 72 of 769 (1,985 Views)

Re: DirectX Error

★★ Novice

same directx error as everyone else during cutscenes, Getdeviceremovedreason error and crash to desktop.  unplayable, GTX 660, just downloaded a new driver released today which specifically said dragon age inquisition on its description. 

Message 73 of 769 (1,943 Views)

Re: DirectX Error

★★★★ Novice

I had enough.  16 hours of troubleshooting this issue and I am barlely 30 minuets into the game.  It crashes on every cinimatic at least once, I had to fight the pride deamon 6 times just so I could get through it and save the game after!  This game is not ready for prime time and so I requested a refund.  I would recommend everyone else do so as well since they give you 24 hours to do so.  

Message 74 of 769 (1,943 Views)

Re: DirectX Error

★★★ Novice

Have the same error, put all settings to low and manged to get a little ways in, of course not to a point I could save. I can't believe after all this time it is released with such a game breaking bug. Very tempted to get a refund and be done with Bioware games.

Message 75 of 769 (1,922 Views)

Re: DirectX Error, DXGI_ERROR_DEVICE_HUNG CRASH

[ Edited ]
★★ Novice

To anyone getting the DXGI_ERROR_DEVICE_HUNG DirectX CRASH error, I'm just posting this as a fix that worked for ME and I highly suggest that everyone try it. (I am running SLI'd GTX 660ti's) so I tried the "core clock lowering fix" that is talked about in this thread and others as well.

 

I was having the  DXGI_ERROR_DEVICE_HUNG DirectX error message every time I got into the character creation cutscene at the very beginning of the game, my game had already crashed more than handful of times and I had tried everything from disabling SLI to turning off every optional setting and lowering the settings down to LOW, nothing worked.

 

What did work however, we shall call it the fix in this situation, was to go into my EVGA Precision X profile and set a custom Profile to lower my CORE CLOCK from the factory setting, I only dropped the core clock by 70MHz. I've been playing the game perfectly fine with no crashes since and that was around 5 hours ago.

 

Once again, I highly suggest everyone that is getting this error at least try this, don't be lazy, go download either MSI Afterburner or EVGA Precision X and do what's been suggested in the other posts. If it doesn't work for you then at least you tried, if it does then your problem is solved!

Message 76 of 769 (1,853 Views)

Re: DirectX Error

[ Edited ]
★★★★ Novice

Yo there, don't even have the game yet. Just reading these posts to be ready for what's to come.

 

Googling a bit I found this. I'm pretty sure you've nothing to lose, so just give it a try and tell me if it was somewhat useful.

 

"Sometimes this problem occurs when "Ambient Occlusion" is disabled in the Nvidia Control Panel-nVidia Inspector and enabled in-game. If it's disabled within the NCP-N.I. the Graphics Engine may report an error due to missing command sets. Just disable it in (DA:I) (Video Settings - Ambient Occlusion Off) OR enable it in the NCP-N.I. setting it to "Performance" or "Quality-HQ" in the NPC-nVIDIA Inspector."

Message 77 of 769 (1,851 Views)

Re: DirectX Error

★★ Novice

I had the same issue and managed to finally get it to not crash after being in game for 15 seconds by lowering my graphics to the high setting.  There is no reason I shouldn't be able to run the game on all ultra, and to compound the issue for some reason I'm capped at 30 frames during cutscenes with jittery animations.

 

Here are my specs:

 

http://hastebin.com/revidireke.tex

Message 78 of 769 (1,834 Views)

Re: DirectX Error

[ Edited ]
★★ Novice

@Konnivar wrote:

I had the same issue and managed to finally get it to not crash after being in game for 15 seconds by lowering my graphics to the high setting.  There is no reason I shouldn't be able to run the game on all ultra, and to compound the issue for some reason I'm capped at 30 frames during cutscenes with jittery animations.

 

Here are my specs:

 

http://hastebin.com/revidireke.tex


1. Remove 30 FPS Cap in cutscenes

Make a shortcut to the Dragon Age: Inquisition exe file and add “-GameTime.MaxSimFps 60 -GameTime.ForceSimRate 60+” to the end.

Or go into Origin, go to Dragon Age Inquisitions, right click and go to Game Properies and Paste the line below:

 

 -GameTime.MaxSimFps 60 -GameTime.ForceSimRate 60+

 

Hope this helps :D.



 

 

Message 79 of 769 (1,818 Views)

Re: DirectX Error

★★★ Novice

I keep getting the DXGI_ERROR_DEVICE_HUNG DirectX CRASH error.   I also downloaded the newest driver today for my video card, Nvidia GTX 660.

 

http://hastebin.com/xofuyehixi.tex

Message 80 of 769 (1,810 Views)
Twitter Stream