Help us improve Answers HQ! Take Survey No, Thanks

DA Inquisition: texture flickering in SLI/Crossfire configuration

by DedMozor
Reply

Original Post

DA Inquisition: texture flickering in SLI/Crossfire configuration

[ Edited ]
★★★★ Novice

Before patch 5: texture flickering issue in DAI
https://www.youtube.com/watch?feature=player_embedded&v=tfs54ZjH-LI
http://www.youtube.com/watch?v=LCDWKF5hSwg&feature=youtu.be
http://youtu.be/MNhzcchE3gc
http://youtu.be/_7IbI-yu9fA

https://www.youtube.com/watch?v=qv7kyPRv92s&list=UUWrju2pzuVTO4fiOc0PiGhA

https://www.youtube.com/watch?v=lp5WckB42lk

 

Patch 5 Notes:

...

"Fixed flickering terrain when using SLI/Crossfire"

...

(http://blog.bioware.com/2015/03/02/dragon-age-inquisition-patch-5-notes/)

 

 

Users of some models of graphics cards still have a problem with texture flickering issue in SLI / Crossfire configuration even after the patch 5 (see below):

 

A list of video cards with status of flickering textures problem in SLI/Crossfire:

NVIDIA

560 Ti 448
660 Ti
670
680
690 - issue fixed after patch 5

760

770
780 - issue NOT SOLVED after patch 5 (report by user PilotGW; VIDEO)
880M
970 - issue NOT SOLVED after patch 5 (report by user ngn356323452135)
980- issue fixed after patch 5

Titan - issue NOT SOLVED after patch 5 (report by user agam3mn0n)

 


AMD
295x2

7970x2

 

This message is no longer updated

Message 1 of 221 (29,496 Views)

Re: DA Inquisition: texture flickering (NVIDIA GTX 690, last driver 344.75)

★★★★ Novice

same problem

Game absolutely uplayable in SLI mode on 690 GTX:womansad:

Message 2 of 221 (29,392 Views)

Re: DA Inquisition: texture flickering (NVIDIA GTX 690, last driver 344.75)

★★★★ Novice

I am having the same issue. On a Nvidia GTX 690.

 

I found that for the issue shown in the first video (the jumping textures), can be fixed by turning off tesselation. The jumping textures also only seem to happen in close range to my character, and seems to happen in the same spots even if I reload the game.

 

The flickering textures on the other hand, seem to appear randomly. Can see flickering in one spot, restart the game and not see the flickering in the same spot. Doesn't matter what proximity to the character, can appear nearby or far in the distance on a mountain. Haven't found a graphics setting that fixes the flickering. There seems to be less flickering with ambient occlusion off, but it's not gone completely.

 

Both issues seem to only be happening on the terrain.

 

I was using the 344.65 driver but I see the 344.75 is now available now so I'll test that out. I'll post again if I find anything new with the latest driver.

Message 3 of 221 (29,328 Views)

Re: DA Inquisition: texture flickering (NVIDIA GTX 690, last driver 344.75)

★★★★ Newbie

Same problem.  Running SLI 670s.

Message 4 of 221 (29,271 Views)

Re: DA Inquisition: texture flickering (NVIDIA GTX 690, last driver 344.75)

★★★★ Novice

Yup, 690 SLI also getting flickering. Disabling SLI removes flickering, but kills framerate. Also seeing significant stuttering with and without SLI, and regardless of texture quality settings.

Message 5 of 221 (29,188 Views)

Re: DA Inquisition: texture flickering (NVIDIA GTX 690, last driver 344.75)

★★★★ Novice

Yep same here Frown.  Not sure if there's anything Bioware can do about this, though.  It seems more likely to be on Nvidia's end.  I wouldn't put the responsibility of getting SLI to work on any developer :P, since it's purely an Nvidia feature.

Message 6 of 221 (29,150 Views)

Re: DA Inquisition: texture flickering (NVIDIA GTX 690, last driver 344.75)

★★★★ Novice

Same here 2 gtx 280's in sli and i have this issue. 

Message 7 of 221 (29,141 Views)

Re: DA Inquisition: texture flickering (NVIDIA GTX 690, last driver 344.75)

[ Edited ]
★★★★ Novice

Nvidia released "game ready" 344.75 drivers but we're still having SLi flickering and bright white fog bug, but performance has improved. this new SLi compatibility flag seems to alieviate the flickering: 0x0C4330F5 feel free to test, my friend is still experimenting with flags but seems to think this one works well. still needs a real fix from EA/BioWare though...

 

also those of you with keplar SLi cards may want to turn HBAO down to SSAA if you want MSAA. I've heard reports that turning AO off completely may remove flickering, but at the cost of image quality.

 

here's my settings for GTX 690 (can't seem to handle 2560x1440 in this game)
resolution: 2304x1296 (16:9 custom), with no scaling for sharper image but letterbox around my 27" monitor. Scaling works too but adds a bit of blur. This basically turns my 27" monitor into a 23" while still staying sharp. Kepler's just weren't designed for much over 1200p I think... Can also try 2133x1200 (16:9) or 1920x1200 (16:10). 1080p obviously runs better, but looks bad on a 1440p screen. Game has native internal resolution scaling too, so you could try turning it down to 0.90 or lower on a high res screen but at the cost of some blur.

 

Mesh: Ultra
Tess: High
Tex: Ultra
Shadows: Ultra
Terrain: Ultra
Veg: Ultra
Water: Ultra
Post-Process: High
AO: SSAO
Effects: Ultra
MSAA: 2X

 

It seems to be a tradeoff if you want HBAO Full or MSAA, but I honestly don't see much of a difference between SSAO and HBAO+, some people even prefer SSAO. With these settings I mostly get 60fps, and 30fps in cutscenes with little to no stuttering/hitching. Game seems to eat up VRAM like crazy, afraid to try fade-touched textures on 2GB. I highly recommend turning off any second or third monitors for lower VRAM usage.

 

Hinterlands still bottlenecks around 45fps, even with low res, with some hitching/stuttering. probably CPU/Engine bottleneck even tho I have a 4.5GHz core i5. Might need to turn down some other CPU-intensive features for smooth performance until we get a bioware patch or further optimized drivers.

 

PS: If you hate the motion blur (negligible performance impact), add these lines to Documents\BioWare\Dragon Age Inquisition\Save\ProfileOptions_profile

GstRender.MotionBlur 0.000000
GstRender.MotionBlurEnabled 0

 

PPS.: EA/BioWare please patch this, I'm not sure how much more optimizing Nvidia can do on their end... AMD users say they have flickering too. some tips on what settings might be bottlenecking certain areas would help too. flickering seems to be related to lighting/AO, and the bright white fog bug makes dungeons really ugly and difficult to navigate.

 

Edit: Disabling Origin In-Game reportedly reduces stuttering some. Also changing the first undefined flag in nvidia inspector from 0x00000003 to 0x00000000 can reduce stutter too, but at a slight performance cost. see thread here for details: https://forums.geforce.com/default/topic/789856/geforce-drivers/dragon-age-inquisition-major-issues-...

Message 8 of 221 (29,111 Views)

Re: DA Inquisition: texture flickering (NVIDIA GTX 690, last driver 344.75)

★★★★ Novice

Yea i can confirm if i disable sli all the issues go away. Frown

 

But at cost of 50% of my fps! With my gtx 780 sli i could crank all that **bleep** up and never get one fps dip. 

 

Now im running 40fps average. 

Message 9 of 221 (29,090 Views)

Re: DA Inquisition: texture flickering (NVIDIA GTX 690, last driver 344.75)

★★★★ Novice

Very weird guys i when to Nvidia control panel disabled sli played game worked fine. So im like ok ill try sli again.

I turn it on restart play dragon age and issues are all gone no fliker with the textures wtf?

Was it just magic or something or disable then enable sli do something.

Message 10 of 221 (29,038 Views)

Get your bonus content

Have you accessed all the Dragon Age: Inquisition bonus content?

Find bonus content

fifa-19-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help