Help us improve Answers HQ! Take Survey No, Thanks

Windows 10 creators dragon age 2

by valsi461
Reply

Original Post

Highlighted
Accepted Solution

Windows 10 creators dragon age 2

★★★★★ Novice

I put in over 200 hours in DA 2 without a problem, but as soon as I installed windows 10 creators edition (against my better judgment) the cut scenes and environment became out of focus.  I unchecked "diffusion depth of field"  in the games video options and that fixed the environment, but the cut scenes were still out of focus.  The only way I could resolve the issue was to roll back to the previous version of windows 10 which immediately fixed the issue.  I could've used DX9 in the games video options, which worked, but I liked using DX 11 with higher resolutions.

Message 1 of 23 (16,688 Views)

Accepted Solution
Highlighted

Re: Windows 10 creators dragon age 2

[ Edited ]
★★★★★ Novice

I have found that the latest build NVidia Drivers 384.76 June 29, 2017 has caused the issue.  After uninstalling Windows 10 Creator update, and reinstalling NVidia Drivers 384.76, the problem returned.  So I installed 382.53 June 9, 2017 and that solved the "out of focus" issue both in the environment and dialogue cut scenes using windows DX11 Very high graphics and all options ticked.  I sent NVidia a detailed report of my system and what version of their drivers did/didn't work, using their troubleshooting form.

 

What happened is when I uninstalled the windows 10 Creator Update, it also reverted back to a previous version of the Nvidia Drivers as well, making me believe it was the Widows update that caused the issue.

View in thread

Message 4 of 23 (17,597 Views)

All Replies
Highlighted

Re: Windows 10 creators dragon age 2

★★★ Expert

@valsi461;  I can confirm everything you said.  I hadn't played DA2 in quite a while (although "...200 hours", Hah!  I have over twice that.) so I wasn't aware of any issues until I read your post.  Am on Win10 Pro v1703 (Creator's Edition) running on an i7-4770, with 16GB RAM and a GTX 1060 6GM VRAM, and I saw the exact same things.

 

Disabling the depth of field in the Video options got rid of the "blurred backgrounds" problem for me, but for the cutscenes I had to drop back to DX9 and give up the enhanced textures.  The loss of detail was much less annoying than the jarring "in/out of focus depending on the camera angle and the exact distances between characters" behaviour I was seeing with DX11.

 

I've flagged the Report for the CMs.  They bundle relevant posts and forward them to the studio for action, (or not.)

Message 2 of 23 (16,650 Views)
Highlighted

Re: Windows 10 creators dragon age 2

Hero

I have tested it and I haven't encountered any of these issues. Here's my dxdiag for comparison:

 

https://hastebin.com/ewuvazorad.tex

 

Might it be an Nvidia specific problem? If so, maybe you should send them a bug report.



I don't work for EA.

Message 3 of 23 (16,637 Views)
Highlighted

Re: Windows 10 creators dragon age 2

[ Edited ]
★★★★★ Novice

I have found that the latest build NVidia Drivers 384.76 June 29, 2017 has caused the issue.  After uninstalling Windows 10 Creator update, and reinstalling NVidia Drivers 384.76, the problem returned.  So I installed 382.53 June 9, 2017 and that solved the "out of focus" issue both in the environment and dialogue cut scenes using windows DX11 Very high graphics and all options ticked.  I sent NVidia a detailed report of my system and what version of their drivers did/didn't work, using their troubleshooting form.

 

What happened is when I uninstalled the windows 10 Creator Update, it also reverted back to a previous version of the Nvidia Drivers as well, making me believe it was the Widows update that caused the issue.

Message 4 of 23 (17,598 Views)
Highlighted

Re: Windows 10 creators dragon age 2

[ Edited ]
★★★ Expert

Confirming that rolling back the nVidia driver worked for me too.  Nerd

Message 5 of 23 (16,611 Views)
Highlighted

Re: Windows 10 creators dragon age 2

★★★★★ Novice

Just loaded up DA 2 and am having the same problems with blurriness on load and randomly while running around. I thought maybe it was me because the game is heavily modded but nope. I just updated my nVidia drivers and updated Win 10. 

Message 6 of 23 (16,540 Views)
Highlighted

Re: Windows 10 creators dragon age 2

★★★ Expert

@cypheroftyr; So did you roll back your driver?

Message 7 of 23 (16,509 Views)
Highlighted

Re: Windows 10 creators dragon age 2

★★★★★ Novice

Not yet, I've been having other issues like every time I update my nVidia drivers my screen resolution changes to 640x480 and I have to unplug my monitor and restart my desktop to get it back to 1900x1200.

Message 8 of 23 (16,498 Views)
Highlighted

Re: Windows 10 creators dragon age 2

[ Edited ]
★★★★★ Novice

Rolled back drivers and still having the same issues. Very blurry and I can run DA2 on highest settings but this is what my game looks like upon load. 

 

 

Message 9 of 23 (16,493 Views)
Highlighted

Re: Windows 10 creators dragon age 2

[ Edited ]
★★★ Expert

@cypheroftyr;  What's your GPU?  Actually, please provide your DXDiag report.  Thx

Message 10 of 23 (16,490 Views)
Twitter Stream