Help us improve Answers HQ! Take Survey No, Thanks

Spore not supported on OSX catalina

by juswanplayspore
Reply

Original Post

Re: Spore not supported on OSX catalina

★★★ Newbie

They'd better

Message 11 of 15 (1,211 Views)

Re: Spore not supported on OSX catalina

★★★ Newbie

Why wouldn't they warn me it wouldn't work?

Message 12 of 15 (983 Views)

Re: Spore not supported on OSX catalina

★ Novice

Same here - been going back and forth with support but just found this thread. They've been telling me it'll work on anything above Leopard

Message 13 of 15 (740 Views)

Re: Spore not supported on OSX catalina

★★★ Newbie
@samueldhop They most likely meant up to Mojave. Also, A developer isn't forced to update their game if they don't want to/don't need to. If the Mac playerbase is small, they might not even update it due to it being too unused. If they do update it though that would be great, I agree
Message 14 of 15 (339 Views)

Re: Spore not supported on OSX catalina

[ Edited ]
★★★ Newbie

@Jeffmark23 wrote:

@juswanplaysporeIf you have Parallels Desktop, and enough disk space, and care about it enough, I believe you can create a MacOS VM in an earlier version to use older apps. Or you can find a used Mini. A pain in the ol' patoot, I know, but neither is uncommon.

 

It would be really nice to hear something from EA, tho...



I did this (used Parallels to run Mojave on Catalina) but my laptop couldn't even handle Amnesia Dark Descent Frown It was so laggy it took like 5 minutes to load the opening scene (SUPER slow fps). Haven't tried other games, but maybe you need a computer with REALLY good specs for it to play properly.

Message 15 of 15 (122 Views)
Twitter Stream