Help us improve Answers HQ! Take Survey No, Thanks

Galactic Adventures Language and mod error

by millsap623

Original Post


Galactic Adventures Language and mod error

[ Edited ]
★★★★ Novice

I bought spore off of origin, and although there was a language error I fixed it and it worked fine. But when I bought galactic adventures and launched it, it played in Spanish instead of English. In addition, whenever I use the .exe file that installed with galactic adventures, all the mods I had stop working. Whenever I use the .exe file that came with the base game though, it plays in English and my mods work, but Galactic Adventures content is not available. I tried fixing galactic adventures like I did with the base game, but I could not find the files I needed in the galactic adventures folder. Any advise? 


Thanks in in advance for any help your able to offer


EDIT: I uninstalled and reinstalled the base game and GA and the issue was fixed. I did have to fix the language for the base game again but afterwards the error did not persist. I know that it seems like an obvious thing to do but as i am used to using steam and not origin i did not think to try that (because steam keeps crashing so i try to avoid uninstalling my steam games but im getting off topic here)

Message 1 of 1 (144 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help