Help us improve Answers HQ! Take Survey No, Thanks

Your device isn't compatible with this version

by Mrbotany
Reply

Original Post

Highlighted

Your device isn't compatible with this version

★★★★ Novice

Product: Star Wars: Galaxy of Heroes
Platform:Android Phone
What type of device are you experiencing the issue with? Galaxy S7 Edge
OS Version 7.0
Ally Code: (Find it here: http://bit.ly/AllyCode ) 214326694
What type of issue do you have? Other
How often does the bug occur? Every time (100%)
Summarize your bug Get push notification of new client, get redirected to Google play store but says device isn't compatible with my version. I tried clearing Google play cache and restarting phone and get same issue.
Steps: How can we find the bug ourselves? Not sure
Connection Type Wifi
Please select your region North America
Country Usa

Thanks
Screenshot_20171122-145430.png
Message 1 of 55 (1,345 Views)

Re: Your device isn't compatible with this version

★★ Novice
I am using Samsung Galaxy s7 and am getting this same error.
Screenshot_20171122-145312.png
Message 2 of 55 (1,332 Views)

Re: Your device isn't compatible with this version

★★★★ Novice

I am getting the same error too and I can't get into the game to get my ally code to raise a ticket!

 

Message 3 of 55 (1,322 Views)

Re: Your device isn't compatible with this version

★★★★ Newbie
I have The same problem with S7.
Message 4 of 55 (1,315 Views)

Re: Your device isn't compatible with this version

★★★★ Novice
Same problem on s8
Message 5 of 55 (1,311 Views)

Re: Your device isn't compatible with this version

★★★★ Novice
Same, with S8 and Android 7.0
Message 6 of 55 (1,305 Views)

Re: Your device isn't compatible with this version

EA Star Wars: Galaxy of Heroes Team

Hi all, thanks for the report. Can you please try to clear your Google Play Store cache and let us know if it fixes the issue? 

Instructions on how to clear the cache for an app can be found here:

http://help.ea.com/en-us/help/mobile/troubleshooting-steps-for-android

 

Thanks.

Message 7 of 55 (1,299 Views)

Re: Your device isn't compatible with this version

★★★★ Novice
Tried this, and issue persists
Message 8 of 55 (1,286 Views)

Re: Your device isn't compatible with this version

★★★★ Novice

 

Tried that and the problem is still there... I stopped playing a different game because of this problem, but I don't want to stop playing this game as I have invested 2 years into playing and hundreds of £!

 

@EA_MindTricks would you recommend we download the apk from elsewhere?

Message 9 of 55 (1,258 Views)

Re: Your device isn't compatible with this version

★★★★ Novice
I have the same issue. Galaxy s7
Message 10 of 55 (1,234 Views)

GET SUPPORT AS YOU PLAY

Find and tap Contact Support in-game under Settings, or contact us on EA Help.

Contact EA Help

fifa-19-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help