Help us improve Answers HQ! Take Survey No, Thanks

Wrong payment info

by RLnoskill
Reply

Original Post

Accepted Solution

Wrong payment info

★★★★ Apprentice

Product: Anthem
Platform:Sony Playstation 4
Please specify your platform model. Sony PlayStation 4 Pro
Please select your region Europe
Were you on an Expedition when the issue occurred? Yes
What type of Expedition were you on when the issue occurred? Freeplay
What was the name of the Mission / Contract / Stronghold you were on? Doesnt matter, it happens in every single thing i do ( missions, stronghold, contract, free play ) or w/e and on all difficultyz
What was your chosen difficulty level? Normal
What Javelin were you using when the issue occurred? Ranger
What was your Expedition team makeup? Random Freelancers
Where did this issue occur? Please include menu name or in game location. After i load into the mission/free play/ w/e
When did this happen? (dd.mm.yy hh:mm) Last 4 days
Summarize your bug "Connection error, your payment information is invalid"
How often does the bug occur? Every time (100%)
Steps: How can we find the bug ourselves? Buy something from the store and then it should appear everytime you do something
What happens when the bug occurs? I get an error
What should be happening instead? Nothing

I heard some friends and other freelancers that have this problem ( it happened after we bought something from the store [ with coins ] ).

Message 1 of 16 (335 Views)

Accepted Solution

Re: Connection Problem there was a problem with the payment information provided

[ Edited ]
Community Manager

@kirosho6002 @RLnoskill @SimplyChaos919 @iiTekz_v2 @Lordsimmons1 @rekam 

 

Please make contact with an EA Game Advisor so we can look into this for you.

 

Click the following link to get started: https://help.ea.com/en/contact-us/

 

For help with contacting an Advisor, please see this link: https://help.ea.com/en-us/help/faq/contact-ea-help/

 

Thanks.

--------------------------------------------------------------------------------------------------
If a post Answers your question please click on Accept as Solution.
Thank players and help them 'Level Up' by giving them XP.
Thank you for sharing your gaming expertise with your fellow players!

View in thread

Message 4 of 16 (335 Views)

All Replies

Unable to consume consumables in mission/freeroam/strongholds

★★★★ Novice

Product: Anthem
Platform:Sony Playstation 4
Please specify your platform model. Sony PlayStation 4 Slim
Please select your region Other
Were you on an Expedition when the issue occurred? Yes
What type of Expedition were you on when the issue occurred? Freeplay
What was the name of the Mission / Contract / Stronghold you were on? This bug occurs every expedition.
What was your chosen difficulty level? Hard
What Javelin were you using when the issue occurred? Storm
What was your Expedition team makeup? Friends
Where did this issue occur? Please include menu name or in game location. At the start of every expedition. As I load in to the map.
When did this happen? (dd.mm.yy hh:mm)
Summarize your bug My consumables don't get consumed like they're supposed to. I always have them equipped, but they don't get used. And I can't see the effects they add to my gameplay. It's almost like the game doesn't register that they're equipped and that's also why the amount I have never goes down after an expedition.
How often does the bug occur? Every time (100%)
Steps: How can we find the bug ourselves? It must be random because my friends don't have this issue. We have compared screenshots and my equipped consumables look exactly the same as theirs. However, theirs get used/consumed and mine do not.
What happens when the bug occurs? A box pops on the screen that says the following, "Connection Problem" "There was a problem with the payment information provided." But the game and/or whatever session I load into works fine. The only problem is that my consumables don't get consumed.
What should be happening instead? I should naturally be seeing the effects of my consumables that I have equipped before matchmaking.

To summarise:

 

- I correctly have my consumables equipped before any type of expedition (freeroam/strongholds/missions/contracts)

- I join/start the expedition and my consumables don't get consumed.

- When I check back to see if the consumables were used, I still see the same number on the consumable. That means it wasn't used.

 

Message 2 of 16 (380 Views)

Connection Problem there was a problem with the payment information provided.

★★★★ Novice

Product: Anthem
Platform:PC
Please specify your platform model. PC
AMD or Nvidia Model Number RTX 2070
Enter RAM memory size in GB 16
Please select your region North America
Were you on an Expedition when the issue occurred? Yes
What type of Expedition were you on when the issue occurred? Freeplay
What was the name of the Mission / Contract / Stronghold you were on? Every mission
What was your chosen difficulty level? Hard
What Javelin were you using when the issue occurred? Interceptor
What was your Expedition team makeup? Mix of the above
Where did this issue occur? Please include menu name or in game location. At the start of every expedition
When did this happen? (dd.mm.yy hh:mm) Every day since launch
Summarize your bug Every time I load up a mission I get a Connection Problem error that states There is an issue with the Payment information Provided. All of my information is accurate and accounted for on Origin and in game.
How often does the bug occur? Every time (100%)
Steps: How can we find the bug ourselves? I can include a picture
What happens when the bug occurs? I have connection problems and disconnect frequently due to it.
What should be happening instead? Playing this game.

Every mission I get this picture and disconnect and reconnect frequently with this screen continuing.

Message 3 of 16 (358 Views)

Re: Connection Problem there was a problem with the payment information provided

[ Edited ]
Community Manager

@kirosho6002 @RLnoskill @SimplyChaos919 @iiTekz_v2 @Lordsimmons1 @rekam 

 

Please make contact with an EA Game Advisor so we can look into this for you.

 

Click the following link to get started: https://help.ea.com/en/contact-us/

 

For help with contacting an Advisor, please see this link: https://help.ea.com/en-us/help/faq/contact-ea-help/

 

Thanks.

--------------------------------------------------------------------------------------------------
If a post Answers your question please click on Accept as Solution.
Thank players and help them 'Level Up' by giving them XP.
Thank you for sharing your gaming expertise with your fellow players!
Message 4 of 16 (336 Views)

Re: Unable to consume consumables in mission/freeroam/strongholds

★★★ Newbie

This problem also happens to me with my Storm only on the Xbox One X.

Message 5 of 16 (339 Views)

Connection Problem - payment information

★★★★ Novice

Product: Anthem
Platform:Sony Playstation 4
Please specify your platform model. Sony PlayStation 4 Slim
Please select your region North America
Were you on an Expedition when the issue occurred? Yes
What type of Expedition were you on when the issue occurred? Mission
What was the name of the Mission / Contract / Stronghold you were on?
What was your chosen difficulty level?
What Javelin were you using when the issue occurred? Ranger
What was your Expedition team makeup? Mix of the above
Where did this issue occur? Please include menu name or in game location. Start of mission
When did this happen? (dd.mm.yy hh:mm) 05.03.19 EST
Summarize your bug Nonsensical notification upon beginning a mission
How often does the bug occur? Every time (100%)
Steps: How can we find the bug ourselves? Start a mission
What happens when the bug occurs? Nonsensical notification upon beginning a mission
What should be happening instead? There should not be a notification popping up

Every time a mission begins, I have a popup notification that says: "Connection Problem. There was a problem with the payment information provided." I have to click "X" for Okay and then the notification goes away, until I start a new mission. The game functions fine, there is no connection problem. I don't understand what they are talking about, "the payment information provided". There are no continuing payments in this game. The game is purchased once, and then there are no additional payments. Playstation has not said anything about any problems with my payment, I only get this notification in the game, and it only started happening a few days ago. I bought the game via preorder many weeks ago, so it's strange to get this notification appearing now.

Message 6 of 16 (360 Views)

Re: Connection Problem - payment information

★★★★ Novice

Here is photo

Message 7 of 16 (358 Views)

Re: Connection Problem - payment information

★★★★★ Newbie

Same thing is happening to me on Xbox One 

Message 8 of 16 (341 Views)

Connection Error - Problem with Payment Info

★★★★ Novice

Product: Anthem
Platform:Microsoft XBOX One
Please specify your platform model. Microsoft Xbox One
Please select your region North America
Were you on an Expedition when the issue occurred? Yes
What type of Expedition were you on when the issue occurred? Mission
What was the name of the Mission / Contract / Stronghold you were on? Forrest of Dawn and First Response
What was your chosen difficulty level? Normal
What Javelin were you using when the issue occurred? Ranger
What was your Expedition team makeup? Friends
Where did this issue occur? Please include menu name or in game location. As soon as my javelin lands when starting a mission. Or contract.
When did this happen? (dd.mm.yy hh:mm) 03.03.19 01:00 and 03.07.19 20:20
Summarize your bug "Connection error - there was a problem processing payment information provided" or something along those lines. I've never tried to purchase anything. The first time I got this error, it kicked me from the cutscene after legion of dawn. Consider making the videos replayable in the messages or something.
How often does the bug occur? Occasionally (10% - 49%)
Steps: How can we find the bug ourselves? No idea. It's when I load in.
What happens when the bug occurs? Get error. Hit a. Continue. No idea if it effected my cut scene or not.
What should be happening instead? Not get an error. Load normally. Not glitch out of a cutscene.

Product: Anthem
Platform:Microsoft XBOX One
Please specify your platform model. Microsoft Xbox One
Please select your region North America
Were you on an Expedition when the issue occurred? Yes
What type of Expedition were you on when the issue occurred? Mission
What was the name of the Mission / Contract / Stronghold you were on? Fortress of Dawn and First Response
What was your chosen difficulty level? Normal
What Javelin were you using when the issue occurred? Ranger
What was your Expedition team makeup? Friends
Where did this issue occur? Please include menu name or in game location. As soon as my javelin lands in game, both mission and contract.
When did this happen? (dd.mm.yy hh:mm) 03.03.19 01:00 And 01.03.19 20:20
Summarize your bug I get the error "connection issue - there was a problem processing payment information provided" or something like that. I've never even tried to buy anything!!! Last time I got the error, it completely dropped me from the cutscene after fortress of dawn, which you can't replay videos in case you didn't know.
How often does the bug occur? Occasionally (10% - 49%)
Steps: How can we find the bug ourselves? Talk to prospero before you launch? There seems to be no rhyme or reason.
What happens when the bug occurs? Game play is fine, screws with cut scenes, I'm guessing.
What should be happening instead? Launch normally. Not get an error. Not lose cut scenes

Message 9 of 16 (340 Views)

Re: Wrong payment info

[ Edited ]
★★★★★ Newbie

@EA_Barry @rekam @Lordsimmons1 @SimplyChaos919 @RLnoskill 

 

I was having the same issue for about 2 days. The payment message would pop up every time I started any type of event. I was also having the problem with my consumables not being applied to my character at the start of missions. 

 

I removed all 3 consumables from my character since they were useless anyway and BAM, no more payment method pop ups. Hasn’t happened to me since. Still sucks I can’t use consumables for some reason but at least the pop up went away!! Hope this helps!

Message 10 of 16 (290 Views)

fifa-18-promo-circle

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

all-ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help