Help us improve Answers HQ! Take Survey No, Thanks

[WORKAROUND] Objects Stuck off Lots

by keekee53
Reply

Original Post

Highlighted

Re: Item is stuck off lot

★★★★ Guide
@jessdiaz01 Have you tried bb.moveobjects on? That solved the problem for me when I accidentally placed a cow plant outside a lot.
Message 31 of 38 (394 Views)
Highlighted

Re: cowplant grew off lot and can't delete it

★ Novice

what is MOO?

 

Message 32 of 38 (374 Views)
Highlighted

Re: Item is stuck off lot

★ Novice

Yes many times... does not work

Message 33 of 38 (373 Views)
Highlighted

Re: cowplant grew off lot and can't delete it

[ Edited ]
★★★★ Guide

@jessdiaz01MOO (or sometimes MO on) is short for moveobjects on. Bummer that it doesn’t seem to work for you though. :/

Message 34 of 38 (368 Views)
Highlighted

cant pick up a violin and it is really annoying

★ Novice

Product: The Sims 4
Platform:PC
Which language are you playing the game in? English
How often does the bug occur? Every time (100%)
What is your current game version number? latest version
What expansions, game packs, and stuff packs do you have installed? all expansion packs apart from island living, vampires and tiny living
Steps: How can we find the bug ourselves? make a sim play an instrument outside your house, (in my case violin)
What happens when the bug occurs? i cant get rid of it no matter what i do
What do you expect to see? i should be able to find a tool that lets me find the owner of it (i forgot the owner or the game doesnt register the sim as its owner) and add them to family, pick it up, and remove from family
Have you installed any customization with the game, e.g. Custom Content or Mods? Not now. I've removed them.
Did this issue appear after a specific patch or change you made to your system? Neutral/Not Sure 

I don't know why but someone put a violin down in front of my sixam base, now either I don't remember who owns it or the game doesn't register the people as It's owner, I've tried every alien, because it was an alien who did it, I've looked everywhere for a solution but everything i tried did not work.

Message 35 of 38 (288 Views)
Highlighted

Re: [WORKAROUND] Objects Stuck off Lots

★★★★ Novice

Just had this happen to me in Sulani. A townie placed a violin just outside my sim's lot, left, and when I tried to bring that townie over to the lot to delete it, it suddenly didn't register him as the owner even though he was the one that put it there, and didn't register my sim as the owner. Apparently nobody's the owner. And it's just sitting there on the sand...

What makes this even worse is that the townie stole that violin from my sim in the first place when they were roommates in University... my sim put his Virtuoso violin down instead of placing it into his inventory (that needs to be default for instruments, seriously) and the townie roommate picked it up and put it in HIS inventory. He taunted my sim with it every time he came over to visit, until now.

Now it's stuck, just outside of my sims' reach. Taunting him forever.

If I ever get back into modding for the Sims, first thing I'm going to do is create townie repellant for Uni called "DON'T TOUCH MY STUFF!"

Message 36 of 38 (199 Views)
Highlighted

Re: [WORKAROUND] Objects Stuck off Lots

★★★★★ Apprentice
@aresvallis I have a couple examples. The first example is this one neighbor who keeps sitting on the bench down the street and using her tablet. One time she put it down and then left. The tablet was on the ground for weeks. My other example is the little community areas littered around the neighborhoods. No matter where it is it's the same; Sims BBQ plates and plates of food and leave garbage everywhere from the food stalls. What's worse most of the time you can't interact with it!
Message 37 of 38 (147 Views)
Highlighted

Re: [WORKAROUND] Objects Stuck off Lots

★★ Newbie
So I had this same issue and I tried every method in the book (including all of the suggestions on this thread) and nothing worked! Then I came across my own discovery and it was a VERY SIMPLE SOLUTION!



First thing to do is to turn on these cheats within the game: 

[ testingcheats on ] +

[ cas.fulleditmode ]



Shift + click on the sim of your choosing and select Modify in CAS. Equip the sim with the Kleptomaniac Trait. 



Travel to any lot other than your home. I chose Pepper's Pub, the bar closest to the ritual grounds. Take your klepto sim over to the ritual altar and click on the object that is stuck. 



There should be an option that reads "Attempt to Swipe". AS LONG AS THERE ARE NO OTHER SIMS AROUND (this is important, otherwise you can't steal the item, your sim will be humiliated and embarrassed, and shame will be brought upon your entire family.. Well... Not your family) YOU SHOULD BE ABLE TO TAKE THE ITEM. There normally isn't anyone in that area unless there's a Celebration ritual going on [10pm - 2am] so this should work. 



You are welcome & I really hope this works for you all!



Happy Simming!

-MzWhizKid 
Message 38 of 38 (50 Views)