Help us improve Answers HQ! Take Survey No, Thanks

[WORKAROUND] [MSP] Camera keys not working in photo mode (QE, WASD)

by KariRaiha
Reply

Original Post

Re: Camera Keys Q and E not working as they should be

★★ Novice

Great, I'm glad you got it working! That is odd, I'm not sure why it would be doing that. Maybe selecting to invert the horizontal camera rotation would fix it in the game camera settings? For me the A pans to the left and the D to the right and my W and S move the camera forward and back. Lol I just realized that I can move around the entire room with the camera while taking a photo, I thought the W and S were zooming in and out. But I couldn't find anything in the PhotoCamera.ini or Camera.ini files that could be causing the inversion. Maybe deleting the cache files again and restarting the game will fix it?

Message 71 of 84 (201 Views)

Re: Camera Keys Q and E not working as they should be

★★★ Novice

I don't know how to clear cache, the weird thing is that in the cinematic mode i dont have this inverted  thing with S and D 

Message 72 of 84 (198 Views)

Re: Camera Keys Q and E not working as they should be

[ Edited ]
★★★★★ Apprentice

@WriteToLive Oh my goodness! ^_^ After months and months of waiting, and then eventually giving up on EA's ability to get this fixed, YOU'VE SOLVED IT! Thank you so much for sharing this! I too am having issues with A + D being inverted, A moving me to the right, and D to the left, but I can live with that because you found a way to bring back the feature that I was most excited to always use! Thank you so much! 

Message 73 of 84 (177 Views)

Re: Camera Keys Q and E not working as they should be

[ Edited ]
★★ Novice

@xjfo411x XD Glad I could help!

Message 74 of 84 (171 Views)

Re: Camera Keys Q and E not working as they should be

[ Edited ]
★★ Novice

@ConyoK @xjfo411x That's so odd though that the controls are inverted for those two keys. The only thing I can think of that might make it different is if you're using the Sims 3 vs Sims 4 camera (although I doubt that) or if you inverted the vertical or horizontal camera rotational. I don't have the issue, but I do have my vertical camera rotation inverted. I did mess with other settings in the Camera.ini, but it was mainly to slow down the camera movement speed and the rotational distance. But maybe I did change something else that affected it. Or a keyboard layout issue? It's odd that it only affects the photo camera view though. I'll keep looking through the .ini files to see if I may have changed something else that could have affected that. Maybe try inverting the horizontal camera controls in the game camera settings and see if that helps?

Message 75 of 84 (168 Views)

Re: Camera Keys Q and E not working as they should be

★★★★ Guide

@WriteToLive  I must congratulate you on your fine discovery and thank you for sharing it here with us! Good show!

 

I've done the changes to the .ini file and the tripod is finally worth using once more! Absolutely marvelous!

 

I do suffer from the same problem as mentioned earlier though, namely the inversion of the horizontal camera keys. In addition, I found that the slider underneath the camera controls stops functioning as well (the one that lets you rotate and orbit the camera around the subject). This, however, is all completely acceptable and still a great workaround for this most annoying "bug". For reference, I use the Sims 4 camera and do not have any inversion enabled in options.

 

And what a massive slap in the face this is for the team over at EA! These people are so shamefully incompetent that they can't even tweak existing settings in their own software! If I were them right now, I'd die of embarrassment like a sim...

 

 

Message 76 of 84 (130 Views)

Re: Camera Keys Q and E not working as they should be

★ Apprentice

@WriteToLiveMAJOR PROPS. Thank you for helping this issue! I also have the issue where the A and D buttons are reversed, but the core functionality is there!

 

 

Message 77 of 84 (105 Views)

Re: Camera Keys Q and E not working as they should be

★★ Novice
@ConyoK Sorry, forgot to reply to the cache part!

To do this, go into the Documents\Electronic Arts\The Sims 4 folder and delete the Config.log file, the localthumbcache.package file, and any other log files or files with "exception" in the filename.

Also delete the spotlight_en-us.package file (depending on your language, the filename will vary slightly) inside the cachestr folder, but leave the cachestr folder.

If you also have the cache folder, delete the files in there as well, but leave the folder.

Delete the entire onlinethumbnailcache folder (not related, but never hurts to delete it to refresh things).

Beyond the exception files, the game will generate a fresh copy of all of the other files you deleted upon starting.
Message 78 of 84 (103 Views)

Re: Camera Keys Q and E not working as they should be

★★ Novice
@jred250 Sweet! I'm trying to replicate the issue in my game to find what's causing it, so as soon as I figure it out I'll let everyone know. Just to be sure, did you already clear the cache and delete the config.log file in the Sims 4 folder in your documents? Just in case anyone wasn't sure which files to delete, I updated my post to include that info. Sometimes they can cause issues after a change, but it may not fix the issue. One way or another I'll track it down though. Are the sliders at least working? The bottom slider stopped working for DMDragonCT, but I'm hoping it's an isolated issue.
Message 79 of 84 (96 Views)

Re: Camera Keys Q and E not working as they should be

★★ Novice
@DMDragonCT I'm relieved it's at least somewhat working for you, sorry those other issues have cropped up! I'm trying to replicate them in my game to find what's causing it, so as soon as I figure it out I'll let everyone know. I'm sure you did but never hurts to double-check, did you clear the cache and delete the config.log file in your Documents\Electronic Arts\The Sims 4 folder? Just in case anyone wasn't sure which files to delete, I updated my post to include that info. Sometimes they can be the problem after a change is made, but not always. But it doesn't hurt to remove those files either way. Rest assured, I will track down the cause of the inversion (and the slider in your case)! I must have changed something in the Camera.ini file as well after I fixed the PhotoCamera.ini file that took care of that before it could happen. But it was a little odd that the issue with the camera height has been unresolved for a year and it mainly has to do with that one setting be set to 0. I was totally flabbergasted that that was all it took to fix it for me. You would think the developers would be familiar enough with the code to know that setting was there. Surely they could have put out a patch that could have updated that and any other related settings, or at least posted how users could fix it themselves. It was probably just too low of a priority.
Message 80 of 84 (87 Views)