Help us improve Answers HQ! Take Survey No, Thanks

Re: Camera Keys Q and E not working as they should be

by WriteToLive
Reply

Original Post

Re: [PARTIAL FIX] [MSP] Camera keys not working in photo mode (QE, WASD)

★★★ Apprentice

The anniversary of this persisting bug will be in just 4 more days.

Since we didn't get a fix in the december 7th update, maybe we can get one earlier next year?

 

Message 61 of 84 (671 Views)

Re: [PARTIAL FIX] [MSP] Camera keys not working in photo mode (QE, WASD)

★ Guide
@KariRaiha Does seem a long time to fix something that on face value should be simple and quick...
Message 62 of 84 (661 Views)

Re: [PARTIAL FIX] [MSP] Camera keys not working in photo mode (QE, WASD)

★ Apprentice

Hey Sims team, how is it going?

 

Just a friendly reminder that this feature is still broken. Just to clarify, when using the "Take Photo" interaction on the tripod, you used to be able to have free camera control like when using the TAB button for free cam. KariRaiha has a great write up of what functionality we are expecting with post #56.

 

This was broken over a year ago in the December 2019 patch. It is really important for those of us who like to use the Moschino pack or those of us who just like to take photographs of our Sims. Please fix this.

 

 

Message 63 of 84 (558 Views)

Re: Camera Keys Q and E not working as they should be

[ Edited ]
★★★★★ Novice

 


Marked as Solution for Visibility. This is still an open issue.


There seems to be a really easy fix for this, at least it fixed it for me.

 

Originally I had the same issues everyone else has had with not being able to adjust the height of the camera when using the tripod. I noticed though that in the PhotoCamera.ini file (the one located at \wherever your base games files are\Game\Bin_LE\res) that at the very bottom of the text in the file, third to last line, is a setting called "TripodUseFreeCam".

 

I kid you not, all I did was change the value there to 1 and after that I was able to use Q and E again when taking pictures with the tripod camera. I had the previous version (1.69.59) when I did this and I currently have the most current patch, and it still works just fine.

 

You can edit the file with any standard text editor, like notepad or notepad++ and just save it. I used Notepad++ so I didn't have to worry about checking to be sure it remained an .ini file when I hit save, so if you're worried just do Save As and check that the file type is still .ini before you hit save.

 

I did this for the PhotoCamera.ini file in both the Bin and Bin_LE folders, but if you have the 64-bit version installed you can just modify the PhotoCamera.ini file in the Bin folder. That was all I did to get the buttons to work again.

 

I recommend deleting the cache files and a few others that could cause issues afterwards. It's good to do this from time to time anyways, I do it every time I close the game.

To do this, go into the Documents\Electronic Arts\The Sims 4 folder and delete the Config.log file, the localthumbcache.package file, and any other log files or files with "exception" in the filename.

Also delete the spotlight_en-us.package file (depending on your language, the filename will vary slightly) inside the cachestr folder, but leave the cachestr folder.

If you also have the cache folder, delete the files in there as well, but leave the folder.

Delete the entire onlinethumbnailcache folder (not related, but never hurts to delete it to refresh things).

Beyond the exception files, the game will generate a fresh copy of all of the other files you deleted upon starting.

 

Some users are having issues with the A and D button functionalities inverting only while using the tripod and the bottom slider may not work, but you can replicate that functionality using WASD to move around and the mouse to direct the view. I'm not sure why it's causing that, but I'm working on figuring out the issue and I will hopefully find out the problem soon. The issue may possibly persist in the Flash Studio, but if you have Ksuihuh's AEP mod (adult film star career mod), you can choose (as the photographer) take erotic photo option on the flash studio and it will function exactly like the fixed tripod does. Or you can manually set up a photo studio with the separate components from build mode (you'll probably need to use the cheat bb.showhiddenobjects to see them).

 

I really hope that this fixes it for anyone else who has had issues with using the tripod.

 

EDIT by crinrict: Added solution banner for info

Message 64 of 84 (1,154 Views)

Re: Camera Keys Q and E not working as they should be

★★★ Apprentice
@WriteToLive Alright I'll be honest with this.
This actually does fix the whole problem...
Hats off to you WriteToLive for fixing a problem that is over a year old.
Now how come someone from the community tells us there is a fix that is as easy as to change two zeroes to ones in an ini file, but EA didn't even tell us that this ini with the setting "TripodUseFreeCam" exists?
Message 65 of 84 (432 Views)

Re: Camera Keys Q and E not working as they should be

★★★ Novice

It didn't fixed it for me, i still can't move freely when i hit the tab button using the tripod Devil

Message 66 of 84 (407 Views)

Re: Camera Keys Q and E not working as they should be

[ Edited ]
★★★★★ Novice

@ConyoK Oh no, you don't hit the tab button when using the tripod, although it should still work even if the tab button is pressed since I just tested it to see if it mattered. Just to be doubly sure, you saved both PhotoCamera.ini files with the TripodUseFreeCam = 1 and checked that both files are still saved as .ini files? I'm sure you did, but it never hurts to check again in case something went wrong and the file didn't save the new value.

 

If both of those files are correct, you can try deleting the cache file and a few others that might be causing the fix to not register. Whenever I make any changes to the game files, I go into the Sims 4 folder in my documents and I always delete the spotlight file in the cachestr folder (if you also have the cache folder, delete the files in there as well), the entire onlinethumbnailcache folder (not related, but never hurts to delete it to refresh things), the Config.log file, the localthumbcache.package file, and any other log files or files with exception in the filename. Beyond the exception related files, the others will regenerate when the game is started.

 

You don't happen to be using any mods? I've got a ton of mods on mine, so it may not be that, but if you're using one that also utilizes the tripod camera, there might be something related to that causing it to not work.

 

 

Edit: Ah sorry, I'm wondering if I misunderstood. Do you mean move freely as in move exactly you like can when you hit the tab button when not using the tripod camera? Or that you can't change the height of the camera when taking a photo using Q and E?

Message 67 of 84 (400 Views)

Re: [PARTIAL FIX] [MSP] Camera keys not working in photo mode (QE, WASD)

[ Edited ]
★★★★★ Novice

@IngeJones @jred250 I replied to another user that with the possible fix for this, it worked for me as well a couple other users. But it's super simple and might solve the issue for you as well.

Message 68 of 84 (398 Views)

Re: Camera Keys Q and E not working as they should be

★★★★★ Novice
@KariRaiha Awesome! I'm so glad it worked for you too!
Message 69 of 84 (397 Views)

Re: Camera Keys Q and E not working as they should be

[ Edited ]
★★★ Novice

I can change the hight with Q and E, i cant move freely when hitting tab, it doesnt work anymore.

Its stoped working last year.

OMFG, editing both .ini get the freecam to work again with tripod ! THANK YOU SO MUCH !!!

EDIT: for some reason S and D is inverted, S make the cam move to the right and D to the left, its weird 

Message 70 of 84 (384 Views)