Help us improve Answers HQ! Take Survey No, Thanks

Todays daily challenge not working

by Cyy_56
Reply

Original Post

Todays daily challenge not working

★★★★ Newbie

Product: Anthem
Platform:PC
Please specify your platform model. PC
AMD or Nvidia Model Number NVIDIA GeForce GTX 1070 Ti
Enter RAM memory size in GB 16
Please select your region North America
Were you on an Expedition when the issue occurred? Yes
What Javelin were you using when the issue occurred? Interceptor
What type of Expedition were you on when the issue occurred? Mission
What was your Expedition team makeup? Random Freelancers
Where did this issue occur? Please include menu name or in game location. Under the challenges tab for the daily challenges
When did this happen? (dd.mm.yy hh:mm) 2/16/2019 10:00am
Summarize your bug My daily challenges are not being registered. I have killed elites and completed combos, but I am not getting credit toward the daily challenge
How often does the bug occur? Every time (100%)
Steps: How can we find the bug ourselves? Not sure
What happens when the bug occurs? I don't complete the daily challenges and miss out on the rewards
What should be happening instead? I should be getting progression toward the daily challenge completion

See info above

Message 1 of 4 (206 Views)

Re: Todays daily challenge not working

★★★★ Newbie

[Solved] I misunderstood that the daily challenges are earning feats and not just completing combos, elite kills, etc. This is not a bug and I have since solved the issue. If anyone else is confused on what feats are. when you are in freeplay or a mission, if you hit 'i' you can see you're current progress toward earning a feat.

Message 2 of 4 (193 Views)

Re: Todays daily challenge not working

★★★★ Novice
So any feat? Mine says elite?
Message 3 of 4 (161 Views)

Re: Todays daily challenge not working

★★★★ Novice

On the topic of feats, I can't find any information on this, but for me and my friend who play together in the same house, we can't see, track, or earn expedition feats at all.. This has been happening for the past two days. Are you, or anyone else having this issue? We can't see feats in or out of expedition and no matter what we do, can't get a single one. The first two days of the early release the feats worked fine for us, but have changed more recently. 

Message 4 of 4 (122 Views)

fifa-18-promo-circle

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

all-ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help