Help us improve Answers HQ! Take Survey No, Thanks

Re: Pilot data error solved, but lose all progress!

by vektork

Original Post

Pilot data error solved, but lose all progress!

★★★★ Novice

Product: Anthem
Platform:Microsoft XBOX One
Please specify your platform model. Microsoft Xbox One X
Please select your region Europe
Were you on an Expedition when the issue occurred? Yes
What type of Expedition were you on when the issue occurred? Mission
What was the name of the Mission / Contract / Stronghold you were on? All of them
What was your chosen difficulty level? Grandmaster 1
What Javelin were you using when the issue occurred? Storm
What was your Expedition team makeup? Mix of the above
Where did this issue occur? Please include menu name or in game location. Everywhere
When did this happen? ( hh:mm) From the day one
Summarize your bug 50 % of my games where affected by pilot data error, after a long chat on Twitter with da help we made all the protocol, without solving anything. After that they asked to make a New pilot. It works perfectly, but... what about my original pilot??? Can you debug it? Seems corrupted since the newone work perfectly 100% of games. I dont want to redo all the game come on... please help me!
How often does the bug occur? Often (50% - 99%)
Steps: How can we find the bug ourselves? Start a mission with my original pilot
What happens when the bug occurs? During the first 15 seconds of any kind of mission i'm kikked out of the game with pilot data error.
What should be happening instead? Go on with a mission.

My original pilot gives pilot data error. The newone works perfectly, but I'm level 30 with legendary and everything, Its impossibile for me to redo everything. Please help me!

Message 1 of 4 (87 Views)

Re: Pilot data error solved, but lose all progress!

★★★★ Novice

Hi Vektork

I experienced the same "workaround" yesterday evening (CET), but on PC, after spending 5 days with hardware/software troubleshooting. Tried new pilot as a last resort, and I'm currently lvl 4, without any issues.
Like you, I would very much appreciate to have my "corrupt" pilot repaired, as I don't wish too have wasted noumerous hours on getting to lvl 30 and grinding for MW and Leg's.

During my troubleshoot, I noticed that I could force a freeze by equiping my weapon(read: fire the weapon). SO, the items(e.g. weapons) might be the root cause for the corrupted data!?

I really hope the DEV's are looking through these posts, as I would very much like to play the game again, without having to start from scratch again.

BR. DimZumDK

Message 2 of 4 (64 Views)

Re: Pilot data error solved, but lose all progress!

★★★★ Novice

Updates: also the new pilot starts to giving pilot data error since I started to change Javelin's colors and materials. Start to lose hope in the future of this game. 

A lot of people are experiencing this issue and no one is giving us any kind of feedback.

The only feedback is -80 buks in my wallet.

Message 3 of 4 (56 Views)

Re: Pilot data error solved, but lose all progress!

★★★★★ Apprentice

I have had this too on PC. Mainly from freeplay, were you disconnect with "Unknown Error" followed by reconnect with "Pilot data read error" resulting in losing all your loot from that session. My connection is still up and working and happening more often - more like demo days.

Message 4 of 4 (49 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help