Help us improve Answers HQ! Take Survey No, Thanks

[OPEN] [JA] "Mail back Artifact" sometimes don't give money

by 99publicidentity
Reply

Original Post

[OPEN] [JA] "Mail back Artifact" sometimes don't give money

[ Edited ]
★★ Guide

Product: The Sims 4
Platform:PC
Which language are you playing the game in? English
How often does the bug occur? Occasionally (10% - 49%)
What expansions, game packs, and stuff packs do you have installed? all
Steps: How can we find the bug ourselves? 1. Have 6+ sims who have higher level in archaeology. 2. Receive some artifact from mailbox. 3. Authenticate all artifacts(1 sim - 1 artifact - 1 workbench) * 6+. 4. After eveyone is done, click each artifact and select "Mail back Artifact".
What happens when the bug occurs? Sometimes(30%+), the artifact disappeared but it didn't give me money.
What do you expect to see? When the item disappeared, add a money to the household funds.
Have you installed any customization with the game, e.g. Custom Content or Mods? Not now. I've removed them.
Did this issue appear after a specific patch or change you made to your system? No

Text

Message 1 of 9 (2,299 Views)

Re: [OPEN] [JA] "Mail back Artifact" sometimes don't give money

Hero
Added

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 2 of 9 (2,235 Views)

Re: [OPEN] [JA] "Mail back Artifact" sometimes don't give money

★★★ Guide

I have this issue, but I think it only happens if I ignore these artifacts long enough. Maybe it's intended and we are not getting money for being not fast enough? Standard smile

Message 3 of 9 (2,201 Views)

Re: [OPEN] [JA] "Mail back Artifact" sometimes don't give money

★ Novice
I wonder if the issue is Sims authenticating artifacts that weren't meant for them? I have two Sims receiving artifacts in the mail. I'll try turning it off for one of them and see if I still experience the bug.
Message 4 of 9 (2,080 Views)

Re: [OPEN] [JA] "Mail back Artifact" sometimes don't give money

[ Edited ]
★★ Guide

I've encountered this issue, too. It usually occurs for me if they authenticate two artifacts they can get money from on the same day/within 24 hours. They get paid for the first one, but the second one is being ignored when they send it back. 

Message 5 of 9 (2,074 Views)

Re: [OPEN] [JA] "Mail back Artifact" sometimes don't give money

★ Guide

I too thought this was intended, as it usually only happens to artifacts that haven't been looked at quick enough, but the game doesn't always follow that rule. It's definitely somewhat buggy if it is intended, as sometimes brand new artifacts won't be paid for either. 

Message 6 of 9 (2,051 Views)

Re: [OPEN] [JA] "Mail back Artifact" sometimes don't give money

★ Pro
I've been having this issue for a long time. Even I had this issue yesterday.
Message 7 of 9 (1,325 Views)

Re: [OPEN] [JA] "Mail back Artifact" sometimes don't give money

[ Edited ]
★★★★★ Apprentice

Happens to me too Frown Usually when I sell the artifact while I'm on pause.....

Message 8 of 9 (1,312 Views)

My sim randomly earns nothing after the autorization of artifacts

★ Pro

Product: The Sims 4
Platform:Mac
Which language are you playing the game in? English
How often does the bug occur? Occasionally (10% - 49%)
What is your current game version number? Mostly my sim earns money about 3k to 4k simoleons after mailing back the artifact but sometimes he doesn't earn money from it
What expansions, game packs, and stuff packs do you have installed? All packs but Island Living, Outdoor Retreat and a couple of stuff packs.
Steps: How can we find the bug ourselves? Sometimes, I notice the artifact doesn't show any info after authorization and earn 0 simoleons after mailing it back.
What happens when the bug occurs? Sometimes, I notice the artifact doesn't show any info after authorization and earn 0 simoleons after mailing it back.
What do you expect to see? I want my sim earns money every time he authorize the artifact
Have you installed any customization with the game, e.g. Custom Content or Mods? Not now. I've removed them.
Did this issue appear after a specific patch or change you made to your system? Neutral/Not Sure 

 

I tested this for a long time because it doesn't happen every time but it does occasionally.

 

 

4.jpg

 

 

5.jpg

 

6.jpg

 

 

This time has no bug. This is a normal process.

 

 

 

 

 

8.jpg

 

Here is another one.

Discoverer is named in Korean language as I got a new sim from other Korean simmer.

So this is not important.

 

 

 

 

10.jpg

 

After authorization, there's no info about the artifact. I took this screenshot with my phone because capturing on computer can't catch the mouse cursor.

 

 

 

 

9.jpg

 

I mailed it back and NO Money..in.

 

I tested this without cc and mods, with cc and mods but it was turned out the same.

It randomly happened, so I forgot to capture this without mods and ccs.

Recently, with other bugs, I repair the game in orgin so often, so repairing the game in origin wouldn't cure this bug i guess.

 

 

 

Message 9 of 9 (866 Views)