Help us improve Answers HQ! Take Survey No, Thanks

Closed rooms not registering as closed

by Astaraya
Reply

Original Post

Re: Roof Won't Place/Ceiling Disappears

★★★★ Novice

Sorry for the late reply, but i was able to fix my issue today after remembering to check in. Like a previous poster said, the ceiling was glitching out because on that same level I had a section of glass roofing. Upon removing that section the ceiling stopped glitching out. The glass roofing was not on the same section of the house (a separated garage out back) but was on the same level.

 

In my original pictures you can also see a glass roof section (within a small fence room with the floor removed so I had an open hole for the skylight) which contributed to the issue. So in order to replicate, glass roofing needs to be on the same level of the floor in order to see the issue. Whether this presents itself in every game is another matter altogether, but now i know how to stop it in mine. Just sad that the glass roofing did this too me

Message 31 of 52 (137 Views)

Re: [OPEN] Disappearing Ceiling

★★★★★ Newbie

I encountered this problem on the 64x64 Magnolia Blossom Park in Willow Creek and I'm freaking out. I don't know what I have to do...

Message 32 of 52 (77 Views)

Re: [OPEN] Disappearing Ceiling

★★★★★ Newbie

I had the same problem for some time, and I didn't bother taking my mods out as I had everything updated and checked as often as possible, but some previous answers are right. If you are having this problem, this is caused by glass roofs. Just put something else than glass of those roof parts and it will go back to normal. After you are finished building, just put the glass texture back where you want glass roofs.

Message 33 of 52 (48 Views)
Highlighted

Closed rooms not registering as closed

[ Edited ]
★★ Novice

I'm in the process of building an estate on a 64x64 lot. I've built several buildings already on the lot, but the latest one is having difficulties in creating a building for some reason? I've tried deleting the building and rebuilding it and it still doesn't seem to register as a closed room. Sometimes, when I'm on the second level, and I scroll in, the ceiling randomly disappears. 

 

Edit: I went in to decorate one of my other buildings that was built before i encountered this problem, and the floor doesn't register anymore. I can't place an object in the room. :/ 

Edit 2: attached screenshots

Message 34 of 52 (278 Views)

Re: Closed rooms not registering as closed

[ Edited ]
★ Pro

@Astaraya Can I clarify a few things? 

 

  • Do you use Mods or CC?
  • When did this problem start? Was part of the building(s) created before the patch on 8-8-19? If any were built before the patch are they behaving any differently?
  • When you see the roof disappear (include a screenshot of this part also, if possible) are you in Camera 3 or Camera 4, and are you panning in, panning up/down, etc.? Any details on this would be helpful.
  • Are you on Mac or PC?
  • Which packs do you have?
  • Can you include a screenshot(s) of the issue?

Retrace a room: If your room does not highlight as a whole when you click on the wall, if you retrace the room this will normally fix this and rebuild the floor and ceiling. I have made a demo of how to retrace a room at this link: https://youtu.be/rx__MGVGMnc

 

To make sure a room is complete or rebuild a ceiling (or floor): When you try to recreate the building you're having issues with, please make sure that all rooms are successfully creating the floor and ceiling and that the game is seeing each as a complete room. This can be checked by clicking on the wall of each room and seeing if the entire  perimeter of the room highlights. If the ceiling is missing, or part of it, you can (while the room is highlighted) go to the level above and click the yellow rim and select 'build ceiling'. Likewise, if a floor is missing you should be able to highlight the room and click the yellow rim around the bottom perimeter of the room and select to 'build floor'.

 

There is a current bug report that I would like you to read and see if it sounds similar to what you are dealing with and in what ways:
https://answers.ea.com/t5/Bug-Reports/NEEDS-INPUT-Floor-Transparent-to-Cursor/m-p/8073946#M100099

 

I made a demo video where I reproduced the issue for that bug report. Can you please watch the demo to see if this is what is happening for you in your building, and if so in what ways: https://youtu.be/8INwCReJ40Q

 

Thank you! I look forward to your reply and further details! 

Message 35 of 52 (247 Views)

Re: Closed rooms not registering as closed

★★ Novice
  • I'd turned off all my CC when I was building this house, and when I encountered the glitch I took out all my mods just to make sure that it wasn't because of my mods, and it isn't. 
  • This problem started yesterday after I had built a house perfectly fine on the same lot earlier. 
  • I'm in Camera 4. Most times the floor appears to be there but when placing roofing or objects, it doesn't register. If I scroll a certain way or if I'm hovering on an object in the ui, the floor disappears sometimes. Screenshots are attached
  • I'm on PC
  • I have get together, cats and dogs, vampires, seasons, laundry day stuff, romantic garden stuff and the free holiday stuff pack 
  • The bug report that you linked to seems to be pretty much what I'm dealing with. 

Thanks. Standard smile 

Message 36 of 52 (222 Views)

Re: Closed rooms not registering as closed

★ Pro

@Astaraya Would you please upload your build to the gallery so that I could have a look in my game? You could upload it and name it something like 'glitch test' and either send me a link to it in the online gallery or your gallery username and the exact name of the lot in the gallery. Thank you!!

Message 37 of 52 (206 Views)

Re: Closed rooms not registering as closed

★★ Novice

Hi, the online gallery isn't showing my lot as uploaded just yet, but my gallery name is this same username, "Astaraya" and I called it "glitch test". The half finished building in the back and the pool area are where I experience the glitch whereas the "garage" area has the floor knocked out on the second floor intentionally. 

Message 38 of 52 (198 Views)

Re: Closed rooms not registering as closed

★ Pro

@Astaraya Got it! I will have a look. Thanks!

Message 39 of 52 (189 Views)

Re: Closed rooms not registering as closed

[ Edited ]
★ Pro

@Astaraya I have made you a video of my findings. Good news is on one of the buildings when I re-traced the room the room sealed and everything worked as expected. The not-so-good news is the other building is showing some the flooring glitch issues that have a bit of the dynamics of the one bug report I sent you, but it is actually reminding mr more of the flooring bug that we have been tracing since Island Living. I am not positive if it began with the patch that was a few days before IL came out or if it came with the pack, but I noticed it when beginning a build with the pack that week. There is suspicion that the glass floor tiles from Island Living &/or the stilt foundation contributed to the issue, but I am very interested in your build since it contains neither, and you do not have Island Living. I am going to consult with Crinrict and other helpers to determine if we should merge your information with the other bug report. I will let you know about that shortly.

 

Video confirming the issue & showing a workaround: https://youtu.be/OJNYrU6REtY

 

In the meantime... there is also a workaround for the other building that I show you in the video, so I think that will help you be able to finish the build to it is functional. Thank you for sharing your build and for your patience!!

Edit: I'm on Mac. No Mods or CC.

__________________________


Coffee cup If we were able to help …. awesome! That’s what we’re here for!
•  Accept As Solution – if a comment answered your question

•  Me Too – if you also have this problem – first post has this button
•  XP – for helpful comments (& to help others 'level up')

Message 40 of 52 (172 Views)

Need help?

We’re happy to help with your account, troubleshooting, and gameplay questions.

Contact us on EA Help

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help