[OPEN] [DU] Contribute knowledge research archive machine not fulfilling

by medleytw300

Original Post

[OPEN] [DU] Contribute knowledge research archive machine not fulfilling

[ Edited ]
★★★ Newbie

Product: The Sims 4
Platform:Microsoft XBOX One
Which language are you playing the game in? English
How often does the bug occur? Rarely (0% - 9%)
What is your current game version number? Sims 4
What expansions, game packs, and stuff packs do you have installed? All current expansion and stuff packs
Steps: How can we find the bug ourselves? Knowledge Aspiration (senior scholar) task: contribute knowledge on a research archive machine.
What happens when the bug occurs? I have accomplished this task 4 or 5 times now, and have even received payment of 300 + simoleons for doing so, but I am not receiving credit, i.e. golden check mark or aspiration points for this task.
What do you expect to see? I want to be able to fully achieve this aspiration so that I can move on to my next knowledge aspiration of choice (either need brain, or master of occult)...
Have you installed any customization with the game, e.g. Custom Content or Mods? Never used.
Did this issue appear after a specific patch or change you made to your system? Neutral/Not Sure 

  • WTF

Edit By Crinrict: Adjusted Tag

Message 1 of 10 (7,704 Views)

Re: Knowledge Aspiration Not Fulfilling

[ Edited ]

@medleytw300  There is no reason whatsoever preventing you from changing aspirations and returning to try again later.  The game allows that with no penalty.  I've also found that sometimes if you change aspirations after something like what you describe, when you come back it will be yellowed out and marked complete.  Not always, just sometimes.  I have noticed that beginning a few packs ago that many of the aspirations are really slow about giving credit.  It seems to depend on the sim too as some seem to get credit faster than others.  Also I noticed in my game sometimes the aspiration will complete on it's own and give you full credit if you've done everything else.  The one you are working on though takes time to complete as you have to finish university and get a job using your degree. 


Some aspirations will give you credit even if they are not the one you have currently assigned - like the 2nd tier one in the romantic aspiration where you have to have 3 first kisses.  For others you do have that be in the one currently assigned - like the knowledge aspiration to read 3 books.  If really differs between aspirations.


I have also read somewhere recently either here or at the main site that there is currently something going on with certain types of aspirations and it only affects certain sims.  I've got one of those and every time he does something that has a count, like the athletic milestone to exercise 10 hours, I get an LE and the counter does not increment.  No fix or workaround on that yet as far as I know. 


Edit:  Sorry I didn't notice that you were on XB1 when I replied.  I'm playing on a PC.  So you might be experiencing something a little different, but the aspiration system is the same on both as far as I know so what I have said should still be good.

Message 2 of 10 (7,641 Views)

Re: Knowledge Aspiration Not Fulfilling

[ Edited ]

@medleytw300 I tested this on PC and didn't have an issue fulfilling this.

Treating this as XB1 issue for now but if you could test another Sim, that'd be great. There's been a few aspiration issue that only happened to certain Sims and not to others (depending on Skills, traits, occultism)

- Is your Sim some kind of occult ?
- Was this the only task you had issues with ?



Also could you post your Sims 4 version number. Current for console is 1.21. I think for console you need to use the version cheat to find out what you have. No other option.

Good Luck


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.

Important Threads

Message 3 of 10 (7,632 Views)

Re: [XB1] [DU] Contribute knowledge on a research archive machine not fulfilling

★★★ Newbie

I am also having this problem, but on PC. I have done it several times and have received money but it doesn't count towards my aspiration. I don't have another sim to try it with, with the skills. I don't use any mods or cc. I have tried switching aspirations as well.

Message 4 of 10 (7,510 Views)

Re: [XB1] [DU] Contribute knowledge on a research archive machine not fulfilling

★ Pro

What skill did you contribute? Writing is currently missing from the objective requirement list.

Message 5 of 10 (7,487 Views)

Re: [XB1] [DU] Contribute knowledge on a research archive machine not fulfilling

[ Edited ]
Community Manager (retired)

Marked as Solution for Visibility Purposes Only


Could anyone experiencing this issue possibly share a save file? We've been unable to reproduce thus far, it'd be a huge help. You can DM the link to me, thanks for the help!



This account is no longer accepting Direct Messages. If you need to send a Direct Message, please send it to TheSimsDirect. Thank you.

Message 6 of 10 (7,115 Views)

Re: [XB1] [DU] Contribute knowledge on a research archive machine not fulfilling

Hero (Retired)

I just had this happen on PS4 not too long ago. I took my sim (The premade Becca) to the library in Britechester to work on this part of her aspiration, and it didn't fulfill. I went into build mode and replaced the machines at the library with new ones and the knowledge counted afterwards.


This was the first time I tried using the library for this task, I usually just have a research machine on my sim's lot and haven't ever had an issue with the contribution not counting for the aspiration.

Message 7 of 10 (6,454 Views)

Re: [XB1] [DU] Contribute knowledge on a research archive machine not fulfilling

★★★★ Apprentice
@kusurusu Oh that was it for me, thanks! Even though it doesn’t make any sense... Thank you!
Message 8 of 10 (6,267 Views)

Re: [XB1] [DU] Contribute knowledge on a research archive machine not fulfilling

★★ Novice

I know this thread is three years old at this point but I would like to state I was also unable to contribute knowledge using the writing skill, attempting multiple times.  It worked on first try wiht cooking after reading the suggestion here to try any other skill except writing.  

Message 9 of 10 (2,467 Views)

Re: [XB1] [DU] Contribute knowledge on a research archive machine not fulfilling

EA Sims Team
Hello @katr1183

If you are still encountering this (without mods), would you be willing to share your save file(s)?

If so, please send me a private message with a link to the file.

Instructions here: http://x.ea.com/74420

Message 10 of 10 (2,430 Views)