Help us improve Answers HQ! Take Survey No, Thanks

[NEEDS SAVES] [ROM] "Always use transportalate" gets Sims stuck

by Malornus
Reply

Original Post

Highlighted
Accepted Solution

[NEEDS SAVES] [ROM] "Always use transportalate" gets Sims stuck

[ Edited ]
★★★★ Novice

Product: The Sims 4
Platform:PC
Which language are you playing the game in? English
How often does the bug occur? Every time (100%)
What is your current game version number? 1.55
What expansions, game packs, and stuff packs do you have installed? All
Steps: How can we find the bug ourselves? Turn on spell, travel to a new lot (went from the realm of magic to the bar in new neighbourhood) and attempt to move sim around the lot.
What happens when the bug occurs? Sim resets.
What do you expect to see? For them to teleport to selected location.
Have you installed any customization with the game, e.g. Custom Content or Mods? Never used.
Did this issue appear after a specific patch or change you made to your system? Neutral/Not Sure 

So while messing around with all of the new stuff, I had my guinea pig sim have the "always use" option turned on for the transportalate spell. Had him leave the realm of magic to check out the bar in the new neighbourhood and after arriving, he never left the spawn location. Was able to cast some spells (decided to perform some mischief on the poor souls there from afar) but then I noticed he couldn't introduce himself to a sim that was inside. Checked on him and he kept resetting. Wasn't until I turned off the "always use" option that he was able to go about his business as usual.

 

 

Error code for reference:

Spoiler
<desyncdata>Exception in Sim Timeline: Exception running Element (AttributeError: 'NoneType' object has no attribute 'animation_outcomes')&#13;&#10;Traceback (most recent call last):&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\scheduling.py", line 212, in simulate&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\elements.py", line 376, in _run&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\interactions\base\teleport_interaction.py", line 311, in _perform_teleport&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\teleport\teleport_helper.py", line 86, in generate_teleport_sequence&#13;&#10;AttributeError: 'NoneType' object has no attribute 'animation_outcomes'&#13;&#10;rtim=0</desyncdata>

 

Message 1 of 14 (1,180 Views)

Accepted Solution
Highlighted

Re: [RoM] "Always teleport" ability doesn't work

[ Edited ]
EA Sims Team

Post marked as Solution for Visibility Purposes Only

 

Is anyone still seeing this issue? If so, could you possibly share a save file? Thanks for the help!

 

http://answers.ea.com/t5/The-Sims-4-Bug-Reports/INFORMATION-How-to-Send-User-Files-to-The-Sims-4-Tea...

View in thread

Message 14 of 14 (264 Views)

All Replies
Highlighted

Re: Unable to move after traveling to new lot with "always use transportala

Hero
@Malornus Can you reproduce this each time or was it a one time thing ?

Happy Gaming
Crin


Trennlinie


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.

Please only contact me via PM when asked to do so.


Important Threads


Message 2 of 14 (1,165 Views)
Highlighted

Re: Unable to move after traveling to new lot with "always use transportala

★★★★ Novice

Multiple times. I fiddled with it for a little while. I had done a save and exit when he was stuck like that for the third or fourth time and reloaded game (was curious) and the error continued to pop, same thing happened when i tried clearing cache before loading game up again. Seems the only way to shake it off is to disable the "always use" option and just use the spell manually.

Message 3 of 14 (1,161 Views)
Highlighted

Re: Unable to move after traveling to new lot with "always use transportala

Hero
@Malornus I didn't personally have any issues.

Could you try a fresh to see if it's related to your save ? Is that a new save you started with the pack ?

Happy Gaming
Crin


Trennlinie


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.

Please only contact me via PM when asked to do so.


Important Threads


Message 4 of 14 (1,156 Views)
Highlighted

Re: Unable to move after traveling to new lot with "always use transportala

[ Edited ]
★★★★ Novice

Yes it was a new save. If anything I imported one of my premade sim's that I have up on the Gallery, so there's a chance that one of his reward traits (which he has many of) or skills (part of me is thinking the meditation one) have something to do with it. Possible that it's coming from something else from the Spellcaster perks. Haven't gotten around to testing it on a fresh sim, but was after I first noticed it, it was happening all the time on that save for him.

 

 

UPDATE:

So fiddled some more. Tested on a new save and a sim I randomly threw together in CAS. Tried to reproduce it and everything worked as it should. Dropped in a new copy of the premade sim I was testing the pack with and made him a Spellcaster as well as cheated his spells. Went to reproduce and no issue. So decided to load up the save I was having the issue in and, to my surprise, the issue wasn't showing itself. However, I still had an older copy of that save where he was having issues right at the save point. The issue still remained there. So not entirely sure what's going on there now. I guess it managed to correct itself at some point during that save, but only later on as I can still make it happen with older copy of the save.

Message 5 of 14 (1,153 Views)
Highlighted

Re: Unable to move after traveling to new lot with "always use transportala

Hero

Would you be willing to share your save with me ?

 

If so, please zip your saves folder and upload it somewhere like dropbox,, googledrive or OneDrive and PM me the link.

Happy Gaming
Crin


Trennlinie


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.

Please only contact me via PM when asked to do so.


Important Threads


Message 6 of 14 (1,091 Views)
Highlighted

[RoM] "Always teleport" ability doesn't work

[ Edited ]
★ Guide

Product: The Sims 4
Platform:PC
Which language are you playing the game in? Русский язык
How often does the bug occur? Every time (100%)
What is your current game version number? Latest
What expansions, game packs, and stuff packs do you have installed? All of them
Steps: How can we find the bug ourselves? Learn the teleport spell, choose to always teleport from the sims' menu, try to teleport anywhere
What happens when the bug occurs? Sims get experience for using magic but doesn't teleport (stands around)
What do you expect to see? Teleport spell teleporting
Have you installed any customization with the game, e.g. Custom Content or Mods? Not now. I've removed them.
Did this issue appear after a specific patch or change you made to your system? Neutral/Not Sure 

"Always teleport" ability doesn't work. Learn the teleport spell, choose to always teleport from the sims' menu, try to teleport anywhere in Magical world. However, simple teleportation choosing from the spells' menu works. "Always teleport" may sometimes work after reloading or going to another location

Additional info:

1. My sim is a ghost

2. His "spellmeter" is full most of the time - but obviously he won't die from it as he is already dead.

Message 7 of 14 (1,121 Views)
Highlighted

Re: [RoM] "Always teleport" ability doesn't work

[ Edited ]
Hero

@rostsit Tested this and it's working for me even with a ghost.

The interaction does seem to have a tendency to get stuck though.

 

https://answers.ea.com/t5/Bug-Reports/Unable-to-move-after-traveling-to-new-lot-with-quot-always-use...

Can you try if reloading the game helps ?

Also didn't have the spell meter issue. Could you post a picture though ? It's turning orange when it full. It can be mistaken for looking full when it's empty.

 

 

Happy Gaming
Crin


Trennlinie


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.

Please only contact me via PM when asked to do so.


Important Threads


Message 8 of 14 (1,097 Views)
Highlighted

Re: [RoM] "Always teleport" ability doesn't work

★ Apprentice

One of my friends had this issue when Realm of Magic came out. Reloading and repairing the game helped. I think I read somewhere that it has happened to non-ghost Sims as well, but I'm not completely certain. I hope you get it fixed soon, good luck!

Message 9 of 14 (1,093 Views)
Highlighted

Re: [RoM] "Always teleport" ability doesn't work

★ Guide
@crinrict I will try reloading. And there is no issue with a spell meter, it works as it should
Message 10 of 14 (1,084 Views)