Help us improve Answers HQ! Take Survey No, Thanks

[NEEDS SAVES] [JTB] Arresting Someone (First Order) gets stuck

by WellThatWasDumb
Reply

Original Post

Re: [OPEN] [JTB] Arresting Someone (First Order) gets stuck

[ Edited ]
★★ Novice

I was having this problem, too, and what snapped my Sim out of it was going into First Person more. It's worked for me twice, but both times on the same ID Check/NPC Sim, so it might be that this NPC Sim is glitches out. Either way, I thought, ya know, might as well throw it out there, how I got around this.

 

Bear in mind, though, that I'm doing my Simming on PS4, so I dunno how or if it might work on other consoles/PC.

 

Edit: this worked twice in the First Order District. However, I got stuck once more, but in the Black Spire district. The First Person switch isn't working this time. I think it's the same Sim, though (ironically, the Sim I always get for Lightsaber Challenges), so my running theory is that he's bugged, since I've successfully escorted another Sim, in this district.

 

Edit x2: I was able to wait out the last instance of Check ID/Escort getting stuck. Can't wait for that to get patched out...

 

TL;DR - I know which tasks I'm not doing anymore, lol.

Message 21 of 37 (1,061 Views)

Re: [OPEN] [JTB] Arresting Someone (First Order) gets stuck

★ Guide

Same problem, on PC, no mods/cc, have everything except the knitting pack. I don't have a droid yet. Fight does happen, it's as soon as you're meant to actually escort the prisoner that the game glitches out. Have tried the resetsim cheat, and it'll cancel the action, but the game still refuses to work because it's convinced someone is still being escorted.

Message 22 of 37 (1,037 Views)

Re: [OPEN] [JTB] Arresting Someone (First Order) gets stuck

[ Edited ]
★★★ Novice

I can get all the way through the fight and to the point of escorting the prisoner... then we freeze. It doesn't matter if I have a Droid or anything else, my sim and the one being arrested freeze.

 

There is no motive decay but time still passes. I can reset both sims as many times as I would like but the game will not recognize it.

 

The only way I have found to "fix" it is to click on the energy motive to trigger my sim to sleep on their own, this somehow resets them and the game let's me click on things and save again.

 

The only issue is, I can't progress my aspiration now without cheating it because I can't make the arrest to complete the milestone.

 

Now, because I don't care enough to wait for this one sim, I'm going to just cheat that milestone, but it is a fair warning for anyone who doesn't wish to do so.

Message 23 of 37 (988 Views)

Re: [OPEN] [JTB] Arresting Someone (First Order) gets stuck

★★★ Newbie
@WellThatWasDumb I had the same problem. I noticed you could still click on the control panel. I didnt have a career at the time so I got a job and it reset the game.
Message 24 of 37 (955 Views)

Re: [OPEN] [JTB] Arresting Someone (First Order) gets stuck

★★ Novice

I have the same bug on ps4

Message 25 of 37 (853 Views)

Re: [OPEN] [JTB] Arresting Someone (First Order) gets stuck

EA Sims Team

Could anyone experiencing this issue possibly share a save file with me? You can DM me the link to your save, thanks for the help!

 

Instructions for sending me your save: http://answers.ea.com/t5/The-Sims-4-Bug-Reports/INFORMATION-How-to-Send-User-Files-to-The-Sims-4-Tea...

Message 26 of 37 (789 Views)

Re: Batuu First Order Escorting Glitch

★★ Novice
@MightyDeathBall If you add the sim you were supposed to escort to your family using testingcheats it cancels escorting and you can give actions to your sim, after that you can delete the sim you added from your family
Message 27 of 37 (747 Views)

Re: Batuu First Order Escorting Glitch

[ Edited ]
★ Guide

Product: The Sims 4
Platform: PC
Which language are you playing the game in? English
How often does the bug occur? Every time (100%)
What is your current game version number? 1.68.156.1020
What expansions, game packs, and stuff packs do you have installed? All except Snowy Escape and Moshicino Stuff pack.
Steps: How can we find the bug ourselves?
What happens when the bug occurs?
What do you expect to see?
Have you installed any customization with the game, e.g. Custom Content or Mods? Never used.
Did this issue appear after a specific patch or change you made to your system? it was only happening after i installed the star wars journey to batuu expansion. This also happened to me before november 10th patch.

 

Oh yes...i remember running into this issue. I basically had my game sit there for like 10 minutes..i thought it was taking long time to arrest a person..lol. I ended up cancelling it in the end, and finally the person got arrested. I did this without using cheats.It was strange they got arrested after i cancelled the action.

 

This bug happend before the november 10th patch, so this bug was in previous versions.

Message 28 of 37 (649 Views)

Re: [NEEDS SAVES] [JTB] Arresting Someone (First Order) gets stuck

★★★ Apprentice

So I was at the Black Spire Outpost, looking for humans to recruit to the First Order (That's a whole other problem lol) when I "checked ID", not realising it would result in my Sim arresting them. Fight happened, then... Nothing. Then everything I clicked on came up with "This interaction is unavailable because a sim is being escorted." The only thing that worked for me, after rage-clicking on everything, was to click on the energy button in the Needs menu. My Sim found a bench to nap on, and when she woke, everything went back to normal. I immediately saved my game! I hope this works for others Standard smile

Message 29 of 37 (531 Views)

Re: [NEEDS SAVES] [JTB] Arresting Someone (First Order) gets stuck

★★★★ Apprentice

Somebody knows if the new patch has fixed this issue?

Message 30 of 37 (387 Views)