Help us improve Answers HQ! Take Survey No, Thanks

Re: Mod lock for GA not working

by lifeisagame007
Reply

Original Post

Accepted Solution

Mod lock for GA not working

[ Edited ]
★★★★ Novice

Product: Star Wars: Galaxy of Heroes
Platform:Android Phone
What type of device are you experiencing the issue with? Essential PH-1
OS Version Android 9
Ally Code: (Find it here: http://bit.ly/AllyCode ) 336-215-397
What type of issue do you have? Gameplay
How often does the bug occur? Occasionally (10% - 49%)
Summarize your bug Mods not locked in attack phase of GA
Steps: How can we find the bug ourselves? Before player lock mod team Set defense When attack phase starts remove mods Attack with them team that had mods removed
Connection Type Mobile
Please select your region Europe
Country UK

I had this issue in last TW, where I have gone into the battle and opponent team went before me even though I had faster mods.

 

I thought at first maybe I forgot to arrange mods before player lock.

 

So this time in GA I double checked mods of my team and opponent team in attack screen of GA and it showed mods I equiped before player lock.

 

However once in battle the opponent went first and my team was very slow like they had no mods equiped.

 

This was my Revan counter team, now I will loose this round because of this annoying bug.

Message 1 of 38 (1,273 Views)

Accepted Solution

Re: Mod lock for GA not working

EA Star Wars: Galaxy of Heroes Team
Hi all, thanks for all the info provided. We've flagged this as a bug and currently looking into it.

View in thread

Message 27 of 38 (1,550 Views)

All Replies

Re: Mod lock for GA not working

★★★★ Novice

So I tested this in my other account (ally code 834-936-418) and had the same issue. As I was expecting it I actually recorded the battle to show the bug.

 

https://youtu.be/MdYMMUZp__U

 

Note that my BB8 is at 307 speed and R2 at 306, meaning that BB8 should go first, then R2, then Thrawn. But this does not happen, Thrawn goes first, and my droids plus Rey are super slow!

 

Glad I had the same issue with my other account just to get confirmation I am not making this up Standard smile

Message 2 of 38 (1,241 Views)

Re: Mod lock for GA not working

★★ Apprentice

There is another report of the same problem here:

https://answers.ea.com/t5/Bug-Reports/Mods-stats-not-properly-locked-at-start-of-GA-despite-displayi...

 

Myself and my guild mates had the same issue also and have to make sure that we put the mods back on when attacking.  I am not positive, but it might also be an issue for defensive teams.

Message 3 of 38 (1,215 Views)

Re: Mod lock for GA not working

★★★★ Novice

Thanks for sharing Standard smile

Message 4 of 38 (1,201 Views)
Highlighted

Re: Mod lock for GA not working

★★★★ Novice

I can't believe this was posted already back in January and didn't make it into general public Standard smile

Message 5 of 38 (1,198 Views)

Re: Mod lock for GA not working

★★★★ Novice

Just experienced this issue. 

 

I'm running zEP, Tarkin, Vader, TFP and Imperial Probe Droid. When I long press on my Vader inside the GA screen, it showed that I had 251 speed according to the mods locked at the beginning of the GA.

 

Opponent is running zEP, Tarkin, Vader, TFP and Royal Guard. His Vader is 221 speed. Should be an easy win. However, somehow his 221 speed Vader starts before mine?

 

I've got no mods on Vader at the moment outside GA, but didn't think that mattered as it occurred after lock.

 

Ally code 153 686 766

 

 

Message 6 of 38 (1,154 Views)

Re: Mod lock for GA not working

EA Star Wars: Galaxy of Heroes Team

Hi all, thanks for the report. As it happens I've been removing mods and equipping Zetas to different characters during the current Grand Arena event, and so far I haven't been able to reproduce any of the issues that players are reporting with Grand Arena (mods not locked after player lock, Zeta upgrades done after player lock active, etc).

I am actually recording all the changes I make during the current GA event and taking notes in which phase and on which date I've made these changes.

 

Maybe I am making these changes at the wrong time, so I would encourage you if possible, to try to make videos like the one @lifeisagame007 made clearly showing each character's Speed in GA as well as making a note of the date when you made these changes. It might help us get to the root of the issue.

 

@lifeisagame007 Thanks for the video. After looking at it, my understanding is that your Grand Admiral Thrawn should have taken the first turn as he is the fastest character (317 Speed as shown in your video). Looks like it's working as intended.

 

The speeds I noticed in your video were the following:

 

Enemy team:

(Leader) Jedi Knight Revan - 182 Speed

Jolee Bindo - 158 Speed

Bastila Shan - 156 Speed

Mission Vao - 146 Speed

Zaalbar - 136 Speed

 

Own team:

Grand Admiral Thrawn - 317 Speed

BB-8 - 307 Speed

R2-D2 - 306 Speed

(Leader) Jedi Training Rey - 275 Speed

Kylo Ren - 162 Speed

Message 7 of 38 (1,132 Views)

Re: Mod lock for GA not working

[ Edited ]
★★★★ Novice

@EA_MindTricks thanks for looking into this but Thrawn should NOT go first, even though he had higher speed.


That's due to BB-8 unique ability 'Self-Preservation Protocol' where 'At the start of each encounter, if BB-8 is active, Droid allies gain 8% Turn Meter for each active Droid ally' BB-8 and R2 should gain 16% bonus TM at the start. Meaning they should go first, I use this team and mods every time in TW an GA so I know the exact sequence.

 

Therefore this is NOT working as intended.

 

Also if you look closely at their TM at the start it is way lower than Thrawns, as if they had no mods equiped at all.

Message 8 of 38 (1,114 Views)

Re: Mod lock for GA not working

[ Edited ]

An alternative view on the scenario above, is the enemy Revan's lead preventing the TM gain from BB-8's unique at the start of the encounter? It should only be blocking TM from enemy leads, so if it is doing this then there's a bug there. In the video, all characters attack in the order of the mod speeds, suggesting BB-8's unique hasn't be taken into account.

As said above, BB-8 should have an effective starting speed of 365 speed and move first.

__________________________________________________________
I am a volunteer on this forum, and not an employee of EA or CG, and happy to help in any way that I can.
Message 9 of 38 (1,101 Views)

Re: Mod lock for GA not working

[ Edited ]
EA Star Wars: Galaxy of Heroes Team

Oh yes, you're right. I didn't take BB-8's unique into account.
@lifeisagame007 Do you remember when you changed the mods and on which characters after player lock for the current GA? It must have been Round 1 in the Attack or Setup phase.

Message 10 of 38 (1,092 Views)

GET SUPPORT AS YOU PLAY

Find and tap Contact Support in-game under Settings, or contact us on EA Help.

Contact EA Help

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help