Help us improve Answers HQ! Take Survey No, Thanks

Mark of Ruin not working

by KaiSPACER
Reply

Original Post

Highlighted

Mark of Ruin not working

★★★★ Novice

Product: Anthem
Platform:PC
Please specify your platform model. PC
AMD or Nvidia Model Number 2080 ti
Enter RAM memory size in GB 32gb
Please select your region North America
Were you on an Expedition when the issue occurred? Yes
What Javelin were you using when the issue occurred? Storm
What type of Expedition were you on when the issue occurred? Freeplay
What was your Expedition team makeup? Random Freelancers
Where did this issue occur? Please include menu name or in game location. Any expedition
When did this happen? (dd.mm.yy hh:mm) 2/18/19 12:00
Summarize your bug Legendary storm component "Mark of Ruin" special text effect will not activate. I have tried it with multiple gear loadouts. I have fully depleted the ability so it is on cooldown.
How often does the bug occur? Every time (100%)
Steps: How can we find the bug ourselves? Equip Mark of ruin
What happens when the bug occurs? Nothing
What should be happening instead? While LB recharges, RB damage increases by %20 for 20 seconds

It worked at first, but then  stopped

Message 1 of 1 (305 Views)

fifa-18-promo-circle

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

all-ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help