Help us improve Answers HQ! Take Survey No, Thanks

Initial Speed in TW Battles doesn't match

by Salaryman96
Reply

Original Post

Highlighted

Initial Speed in TW Battles doesn't match

[ Edited ]
★★★★★ Novice

Product: Star Wars: Galaxy of Heroes
Platform:Apple iPhone
What type of device are you experiencing the issue with? All
OS Version All
Ally Code: (Find it here: http://bit.ly/AllyCode ) 172-759-465
What type of issue do you have? Gameplay
How often does the bug occur? Often (50% - 99%)
Summarize your bug Initial Speed on Toons in TW doesn't match Speed during registration/displayed
Steps: How can we find the bug ourselves? Switch Mods of a TW registered toon after registration period is over.
Connection Type Mobile
Please select your region Asia
Country Japan

This happens only in Territory Wars. There, squads with their mods gets locked in into the war after a 24 hour signup time. Changes in the toon (Mods, Level, Gear) after this shouldn't be reflected.

 

When playing against opponents, comparing the speed of both sides highest toon as a good way to figure out, which toons get first. In a ZKru Lead setup against a zFinn Lead setup, I compared my fastest toons speed (Poe at 270) witch that of the opponent (zKru: 227 Speed base Speed + 30 from zKru leadership = 257).

 

  • This was the first battle against that opponent squad (no preloaded TM)
  • zKru of the opponent went first (Kylo or Phasma were slower, and no FOO that was faster and could have given TM).
  • Poe went even after my Scavenger Rey (Speed 251) despite he should go first.
  • What I did, is after the sign up for the TW to switch Mods of POE with another toon, which brought Pos Speed down to 239. It really looks that Poes Speed in the battles was not the 270 from the Mod-Set at the end of the registration period, but from the Mod-Set after the Registration Period.
  • The stats screenshots were taken right before the battle.

Other Players from my guild and players form other guild reported a similar behavior. I had this before also but didn't take screenshots then.

 

opponent.jpg
poe (fastest).jpg
zKru (second fastest).jpg
Message 1 of 10 (373 Views)

Re: Initial Speed in TW Battles doesn't match

★★★★★ Novice

Not seeing any feedback here, but I am convinced now we have a serious bug where the stats after TW lock down still can change, but visuals remain.

 

- This is completely new TW, the Team I fought was untouched and was fought definitely the first time.

- Again Resistance vs A Kru Setup

- Turn Order according to visual display (and what went into TW lock): Poe 274, Rey 253, KRU 221+30 = 251.

- Turn Order in Game: Rey -> KRU -> Poe. You can

- Poe was remodded to 239 after the TW lockout...

 

I would really like to see a response from CG/EA.

opponent.JPG
poe.JPG
kru.JPG
Message 2 of 10 (287 Views)

Re: Initial Speed in TW Battles doesn't match

★★★★★ Novice

And two additional screenshots for proof. You can see that Poes TM-bar has less speed than expected.

rey.JPG
first turn.jpg
Message 3 of 10 (286 Views)

Re: Initial Speed in TW Battles doesn't match

Was Scavenger Rey also remodded after the lockout? According to the screenshots she should have 253 to KRU 251...but that doesn't account for the speed bump (I believe it's +5) given to the defending team. I would have expected KRU to go before Scavenger Rey unless you dropped her speed by a couple of points after the lock.

Good sleuthing on this though! The Poe speed definitely seems to reflect post-lock changes and not matching the description.
_____________________________________________________________
I am a volunteer on this forum, and not an employee of EA or CG. Please let me know how I can help you!
Message 4 of 10 (253 Views)

Re: Initial Speed in TW Battles doesn't match

★★★★★ Novice

I don't think there is a speed bump for the defending team? Is that stated somewhere?

 

Rey wasnt remodded.

Message 5 of 10 (241 Views)

Re: Initial Speed in TW Battles doesn't match

It's always been in the game. Because the AI is usually worse than an active player, the defending team in all game modes gets a +5 speed boost. This is relevant in Arena and GW especially.

You can actually test it yourself in GW. Go into a node manually, check the speed of the fastest enemy. Then assign your characters who are all slower than him, and then use mods to increase the speed of your fastest character. If you increase your fastest character to 4 points above the fastest enemy, he should still go first. If they tie, it should be a 50/50 split. If you are 6 points faster, your character will go first.

I did these tests like a year and a half ago, but when I mentally add 5 speed to all opponents, it works out.
_____________________________________________________________
I am a volunteer on this forum, and not an employee of EA or CG. Please let me know how I can help you!
Message 6 of 10 (209 Views)

Re: Initial Speed in TW Battles doesn't match

There is definitely no speed bump to defending teams, nor do I believe there ever has been. To humor you, I DID test in GW. I recorded all the opponent speeds in node 1, and found a character in my inventory who was one speed faster. My character went first, with the 1 speed slower opponent near 100%.

Also, if this were happening in arena, it would be very well known.

I'm not sure what you did during your test from so long ago, but there was something you were not taking into account. Unless you mean it was 2+ years ago, when speed worked in ticks.
Message 7 of 10 (122 Views)

Re: Initial Speed in TW Battles doesn't match

I'll test it again later. The first node in my GW today has a Vader in it, and the math on Vader speed needs a degree in mathematics. So, to simplify I'll wait until I can kill GW nodes tomorrow (for guild activity) and test it there.

Maybe @EA_HighCommand could confirm whether the AI team gets a small speed bump, so we don't have to test it manually?

What do you mean "speed worked in ticks"?
_____________________________________________________________
I am a volunteer on this forum, and not an employee of EA or CG. Please let me know how I can help you!
Message 8 of 10 (107 Views)

Re: Initial Speed in TW Battles doesn't match

Don't concern yourself about the ticks comment, because it hasn't worked that way in over two years, yet there are still people trying to spread around that it still works that way.

But I assure you if defending teams were getting a +5 speed bump, the whole community would know. People are constantly checking speeds in arena, and the really competitive people will even sometimes remod to get a key character even 1 speed faster than an opponent. There are a lot of people who think speed is broken in arena, but the community is able to explain the mechanics to show it is working just perfectly...surely any speed boost would be caught here.

But I recommend you test for your own piece of mind. Try to record every unit and their speeds and ability kevels on both sides, and if you still think there's some discrepancy, post on the forums and I'm sure someone will figure out what's going on.
Message 9 of 10 (97 Views)

Re: Initial Speed in TW Battles doesn't match

Hey @crzydroid thanks for this! I tried it in GW yesterday, and my character with 1 more speed went first. You were right! Thanks for helping correct my misconception.
_____________________________________________________________
I am a volunteer on this forum, and not an employee of EA or CG. Please let me know how I can help you!
Message 10 of 10 (67 Views)

GET SUPPORT AS YOU PLAY

Find and tap Contact Support in-game under Settings, or contact us on EA Help.

Contact EA Help

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help