Help us improve Answers HQ! Take Survey No, Thanks

Failed Quick play Strongholds still gave me credit for Challenge of Valor

by the_effn_t
Reply

Original Post

Highlighted

Failed Quick play Strongholds still gave me credit for Challenge of Valor

★★★★ Novice

Product: Anthem
Platform:Sony Playstation 4
Please specify your platform model. Sony PlayStation 4
Please select your region North America
Were you on an Expedition when the issue occurred? No
Where did this issue occur? Please include menu name or in game location. The issue occurred when attempting to do quick play strongholds.
When did this happen? (dd.mm.yy hh:mm) 17.03.19 07:00 central (around that time and onward a few hours is when these occurred)
Summarize your bug I would choose to do a quick play stronghold at GM1 and after attempting matchmaking and a load screen, it would kick me back to enclave menu. On the next option I'm choosing often because as of that game play session it happened almost every time.
How often does the bug occur? Often (50% - 99%)
Steps: How can we find the bug ourselves? Choose stronghold quick play on GM1.
What happens when the bug occurs? It kicks me back to the enclave menu screen. An error message pops up. Not exactly sure the verbiage in the error message but something like "error connecting to EA live service" or "error retrieving data".
What should be happening instead? I should be connecting to a stronghold to fill in to one that had already begun from other players.

My progress in game had me trying to complete the Challenge of Valor. I had been getting completions on both the strongholds and quick play portions by doing the quick play strong hold. Up until yesterday, they had mostly been working. I was a few ahead on the strong hold so it was about 17/25 on strong holds and 13/25 for quick play. The issue started happening to where I would choose to join a quick play stronghold on GM1 and the animation would show for matchmaking, then it would think a bit as normal then a load screen would begin. This usually signifies it has found me a group that it will then join me up with. By comparison if it does not find me a match it goes back to the mission select and asks if I want to change the difficulty of the search. If that happens I usually select "back" and try again with GM1. But in this case it was giving me the load screen but then after progressing to almost done it would take me back to the enclave intro screen (not the game title screen where it says ANTHEM). Another thing is that even though this didn't happen always, sometimes I would hear the music that accompanies the end game XP victory screen. Also, I started receiving a message in my "inbox" that I was getting credited for XP and any rewards I had missed will be in the forge, etc etc. After about 6 of these, I checked my challenge status and I was getting credit for completions of both a stronghold and a quick play. 

 

I ended up being able to match into one stronghold but then it happened again. All in all I played one stronghold and failed about 10 times but because of that glitch it gave me credit for all my 25/25 strongholds and quick play.

 

To some that may be a quick shortcut to get the sweet vinyl that comes with that but I honestly wanted to play it through legit. I'm one of those grinders and completionists and this kind of activates my "ocd" about not completing it legit. 

 

So honestly I want this bug reported but maybe you can reset me back so I can do them legit? I did go in and finish my world events legit but just the strongholds and quickplay. Please look into this. Thanks. 

Message 1 of 1 (35 Views)

fifa-18-promo-circle

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

all-ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help