Help us improve Answers HQ! Take Survey No, Thanks

[FIXED] [XB1] Sound crackling and skipping

by hrdavey
Reply

Original Post

Accepted Solution

[FIXED] [XB1] Sound crackling and skipping

[ Edited ]
★★★ Newbie

Product: The Sims 4
Platform:Microsoft XBOX One
Which language are you playing the game in? English
How often does the bug occur? Every time (100%)
What is your current game version number? 1.26.54.2300
What expansions, game packs, and stuff packs do you have installed? All but luxury party stuff, perfect patio stuff and romantic garden stuff
Steps: How can we find the bug ourselves? Play game
What happens when the bug occurs? In live mode sound crackles and skips. Sound is fine in loading screens, when game is paused and when testing songs through game options.
What do you expect to see? Sound should work without crackling and skipping
Have you installed any customization with the game, e.g. Custom Content or Mods? On console - never used.
Did this issue appear after a specific patch or change you made to your system? Yes
Please describe the patch or change you made. Since Eco Lifestyle

Edit By Crinrict: Added Tag to Title

Message 20 of 118 (6,701 Views)

Accepted Solution

Re: Freezing, distorted audio

Hero

For our Xbox One Simmers, we have fixed an issue in which the audio was distorted after several hours of gameplay.


Fixed in Patch 1.70.84/ 1.37

If you're still experiencing this issue, please create a new thread.

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.


Important Threads

View in thread

Message 118 of 118 (474 Views)

All Replies

[XB1][ROM] Gamesound is messed up/sounds like static

[ Edited ]
★ Guide

Product: The Sims 4
Platform:Microsoft XBOX One
Which language are you playing the game in? English
How often does the bug occur? Often (50% - 99%)
What is your current game version number? 1.19.60.2300
What expansions, game packs, and stuff packs do you have installed? everything up to date (16th of October 2019)
Steps: How can we find the bug ourselves? Install RoM and play for a while?
What happens when the bug occurs? The sound is messed up, it sounds like static, it's the worst at the realm of magic (specially casters alley) but it also happens in other worlds.
What do you expect to see? for the sound to be normal, as before
Have you installed any customization with the game, e.g. Custom Content or Mods? On console - never used.
Did this issue appear after a specific patch or change you made to your system? Yes
Please describe the patch or change you made. installed RoM

nothin more to add.

Message 1 of 118 (5,652 Views)

Re: [XB1][ROM] Gamesound is messed up/sounds like static

[ Edited ]
Hero

@ra7orrat There's this issue for PC: https://answers.ea.com/t5/Bug-Reports/NEEDS-INPUT-ROM-Scary-magicky-sound-on-home-lot/td-p/8188643

Unclear if that's what you're hearing.

If not, could you maybe post a video with sound to illustrate what you hear ?

 

Also, could you please edit your game version number., The current one for console is: v1.19

 

So if you're all updated, you should have that.

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.


Important Threads

Message 2 of 118 (5,630 Views)

Re: [XB1][ROM] Gamesound is messed up/sounds like static

★ Guide

Hey,

 

updated the version number.

No, that is not what I am hearing, I'll try to make a video later.

Message 3 of 118 (5,618 Views)

Re: [XB1][ROM] Gamesound is messed up/sounds like static

★ Guide

Okay, so I played for a while yesterday and it didn't happen, but today it happend again, so here's a link to the video, hope it works.

 

https://1drv.ms/v/s!AvYGL-9xzZSAgwrhMCeSugEOKuhg?e=5CQ7gZ

Message 4 of 118 (5,595 Views)

Re: [XB1][ROM] Gamesound is messed up/sounds like static

Hero
@ra7orrat See what you mean.

I assume you only have this with the pack and it's not a hardware issue of some kind ?

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.


Important Threads

Message 5 of 118 (5,573 Views)

Re: [XB1][ROM] Gamesound is messed up/sounds like static

★ Guide

yes, outside of the sims4 my sound is fine, so it's not my console.

 
Message 6 of 118 (5,560 Views)

Re: [XB1][ROM] Gamesound is messed up/sounds like static

Hero
@ra7orrat OK. I'm very bad at this as I have no clue about consoles after talking others, can you check if you're using uncompressed Stereo ?

Settings - Display and Sound - Audio Output ? Does it make any difference if you change settings ?

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.


Important Threads

Message 7 of 118 (5,550 Views)

Re: [XB1][ROM] Gamesound is messed up/sounds like static

[ Edited ]
★ Guide

I got two option HDMI audio and Optical audio, they were both set to "stereo uncompressed" , I could only turn either one of them off but can not change to different settings (5.1 or 7.1 uncompressed) as my system does not support it.

I turned HDMI off now and will try it out...

 

Edit: HDMI off just turns my whole sound off, so I turned the optical audio off onstead and will try again

Message 8 of 118 (5,530 Views)

Re: [XB1][ROM] Gamesound is messed up/sounds like static

★★★ Newbie

I am also having this issue! I updated the game before RoM came out, the update that gave us the stairs configuration with landings, as well as the Muslim inspired clothing. It also added story mode and the new base Sims. After that update, I got RoM and the audio starts cutting in and out badly whenever I'm in Glimmerbrook or the Realm. Especially in Spell Caster's Alley, just like you said. I started in winter just now and the audio is cutting out like crazy thanks to the wind from the storm in the game. I want to solve this issue because gameplay is becoming annoying.

Message 9 of 118 (5,516 Views)