[FIXED] Some reward traits wrongfully say: Not available for robots

by hellaradveg

Original Post

Accepted Solution

[FIXED] Some reward traits wrongfully say: Not available for robots

[ Edited ]
★★★ Newbie

Product: The Sims 4
Which language are you playing the game in? English
How often does the bug occur? Often (50% - 99%)
What is your current game version number? 64 Bit
What expansions, game packs, and stuff packs do you have installed? University Parenthood Toddler Stuff Kids Room Stuff
Steps: How can we find the bug ourselves? Click on aspirations, then rewards store, then go to fertile trait
What happens when the bug occurs? Button is greyed out and unclickable, when I hover over it is says it’s not available for robots
What do you expect to see? I should be able to click the button and it should say redeem when I hover over it
Have you installed any customization with the game, e.g. Custom Content or Mods? Never used.
Did this issue appear after a specific patch or change you made to your system? Yes
Please describe the patch or change you made. Before I started the game it made me update it in origin

It hasn’t happened to every sim, just the two teenagers so far

Message 11 of 76 (17,979 Views)

Accepted Solution

Re: Some reward points say "Not available for robots" and I already bo


● Mouse hovering over purchased traits will no longer display the text “Not available for Robots.” We understand that Robots are sentient beings, but unfortunately, these traits are not robot compliant

Fixed in Patch 1.66.139/ 1.31


If you're still seeing this for any traits, please create a new thread.

Happy Gaming


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.

Important Threads

View in thread

Message 76 of 76 (2,426 Views)

All Replies

my sim is randomly a robot

★★★ Newbie

I loaded up an older game and tried to give one of the sims the fertile reward. I was told that I couldn't because that reward is Not Available for Robots. I did not make my sim a robot of any kind. This was an older save file. Downloading University shouldn't turn my sims into other things, right? And is there a cheat/action to make her a regular sim?

Message 1 of 76 (18,549 Views)

Re: my sim is randomly a robot

★★★ Newbie

I don't have University, but the same thing happened to me today. Most of the rewards I had on my Sim are missing from traits panel, but when I go back to purchase them again say "Not available for robots". 

Message 2 of 76 (18,490 Views)

Re: my sim is randomly a robot


@Diamond_Destiny8@captain_rogers90 , do either of you happen to use Mods or Custom Content (CC)? Wondering  If so, please do the following:


1) Move the Mods Folder to your desktop

2) Delete localthumbcache.package file in the game folder.

3) Fix you game in Origin by logging in and go to Library, then right-click on The Sims 4 and choose the "Repair Game" option from the list.  Wait until Origin finishes repairing all your packs and not just the base game.

4) Now, when you turn on your game again, it will create a new mods folder that will be empty.  Check to see if your game is now working without mods/CC.

5) Now you can try adding back items from your Mods folder one at a time checking your game each time to see which item is causing your game to not work properly.  If you have a lot of items, you can try the 50/50 Method. 

The CC creators will usually update the CC items and Mods after these updates, so when you find out which one is the culprit, you can get the updated version from whoever made that item of CC in the first place.  You should try these steps anytime you have problems in your game to rule out CC/Mods problems.  It is the responsibility of the Mods/CC creators to update their items anytime EA releases a patch/update, and it is the responsibility of the people who use Mods/CC to make sure they are using the most recent version. 

Now, if this doesn't work, there might be another problem with your game or this might be a bug.  But we have to rule out a Mods/CC problem first to determine that! Standard smile

Please reply back with an update!  Angel


CCP Champion Banner - Red.png

Message 3 of 76 (18,471 Views)

Re: my sim is randomly a robot

★★★ Newbie

Unfortunately I don’t have mods or CC. It’s probably a bug but hopefully raising awareness will get the devs to fix it!

Message 4 of 76 (18,461 Views)

Re: my sim is randomly a robot


@Diamond_Destiny8, thank you for replying1 Angel  That does help to have that ruled out!  I haven't heard if this is already posted as a bug in the Bug Report section or not, so it would be best if you posted your expireince there by filling out a Bug Report yourself!  https://answers.ea.com/t5/Bug-Reports/bd-p/The-Sims-4-Bugs  That way, other people with the same problem can add to it and it will be more likely to get fixed!Fingers crossed  Someone also might post a workaround solution there in the meantime. Standard smile


Best of luck and Happy Simming!Party hat

CCP Champion Banner - Red.png

Message 5 of 76 (18,425 Views)

Re: my sim is randomly a robot

[ Edited ]
★★★ Apprentice

I just got University yesterday and now my 1/2 alien Sim is getting that same notice on Rewards - "not available for robots"

My Sim is not a robot and I'm annoyed I've lost my alien traits!  

No mods/CC running 

Sounds like a bug to me. Hope someone has Fix or work around asap

Message 6 of 76 (18,212 Views)

Re: my sim is randomly a robot

[ Edited ]

@jezzabella2313, yes, I would be upset too if my Alien had lost their traits! Devil  
You stated that you don't have any Mods/CC "running".  Do you mean that you disabled them, or that you got rid of them, or that you never used them?


It often isn't enough to just disable Mods.  If you have ever used them and have not done the procedure I describe above , please try that as it will help remove any bits of corrupted data that might still be present.  If you have already done this, or if doesn't work, or if you have never used Mods/CC , it would probably be best if you filled out a Bug Report on this since It doesn't look like @captain_rogers90 or @Diamond_Destiny8  ever filled one out despite the suggestion to do so. Disappointed I could be wrong, but this does look like a bug. Here is the link to the Bug Reports section: https://answers.ea.com/t5/Bug-Reports/bd-p/The-Sims-4-Bugs
Please fill out the form so they can start trying to fix this! Angel Other people with the same problem can then add to what you posted! Thank you! Standard smile

CCP Champion Banner - Red.png

Message 7 of 76 (18,178 Views)

Re: my sim is randomly a robot

★★★ Newbie

My game did this too and I just updated it today because it’s been a while since I’ve played. I don’t have Discover University, but I do have Cats and Dogs, Romantic Garden Stuff, Parenthood, Spa Day, and Holiday Celebration Packs. I tried repairing my game and all packs and it didn’t work.

Message 8 of 76 (18,048 Views)

game thinks my child is a robot

★ Novice

I just logged into a game I have had for a few weeks now. I am unable to purchase satisfaction points for my HUMAN child because the store thinks he is a robot. Everything is grayed out and says "Not Available for Robots". How can I fix this issue?

Message 9 of 76 (17,912 Views)