Re: Issue with auto-solve (fun & energy) and Free will not working

by Daugue

Original Post

Re: Issue with auto-solve (fun & energy)

★ Apprentice

I too have this problem, and can't come up with a solution.


I've played about eight or nine households in the past couple days and have visited at least as many.  I don't use the 'fun' button, but do use the energy button.  


When changing households I notice that a small percentage of the sims will go to sleep, or nap automatically without me telling them too.  But after the first time, the majority of those will no longer choose to do it automatically, nor will the energy button work.  I've had a household that appeared to have the majority of the sims behaving like they should but I moved the beds to a new location, then no sims would rest automatically or with the energy button.  They would have a bed selected.  For the most part I have to manually click on a bed for the sim to sleep.


When I visit other households, there may be a very small percentage of sims who will go to bed automatically.  The rest of them just stand in one place until they pass out or until they have to use the toilet.  I think they would starve to death if I let them.  Once they wake up from passing out they stand there until they pass out again.  Painful to watch. Frown  


I use mods to automate things, and have not removed them.  I probably will since the game is no longer playable in this fashion.  I too do not micromanage every sim every minute of the sim day, and of course have no control over sims whom I visit.


This problem came about at the same time 'select bed' was an option.  I have never done that manually, but it happens once a sim uses a bed.


Something that came about just before the update (which I figured changes were being made on the server) is that my Sims get stuck in doorways.  (not all sims and not all the time) and it's just the main entrance ways to buildings.  They eventually snap out and will be doing or have done the commands that were issued prior to them going through the door way.



Message 31 of 87 (2,932 Views)

Re: Issue with auto-solve (fun & energy) and Free will not working

★★★★ Apprentice

I did a complete reinstall and the bug still shows up! Are the developers looking into this and/or working on it?

Message 32 of 87 (2,821 Views)

Re: Issue with auto-solve (fun & energy) and Free will not working


AFAIK it's being looked into but there's no info on when it's going to be fixed.

Good Luck


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.

Important Threads

Message 33 of 87 (2,807 Views)

Re: Issue with auto-solve (fun & energy) and Free will not working

[ Edited ]
★ Guide

Just a little "me too!!" post regarding the autonomy not working for sending sims to bed.  It worked on a new game but not on my save game (which has been going for a year).   Using the needs panel to send sims to bed, either sends them to the sofa or the hot tub (just one sim) and doesn't work for others at all.  


I need to note that I have 3 mods on the save game, which I removed to test if that helped, the issue remained.  I cannot reset the house as suggested, or I risk losing my last 2 haunting ghosts!


*added info*

When first loading the family after the update, they did go to bed at first but only in unclaimed beds, after that they could only be sent to sleep manually.

Message 34 of 87 (2,793 Views)

Sims 4: Household will not "Act on their own"

★★ Newbie

Hey Guys.


Ive have an issue with the Sims 4.


When im controlling my household, they dont act on their own if their needs is low. They dont eat or visting the bathroom when the bar is low.


The "self act" is marked in the settings menu, but they dont "Act" on their own. Isnt that a bug?


Hope you guys can help me.



Message 35 of 87 (2,771 Views)

Re: Sims 4: Household will not "Act on their own"


Hi @Chratz,


it is. merged with existing thread

Good Luck


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.

Important Threads

Message 36 of 87 (2,761 Views)

Re: Sims 4: Household will not "Act on their own"

★★ Pro

Me, too. Haven't had time to check all my households, but they do seem to be napping on furniture or in the hot tub more than sleeping in beds. 


The one exception is households with the reward bed from the Art Critic career. I have that bed in more than one household because my Art Critic's wife has a furniture store. All sims seem to choose that bed (when I use auto resolve) no matter whose bed it is. This was true before Sept. and is still the case. Maybe that's a bug. I've just assumed it had a high attraction score.

Message 37 of 87 (2,751 Views)

Zero Autonomy

[ Edited ]
★ Novice

Hi. Please read the entirety of this. So me and my Wife (2 separate computers on 2 separate accounts) both have the same problem.

I'll explain a fully as I can.
So I built a house (on the Gallery as "Modern Luxury Mansion 2.0")...I did the House itself, the Kitchen, the teen bedroom on 2nd floor and all of the outside...My Wife designed all the other rooms and we used the Gallery as a way to coop build this House.
She made a family called Beattie, as did I)

We were stuck with Zero Autonomy. (Autonomy was set to full in options)
Couldn't figure out why, trawled the forums and internet in general to find an answer, which I tried every answer going.

Deleted local thumb package thing from the folder in my documents.
Repaired game multiple times.
Reinstalled the game multiple times.
Evicted family, bulldozed lot, put lot back on and family back in...problem remained.
Started new game 3 times.

The only thing that worked (temporarily) was starting a new game...Put the same house back in. Same family back in...worked great until.
Once I had cheated all the skills and careers back to full (we were NOT going to waste another 3 weeks maxing everything again). we started upgrading all the objects in the House.

Got 6 objects each upgraded...

The male representing myself ended up with zero autonomy...while the character representing my wife, carried on upgrading and had full autonomy...
So i made a new save and tried again...same thing happened.
My Wifes account and on her computer experienced something else...She got her careers up and skills up the same way with cheats....then went to neighbourhood view to put her b uildings back into the Newcrest neighbourhood where our 40x50 build was situated. When she returned to her house, her Sims have zero autonomy...

By zero autonomy we mean that even leaving the game on FastForwardx3 for 24 hours, they did nothing but stand there...The only need they saw to was sleep...and they fell to the floor face first and slept for 1 hour (in game) and woke up again.

They wouldn't eat as far as we could tell...It actually got to the point of 1-2% of hunger left, the bar was bright red and we said "these sims are about to die" and forced them to eat.

So we left it there...The game is unplayable in it's current form to us. This happened last week too when we came back to the game...Wife downloaded  a made house from Gallery which caused zero autonomy, and the house I built caused it too...So I made a new more spacious property...Which seems to have the same problem..But it can't be...These problems didn't exist back 6 months ago, autonomy always worked if it was turned on.

SO...I went to EA Sims 4 support and did a Live chat thing, the GM told me that it's clearly a bug and that he will put it on highest priority and escalate it as fast as possible.

He also told me to write a report here as someone might be able to assist in getting the Bug noticed by Development.

It's unplayable as I both of us. Even the Sims 1 had more autonomy than this...and it didn't even have a function for it back then.

These sims would literally die if we left them to it...

[P.S.for above] The object that seemed to bug it out for me was one of the new wood-slat wall speakers, that might of had something on the floor in front of it, or a painting hung beneath it or something else similar...

However that isn't what bugged my wife's out, she just went to the neighbourhood, put a building in, and returned to the household...

So...Any thoughts, clues, suggestions or ideas?

We don't think we can be bothered doing all that work to just have to start over every day. Seems a lot causes the Zero Autonomy bug. When it didn't 6+ months ago.

I also asked the GM to download the property from my Gallery "Modern Luxury Mansion 2.0" (my account is Aeonboom)
And told him to download the family Beattie, get all the skills, careers up full all aspirations except, deviance, food and nature complete. Then upgrade all objects in the house as it currently stands, and then he'd probably find he had zero autonomy...I suggest the same to anyone else. It's a curious thing. I just don't understand why it would bug out. I had a thought to start another new save, delete all wall speakers and try again see if it still happens, but I don't think I can be bothered with the week of Sims farse I've had.

[edit] deleting wall speakers kind of works, the only things the sims are doing though is entering house, becoming happy (because of beautifully decorated buff), so they go to play computer game(or troll teh forums), become focused, so they go to the observatory/microscope, then they go make a drink which doesn't get drunk, then dance, then repeat the same process. That's not what it was like unbugged, they'd use all sorts of objects. They were even happy with using the wall speakers and upgrading them...until this bug happened. They would paint a lot, which was nice. I like to be able to leave it running with full autonomy, it's interesting to see what they got up to, they'd do all sorts...but now they're only doing the same actions. I'm so lost with this. =S
It's like they've got amnesia...Do I need to teach them to use everything again? in the sense of real repeating things to a child so they learn for themselves. "Here easel, here's a brush"...or "here look. a swimming pool!...*push*"   *grin*

[Second edit] Wife's account still bugged with Zero Autonomy. All wall speakers removed too. So that wasn't the problem for her.
[Third edit] Wife's account now working fine, started new save, deleted all wall upgradeable's and let her play and it's stable.

Don't really need help, just posting as a report for Bug. As requested by GM.

Message 38 of 87 (2,551 Views)

Re: Issue with auto-solve (fun & energy) and Free will not working

★ Novice

I have this issue too, after a certain point my sims stop acting on their own, Auto-solve for energy seems to be linked to claiming beds as has been mentioned but I may have found at least one source of broken fun. I don't usually start with a computer for my sim but this time i did and autonomy and auto solve fun broke right away, after removing the pc  she started acting again. Hope this helps, I'd like my game to work normally again.

Message 39 of 87 (2,587 Views)

Re: Issue with auto-solve (fun & energy) and Free will not working

[ Edited ]
★★ Novice

Good catch on computer, Daugue. I might not be alone on this but I tend to try to get a computer going right from the get go.


But looks like it is the computer causing this after it is used. Everything is fixed after I removed all computers. The Slablet still works and can still be used without causing the problem. Tested up to ghostwriter machine. I only have milton word processor unlocked at the moment but my best guess is it probably just a computer use bug or something. 



Also No mods used. 



Message 40 of 87 (2,550 Views)